summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-13 13:10:59 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-13 13:10:59 +0000
commit0e603f39d5e9434f53e58f96fac08789749ee0a0 (patch)
treee28e7ca1e2ab5013a25f8215bbb6d98324a59fdb /app-arch
parentAdd mailing list announcement URL, too. (diff)
downloadgentoo-2-0e603f39d5e9434f53e58f96fac08789749ee0a0.tar.gz
gentoo-2-0e603f39d5e9434f53e58f96fac08789749ee0a0.tar.bz2
gentoo-2-0e603f39d5e9434f53e58f96fac08789749ee0a0.zip
Remove dselect support (bug #513100).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog7
-rw-r--r--app-arch/dpkg/dpkg-1.17.10-r1.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index d80694e8daff..a3f52238852a 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.282 2014/06/08 11:17:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.283 2014/06/13 13:10:59 jer Exp $
+
+*dpkg-1.17.10-r1 (13 Jun 2014)
+
+ 13 Jun 2014; Jeroen Roovers <jer@gentoo.org> +dpkg-1.17.10-r1.ebuild:
+ Remove dselect support (bug #513100).
08 Jun 2014; Jeroen Roovers <jer@gentoo.org> -dpkg-1.17.9.ebuild:
Old.
diff --git a/app-arch/dpkg/dpkg-1.17.10-r1.ebuild b/app-arch/dpkg/dpkg-1.17.10-r1.ebuild
new file mode 100644
index 000000000000..92f2957cae3d
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.17.10-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.17.10-r1.ebuild,v 1.1 2014/06/13 13:10:59 jer Exp $
+
+EAPI=5
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="+bzip2 +lzma nls test unicode +update-alternatives +zlib"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.0
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ lzma? ( app-arch/xz-utils )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ bzip2? ( app-arch/bzip2 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ >=sys-devel/gettext-0.18.2
+ )
+ test? (
+ dev-perl/DateTime-Format-DateParse
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ virtual/perl-Test-Harness
+ )
+"
+
+DOCS=( ChangeLog THANKS TODO )
+
+src_prepare() {
+ # do not expect Debian's gzip --rsyncable extension
+ epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
+
+ epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ # test fails (bug #414095)
+ sed -i utils/Makefile.am \
+ -e '/^test_cases/d;/100_update_alternatives/d' || die
+
+ use nls && strip-linguas -i po
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable nls) \
+ $(use_enable unicode) \
+ $(use_enable update-alternatives) \
+ $(use_with bzip2 bz2) \
+ $(use_with zlib) \
+ $(use_with lzma liblzma) \
+ --disable-compiler-warnings \
+ --disable-dselect \
+ --disable-silent-rules \
+ --disable-start-stop-daemon \
+ --localstatedir="${EPREFIX}"/var \
+ --without-selinux
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}