summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-01 10:02:38 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-01 10:02:38 +0000
commit576b3c10bd6e14238f7b4946bb2f57648f46e02d (patch)
tree37a9731f11d9bce97e679cfbae6661f368879104 /app-arch
parentSecurity update. (diff)
downloadgentoo-2-576b3c10bd6e14238f7b4946bb2f57648f46e02d.tar.gz
gentoo-2-576b3c10bd6e14238f7b4946bb2f57648f46e02d.tar.bz2
gentoo-2-576b3c10bd6e14238f7b4946bb2f57648f46e02d.zip
Security update.
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unzip/files/digest-unzip-5.501
-rw-r--r--app-arch/unzip/unzip-5.50.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/unzip/files/digest-unzip-5.50 b/app-arch/unzip/files/digest-unzip-5.50
new file mode 100644
index 000000000000..4bb9fb3d4363
--- /dev/null
+++ b/app-arch/unzip/files/digest-unzip-5.50
@@ -0,0 +1 @@
+MD5 798592d62e37f92571184236947122ed unzip550.tar.gz 1068662
diff --git a/app-arch/unzip/unzip-5.50.ebuild b/app-arch/unzip/unzip-5.50.ebuild
new file mode 100644
index 000000000000..7e0176fa04f1
--- /dev/null
+++ b/app-arch/unzip/unzip-5.50.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.50.ebuild,v 1.1 2002/10/01 10:02:38 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Unzipper for pkzip-compressed files"
+SRC_URI="ftp://ftp.info-zip.org/pub/infozip/src/${PN}${PV/.}.tar.gz"
+HOMEPAGE="ftp://ftp.info-zip.org/pub/infozip/UnZip.html"
+
+SLOT="0"
+LICENSE="Info-ZIP"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ cp unix/Makefile unix/Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" unix/Makefile.orig > unix/Makefile
+
+ use x86 \
+ && TARGET=linux \
+ || TARGET=linux_noasm
+
+ make -f unix/Makefile $TARGET || die
+}
+
+src_install() {
+
+ dobin unzip funzip unzipsfx unix/zipgrep
+ doman man/*.1
+ dodoc BUGS COPYING History* LICENSE README ToDo WHERE
+}