summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-05-05 19:13:37 +0000
committerJustin Lecher <jlec@gentoo.org>2014-05-05 19:13:37 +0000
commit9aeebbb7f1186139696f8f1670daed9b3559a0b6 (patch)
treedfea91052e0babd7ba019d9fa33b01d3edd34aef /app-arch
parentBump for version 2014.3, Remove older ebuilds using legacy EAPI's. (diff)
downloadgentoo-2-9aeebbb7f1186139696f8f1670daed9b3559a0b6.tar.gz
gentoo-2-9aeebbb7f1186139696f8f1670daed9b3559a0b6.tar.bz2
gentoo-2-9aeebbb7f1186139696f8f1670daed9b3559a0b6.zip
app-arch/lbzip2: Version Bump, #509436
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lbzip2/ChangeLog7
-rw-r--r--app-arch/lbzip2/lbzip2-2.5.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-arch/lbzip2/ChangeLog b/app-arch/lbzip2/ChangeLog
index 91061c9da219..92030187e3ef 100644
--- a/app-arch/lbzip2/ChangeLog
+++ b/app-arch/lbzip2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/lbzip2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.68 2014/01/27 07:14:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.69 2014/05/05 19:13:37 jlec Exp $
+
+*lbzip2-2.5 (05 May 2014)
+
+ 05 May 2014; Justin Lecher <jlec@gentoo.org> +lbzip2-2.5.ebuild:
+ Version Bump, #509436
27 Jan 2014; Justin Lecher <jlec@gentoo.org> -lbzip2-2.2-r1.ebuild,
-lbzip2-2.3.ebuild, -files/lbzip2-2.2-assertion.patch,
diff --git a/app-arch/lbzip2/lbzip2-2.5.ebuild b/app-arch/lbzip2/lbzip2-2.5.ebuild
new file mode 100644
index 000000000000..3935efb1b735
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-2.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-2.5.ebuild,v 1.1 2014/05/05 19:13:37 jlec Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Parallel bzip2 utility"
+HOMEPAGE="https://github.com/kjn/lbzip2/"
+SRC_URI="http://archive.lbzip2.org/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug symlink"
+
+RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
+DEPEND=""
+
+PATCHES=( "${FILESDIR}"/${PN}-2.3-s_isreg.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_enable debug tracing)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use symlink; then
+ dosym ${PN} /usr/bin/bzip2
+ dosym lbunzip2 /usr/bin/bunzip2
+ fi
+}