summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2002-05-31 18:55:43 +0000
committerPreston A. Elder <prez@gentoo.org>2002-05-31 18:55:43 +0000
commitce25484b552fa76a814cb1d4a9cee0ff192ae666 (patch)
tree834347deb6312244ff7dab406c587c8afd054b9e /app-arch
parentfirst relase (diff)
downloadgentoo-2-ce25484b552fa76a814cb1d4a9cee0ff192ae666.tar.gz
gentoo-2-ce25484b552fa76a814cb1d4a9cee0ff192ae666.tar.bz2
gentoo-2-ce25484b552fa76a814cb1d4a9cee0ff192ae666.zip
Added unrar-3.00-r1, that works with gcc 3.1
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unrar/ChangeLog9
-rw-r--r--app-arch/unrar/files/digest-unrar-3.00-r11
-rw-r--r--app-arch/unrar/files/unrar-3.00-rartypes.hpp25
-rw-r--r--app-arch/unrar/unrar-3.00-r1.ebuild24
4 files changed, 58 insertions, 1 deletions
diff --git a/app-arch/unrar/ChangeLog b/app-arch/unrar/ChangeLog
index 01214976ff02..51d12e144a8e 100644
--- a/app-arch/unrar/ChangeLog
+++ b/app-arch/unrar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/unrar
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/ChangeLog,v 1.2 2002/05/26 13:46:33 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/ChangeLog,v 1.3 2002/05/31 18:55:43 prez Exp $
+
+*unrar-3.00 (31 May 2002)
+
+ 31 May 2002; Preston A. Elder <prez@gentoo.org> unrar-3.00-r1.ebuild
+ files/digest-unrar-3.00-r1 files/unrar-3.00-rartypes.hpp :
+
+ Made it work with gcc 3.1
*unrar-3.00 (26 May 2002)
diff --git a/app-arch/unrar/files/digest-unrar-3.00-r1 b/app-arch/unrar/files/digest-unrar-3.00-r1
new file mode 100644
index 000000000000..79c51233eb97
--- /dev/null
+++ b/app-arch/unrar/files/digest-unrar-3.00-r1
@@ -0,0 +1 @@
+MD5 7c3b82490cbe130a40ce3fa14655605c unrarsrc.tgz 108844
diff --git a/app-arch/unrar/files/unrar-3.00-rartypes.hpp b/app-arch/unrar/files/unrar-3.00-rartypes.hpp
new file mode 100644
index 000000000000..9bc1b740e4b6
--- /dev/null
+++ b/app-arch/unrar/files/unrar-3.00-rartypes.hpp
@@ -0,0 +1,25 @@
+#ifndef _RAR_TYPES_
+#define _RAR_TYPES_
+
+typedef unsigned char byte; //8 bits
+typedef unsigned short ushort; //preferably 16 bits, but can be more
+typedef unsigned int uint; //32 bits or more
+
+typedef unsigned int uint32; //32 bits exactly
+#define PRESENT_INT32
+
+#ifdef _WIN_32
+typedef wchar_t wchar;
+#elif defined(__GNUC__)
+#if __GNUC__ < 3 || (__GNUC__ == 3 && __GNUC_MINOR__ < 1)
+typedef __wchar_t wchar;
+#else
+typedef wchar_t wchar;
+#endif
+#else
+typedef ushort wchar;
+#endif
+
+#define SHORT16(x) (sizeof(ushort)==2 ? (ushort)(x):((x)&0xffff))
+
+#endif \ No newline at end of file
diff --git a/app-arch/unrar/unrar-3.00-r1.ebuild b/app-arch/unrar/unrar-3.00-r1.ebuild
new file mode 100644
index 000000000000..6f4cb3681015
--- /dev/null
+++ b/app-arch/unrar/unrar-3.00-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-3.00-r1.ebuild,v 1.1 2002/05/31 18:55:43 prez Exp $
+
+MY_P=${PN}src
+S=${WORKDIR}
+DESCRIPTION="Uncompress rar files"
+SRC_URI="ftp://ftp.elf.stuba.sk/pub/pc/pack/${MY_P}.tgz"
+HOMEPAGE="ftp://ftp.elf.stuba.sk/pub/pc/pack"
+
+DEPEND="virtual/glibc
+ app-arch/unzip"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cp ${FILESDIR}/unrar-3.00-rartypes.hpp rartypes.hpp
+ make -f makefile.gcc || die
+}
+
+src_install() {
+ dobin unrar
+ dodoc readme.txt license.txt
+}