summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2012-10-11 08:11:12 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2012-10-11 08:11:12 +0000
commit7831143ce0e84c3a0d67ec77c56f4fbf3f4f2bbd (patch)
tree896b6f2eb81001815b3b2964c1d759407455c65f /app-backup/obnam
parentRemove sed "s:gcc:$(CC):" and "s:make:$(MAKE):" as patches gone upstream. (diff)
downloadgentoo-2-7831143ce0e84c3a0d67ec77c56f4fbf3f4f2bbd.tar.gz
gentoo-2-7831143ce0e84c3a0d67ec77c56f4fbf3f4f2bbd.tar.bz2
gentoo-2-7831143ce0e84c3a0d67ec77c56f4fbf3f4f2bbd.zip
Revbumped. Added fix for 'diff' subcommand
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'app-backup/obnam')
-rw-r--r--app-backup/obnam/ChangeLog8
-rw-r--r--app-backup/obnam/files/obnam-1.2_diff_fix.patch11
-rw-r--r--app-backup/obnam/obnam-1.2-r1.ebuild52
3 files changed, 70 insertions, 1 deletions
diff --git a/app-backup/obnam/ChangeLog b/app-backup/obnam/ChangeLog
index 6075da03329c..8f5757362b1f 100644
--- a/app-backup/obnam/ChangeLog
+++ b/app-backup/obnam/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/obnam
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/obnam/ChangeLog,v 1.5 2012/10/11 07:47:12 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/obnam/ChangeLog,v 1.6 2012/10/11 08:11:12 mschiff Exp $
+
+*obnam-1.2-r1 (11 Oct 2012)
+
+ 11 Oct 2012; Marc Schiffbauer <mschiff@gentoo.org> +obnam-1.2-r1.ebuild,
+ +files/obnam-1.2_diff_fix.patch:
+ Revbumped and added patch to fix 'diff' sub command of obnam
11 Oct 2012; Marc Schiffbauer <mschiff@gentoo.org> obnam-1.2.ebuild:
Create obnam log directory automatically. Thanks to Martin Dummer for
diff --git a/app-backup/obnam/files/obnam-1.2_diff_fix.patch b/app-backup/obnam/files/obnam-1.2_diff_fix.patch
new file mode 100644
index 000000000000..5739dd0b7e89
--- /dev/null
+++ b/app-backup/obnam/files/obnam-1.2_diff_fix.patch
@@ -0,0 +1,11 @@
+diff -urN obnam-1.2.orig/obnamlib/plugins/show_plugin.py obnam-1.2/obnamlib/plugins/show_plugin.py
+--- obnam-1.2.orig/obnamlib/plugins/show_plugin.py 2012-10-06 18:45:31.000000000 +0200
++++ obnam-1.2/obnamlib/plugins/show_plugin.py 2012-10-11 09:54:28.757951340 +0200
+@@ -234,6 +234,7 @@
+ self.show_diff_for_file(gen2, full, '+')
+ for basename in sorted(set1):
+ # This was only in gen1 - it got removed
++ full = os.path.join(dirname, basename)
+ self.show_diff_for_file(gen1, full, '-')
+
+ for subdir in subdirs:
diff --git a/app-backup/obnam/obnam-1.2-r1.ebuild b/app-backup/obnam/obnam-1.2-r1.ebuild
new file mode 100644
index 000000000000..0afaac05332e
--- /dev/null
+++ b/app-backup/obnam/obnam-1.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/obnam/obnam-1.2-r1.ebuild,v 1.1 2012/10/11 08:11:12 mschiff Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6:2.7"
+PYTHON_MODNAME="${PN}lib"
+MY_P="${PN}_${PV}.orig"
+
+inherit eutils distutils python
+
+DESCRIPTION="A backup program that supports encryption and deduplication"
+HOMEPAGE="http://liw.fi/obnam/"
+SRC_URI="http://code.liw.fi/debian/pool/main/o/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/cliapp-1.20120630
+ dev-python/larch
+ dev-python/paramiko
+ dev-python/tracing
+ >=dev-python/ttystatus-0.19
+ "
+RDEPEND="${DEPEND}"
+
+# S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}_diff_fix.patch"
+}
+
+src_install() {
+ distutils_src_install
+ rm "${D}"/usr/bin/obnam-{benchmark,viewprof}
+ rm "${D}"/usr/share/man/man1/obnam-benchmark*
+ insinto /etc
+ doins "${FILESDIR}"/obnam.conf
+ keepdir /var/log/obnam
+}
+
+pkg_postinst() {
+ if [[ $REPLACING_VERSIONS < "1.2" ]]; then
+ elog "You will need to setup a config file before running obnam for the first time."
+ elog "For details, please see the obnam(1) manual page."
+ elog "An example file has been installed as /etc/obnam.conf for your convenience."
+ fi
+}