summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-09-30 14:59:01 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-09-30 14:59:01 +0000
commite03db94bc22a7f97e4bd5cedae5cace2a4c1e75d (patch)
tree86ee243f9a2c711e0159eec641bf779f723f26bd /app-backup
parentStable on sparc (diff)
downloadgentoo-2-e03db94bc22a7f97e4bd5cedae5cace2a4c1e75d.tar.gz
gentoo-2-e03db94bc22a7f97e4bd5cedae5cace2a4c1e75d.tar.bz2
gentoo-2-e03db94bc22a7f97e4bd5cedae5cace2a4c1e75d.zip
New package which makes it easy to backup windows and *nix computers. I useit at work, and klieber and tigger^ both want to try it. Furthermore, it's in high demand on the forums and submitted in bug #80818 by chewi (James LeCuirot)
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/backuppc/ChangeLog13
-rw-r--r--app-backup/backuppc/Manifest5
-rw-r--r--app-backup/backuppc/backuppc-2.1.2.ebuild130
-rw-r--r--app-backup/backuppc/files/digest-backuppc-2.1.22
-rw-r--r--app-backup/backuppc/files/postinstall-en.txt1
-rw-r--r--app-backup/backuppc/metadata.xml9
6 files changed, 160 insertions, 0 deletions
diff --git a/app-backup/backuppc/ChangeLog b/app-backup/backuppc/ChangeLog
new file mode 100644
index 000000000000..55be8dc89c9e
--- /dev/null
+++ b/app-backup/backuppc/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-backup/backuppc
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/backuppc/ChangeLog,v 1.1 2005/09/30 14:59:01 seemant Exp $
+
+*backuppc-2.1.2 (30 Sep 2005)
+
+ 30 Sep 2005; Seemant Kulleen <seemant@gentoo.org>
+ +files/postinstall-en.txt, +metadata.xml, +backuppc-2.1.2.ebuild:
+ New package which makes it easy to backup windows and *nix computers. I
+ useit at work, and klieber and tigger^ both want to try it. Furthermore,
+ it's in high demand on the forums and submitted in bug #80818 by chewi
+ (James LeCuirot)
+
diff --git a/app-backup/backuppc/Manifest b/app-backup/backuppc/Manifest
new file mode 100644
index 000000000000..9d49e81c0246
--- /dev/null
+++ b/app-backup/backuppc/Manifest
@@ -0,0 +1,5 @@
+MD5 1d03677e13e7c9f92290395c8c4fb09f backuppc-2.1.2.ebuild 3100
+MD5 3c20dccad7b705d7e9a379e6831149f9 metadata.xml 252
+MD5 3cf4e2bb789394d6804ca70c8a7a54d2 ChangeLog 513
+MD5 0336fa906c634b8bce2e040039a2d9a9 files/postinstall-en.txt 69
+MD5 ac73cb1a93d9daee69e7bbab5e502390 files/digest-backuppc-2.1.2 143
diff --git a/app-backup/backuppc/backuppc-2.1.2.ebuild b/app-backup/backuppc/backuppc-2.1.2.ebuild
new file mode 100644
index 000000000000..7f67dd082d77
--- /dev/null
+++ b/app-backup/backuppc/backuppc-2.1.2.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/backuppc/backuppc-2.1.2.ebuild,v 1.1 2005/09/30 14:59:01 seemant Exp $
+
+inherit eutils webapp
+
+IUSE="samba doc"
+
+MY_P=BackupPC-${PV}
+PATCH_VER=0.1
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A high performance, enterprise grade backup system for backing up
+Linux, Windows, Mac OS X desktops and laptops to a server's disk. No client
+side software needed."
+HOMEPAGE="http://backuppc.sourceforge.net"
+SRC_URI="mirror://sourceforge/backuppc/${MY_P}.tar.gz
+ http://dev.gentoo.org/~seemant/distfiles/${P}-gentoo-${PATCH_VER}.tar.bz2
+ mirror://gentoo/${P}-gentoo-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="dev-perl/File-RsyncP
+ app-arch/par2cmdline
+ app-arch/gzip
+ app-arch/bzip2
+ app-arch/unzip
+ dev-perl/Archive-Zip
+ virtual/mta
+ samba? ( net-fs/samba )"
+
+PATCHDIR=${WORKDIR}/gentoo/prepatch
+
+pkg_setup() {
+ enewgroup backuppc
+ enewuser backuppc -1 /bin/false /dev/null backuppc
+
+ webapp_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+
+ EPATCH_SUFFIX="diff" epatch ${PATCHDIR}
+}
+
+src_compile() {
+ find ./ -name 'CVS' -type d | xargs rm -rf
+}
+
+src_test() {
+ einfo "Can not test"
+}
+
+src_install() {
+ local myconf
+ if use samba ; then
+ myconf="--bin-path smbclient=$(type -p smbclient)"
+ myconf="--bin-path nmblookup=$(type -p nmblookup)"
+ fi
+
+ webapp_src_preinst
+
+ dodir ${MY_HTDOCSDIR}/${PN}
+
+ ./configure.pl \
+ --batch \
+ --bin-path perl=$(type -p perl) \
+ --bin-path ptar=$(type -p tar) \
+ --bin-path rsync=$(type -p rsync) \
+ --bin-path ping=$(type -p ping) \
+ --bin-path df=$(type -p df) \
+ --bin-path ssh=$(type -p ssh) \
+ --bin-path sendmail=$(type -p sendmail) \
+ --bin-path hostname=$(type -p hostname) \
+ --bin-path gzip=$(type -p gzip) \
+ --bin-path bzip2=$(type -p bzip2) \
+ --bin-path hostname=$(type -p hostname) \
+ --hostname XXXXXX \
+ --uid-ignore \
+ --install-dir=/usr \
+ --dest-dir ${D} \
+ --html-dir ${MY_HTDOCSDIR}/image \
+ --html-dir-url /backuppc/image \
+ --cgi-dir ${MY_CGIBINDIR}/ \
+ --data-dir /var/lib/backuppc \
+ ${myconf} || die "failed the configure.pl script"
+
+ pod2man \
+ --section=8 \
+ --center="BackupPC manual" \
+ ${S}/doc/BackupPC.pod backuppc.8 || die "failed to generate man page"
+
+ doman backuppc.8
+
+ diropts -m 750
+ keepdir /var/lib/backuppc/{trash,pool,pc,log,cpool}
+
+ diropts -m 755
+ dodir /etc/backuppc
+ mv ${D}/var/lib/backuppc/conf/* ${D}/etc/backuppc
+ rmdir ${D}/var/lib/backuppc/conf
+
+ fperms 644 /etc/backuppc/config.pl
+ fperms 644 /etc/backuppc/hosts
+
+ newinitd ${S}/init.d/gentoo-backuppc backuppc
+ newconfd ${S}/init.d/gentoo-backuppc.conf backuppc
+
+ webapp_postinst_txt \
+ en ${FILESDIR}/postinstall-en.txt || die "webapp_postinst_txt"
+
+ webapp_src_install || die "webapp_src_install"
+
+ cd ${D}/etc/backuppc
+ ebegin "Patching config.pl for sane defaults"
+ patch -p0 < ${WORKDIR}/gentoo/postpatch/config.pl.diff
+ eend $?
+
+ chown -R backuppc:backuppc "${D}/var/lib/backuppc"
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ ebegin "Adjusting ownership of /var/lib/backuppc"
+ chown -R backuppc:backuppc "${ROOT}/var/lib/backuppc"
+ eend $?
+}
diff --git a/app-backup/backuppc/files/digest-backuppc-2.1.2 b/app-backup/backuppc/files/digest-backuppc-2.1.2
new file mode 100644
index 000000000000..20a380714b51
--- /dev/null
+++ b/app-backup/backuppc/files/digest-backuppc-2.1.2
@@ -0,0 +1,2 @@
+MD5 72fc0f09084f44c42ba5d22451cfe29b BackupPC-2.1.2.tar.gz 354599
+MD5 84a94fa957cef434e453c0d8350c0b46 backuppc-2.1.2-gentoo-0.1.tar.bz2 17219
diff --git a/app-backup/backuppc/files/postinstall-en.txt b/app-backup/backuppc/files/postinstall-en.txt
new file mode 100644
index 000000000000..ec1634b987e8
--- /dev/null
+++ b/app-backup/backuppc/files/postinstall-en.txt
@@ -0,0 +1 @@
+Please make sure to edit /etc/backuppc/config.pl to suit your needs.
diff --git a/app-backup/backuppc/metadata.xml b/app-backup/backuppc/metadata.xml
new file mode 100644
index 000000000000..3ee4d4e59b0e
--- /dev/null
+++ b/app-backup/backuppc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<maintainer>
+ <email>seemant@gentoo.org</email>
+ <name>Seemant Kulleen</name>
+</maintainer>
+</pkgmetadata>