summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-07-19 13:27:37 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-07-19 13:27:37 +0000
commit466b9e265fdd9baa6fd5d9ad846d8374044fe8a8 (patch)
tree70694604667c3bc74f72877a0d0ed3f598bed752 /app-cdr/cdemu
parentOld. (diff)
downloadgentoo-2-466b9e265fdd9baa6fd5d9ad846d8374044fe8a8.tar.gz
gentoo-2-466b9e265fdd9baa6fd5d9ad846d8374044fe8a8.tar.bz2
gentoo-2-466b9e265fdd9baa6fd5d9ad846d8374044fe8a8.zip
Do not use a hard-coded completion directory to fix compatibility with bash-completion-2.1-r1 (bug #477378, thanks to Michał Górny).
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-cdr/cdemu')
-rw-r--r--app-cdr/cdemu/ChangeLog9
-rw-r--r--app-cdr/cdemu/cdemu-2.1.0-r1.ebuild62
-rw-r--r--app-cdr/cdemu/files/cdemu-2.1.0-bash-completion-dir.patch13
3 files changed, 83 insertions, 1 deletions
diff --git a/app-cdr/cdemu/ChangeLog b/app-cdr/cdemu/ChangeLog
index 7110f1927798..25630f186a1a 100644
--- a/app-cdr/cdemu/ChangeLog
+++ b/app-cdr/cdemu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-cdr/cdemu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/ChangeLog,v 1.41 2013/06/29 04:07:43 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/ChangeLog,v 1.42 2013/07/19 13:27:37 tetromino Exp $
+
+*cdemu-2.1.0-r1 (19 Jul 2013)
+
+ 19 Jul 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +cdemu-2.1.0-r1.ebuild, +files/cdemu-2.1.0-bash-completion-dir.patch:
+ Do not use a hard-coded completion directory to fix compatibility with
+ bash-completion-2.1-r1 (bug #477378, thanks to Michał Górny).
29 Jun 2013; Alexandre Rostovtsev <tetromino@gentoo.org> -cdemu-1.5.0.ebuild,
-files/cdemu-1.5.0-man-paragraph.patch:
diff --git a/app-cdr/cdemu/cdemu-2.1.0-r1.ebuild b/app-cdr/cdemu/cdemu-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..a68ea5cc8f0c
--- /dev/null
+++ b/app-cdr/cdemu/cdemu-2.1.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/cdemu-2.1.0-r1.ebuild,v 1.1 2013/07/19 13:27:37 tetromino Exp $
+
+EAPI="5"
+
+CMAKE_MIN_VERSION="2.8.5"
+PYTHON_COMPAT=( python2_6 python2_7 )
+PLOCALES="de fr no pl sl sv"
+
+inherit bash-completion-r1 cmake-utils eutils fdo-mime l10n python-single-r1
+
+DESCRIPTION="Command-line tool for controlling cdemu-daemon"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/cdemu-client-${PV}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="+cdemu-daemon"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ cdemu-daemon? ( app-cdr/cdemu-daemon:0/5 )"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ >=sys-devel/gettext-0.18"
+
+S=${WORKDIR}/cdemu-client-${PV}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang src/cdemu
+ epatch "${FILESDIR}/${PN}-2.1.0-bash-completion-dir.patch"
+ # build system doesn't respect LINGUAS :/
+ l10n_find_plocales_changes po "" ".po"
+ rm_po() {
+ rm po/$1.po || die
+ }
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+src_configure() {
+ DOCS="AUTHORS README"
+ local mycmakeargs=(
+ -DPOST_INSTALL_HOOKS=OFF
+ -DGENTOO_BASHCOMPDIR="$(get_bashcompdir)"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-cdr/cdemu/files/cdemu-2.1.0-bash-completion-dir.patch b/app-cdr/cdemu/files/cdemu-2.1.0-bash-completion-dir.patch
new file mode 100644
index 000000000000..5dda0e7c0ed9
--- /dev/null
+++ b/app-cdr/cdemu/files/cdemu-2.1.0-bash-completion-dir.patch
@@ -0,0 +1,13 @@
+diff --git a/cdemu-client/CMakeLists.txt b/cdemu-client/CMakeLists.txt
+index 6f33b7c..1090c0d 100644
+--- a/cdemu-client/CMakeLists.txt
++++ b/cdemu-client/CMakeLists.txt
+@@ -41,7 +41,7 @@ install (
+
+ install (
+ FILES data/cdemu-bashcomp
+- DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/bash_completion.d
++ DESTINATION ${GENTOO_BASHCOMPDIR}
+ RENAME cdemu-client
+ )
+