summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2008-08-03 21:09:18 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2008-08-03 21:09:18 +0000
commit16a3c6760e48d6f2fde0e4143d3a42ce6c74c18a (patch)
tree006f253aeef77895a9c8e098117e821608a485db /app-cdr/cdemud
parentStable on x86 wrt security bug #233383 (diff)
downloadgentoo-2-16a3c6760e48d6f2fde0e4143d3a42ce6c74c18a.tar.gz
gentoo-2-16a3c6760e48d6f2fde0e4143d3a42ce6c74c18a.tar.bz2
gentoo-2-16a3c6760e48d6f2fde0e4143d3a42ce6c74c18a.zip
1.1.0 version bump for bug 232996. Thanks to Yaroslav Isakov <yaroslav.isakov at
gmail dot com>. (Portage version: 2.1.4.4)
Diffstat (limited to 'app-cdr/cdemud')
-rw-r--r--app-cdr/cdemud/ChangeLog8
-rw-r--r--app-cdr/cdemud/cdemud-1.1.0.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/app-cdr/cdemud/ChangeLog b/app-cdr/cdemud/ChangeLog
index 1418294ff6f3..2ec1ec663797 100644
--- a/app-cdr/cdemud/ChangeLog
+++ b/app-cdr/cdemud/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-cdr/cdemud
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemud/ChangeLog,v 1.3 2008/06/26 13:28:58 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemud/ChangeLog,v 1.4 2008/08/03 21:09:18 vanquirius Exp $
+
+*cdemud-1.1.0 (03 Aug 2008)
+
+ 03 Aug 2008; Marcelo Goes <vanquirius@gentoo.org> +cdemud-1.1.0.ebuild:
+ 1.1.0 version bump for bug 232996. Thanks to Yaroslav Isakov
+ <yaroslav.isakov at gmail dot com>.
26 Jun 2008; Santiago M. Mola <coldwind@gentoo.org> cdemud-1.0.0.ebuild:
Add ~amd64 keyword wrt bug #198672
diff --git a/app-cdr/cdemud/cdemud-1.1.0.ebuild b/app-cdr/cdemud/cdemud-1.1.0.ebuild
new file mode 100644
index 000000000000..d99c9bf94604
--- /dev/null
+++ b/app-cdr/cdemud/cdemud-1.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemud/cdemud-1.1.0.ebuild,v 1.1 2008/08/03 21:09:18 vanquirius Exp $
+
+inherit eutils
+
+DESCRIPTION="Daemon of the cdemu cd image mounting suite"
+HOMEPAGE="http://www.cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/cdemu-daemon-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa"
+
+S="${WORKDIR}/cdemu-daemon-${PV}"
+
+DEPEND=">dev-libs/dbus-glib-0.6
+ >=dev-libs/libdaemon-0.10
+ >=dev-libs/libmirage-1.0.0
+ alsa? ( >=media-libs/alsa-lib-1.0.0
+ >=media-libs/libsndfile-1.0.0 )
+ dev-util/unifdef"
+RDEPEND=">dev-libs/dbus-glib-0.6
+ >=dev-libs/libdaemon-0.10
+ >=dev-libs/libmirage-1.0.0
+ alsa? ( >=media-libs/alsa-lib-1.0.0
+ >=media-libs/libsndfile-1.0.0 )
+ >=sys-fs/vhba-1.0.0
+ >=sys-fs/sysfsutils-2.1.0"
+
+src_compile() {
+ local myconf
+
+ myconf="--sysconfdir=/etc $(use_enable alsa)"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ unifdef "${FILESDIR}/${PN}.conf.d" \
+ -$(use alsa && echo D || echo U)ALSA \
+ >"${T}/${PN}"
+ doconfd "${T}/${PN}"
+ unifdef "${FILESDIR}/${PN}.init.d" \
+ -$(use alsa && echo D || echo U)ALSA \
+ >"${T}/${PN}"
+ doinitd "${T}/${PN}"
+}
+
+pkg_postinst() {
+ elog "Either cdemu group users can start"
+ elog "their own daemons or you can start"
+ elog "a systembus style daemon, adding"
+ elog "${PN} to the default runlevel by"
+ elog " # rc-update add ${PN} default"
+ elog "as root. Systembus style daemons can be configured"
+ elog "in /etc/conf.d/{PN}.conf"
+ echo
+}