summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-08-26 08:41:38 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-08-26 08:41:38 +0000
commit94463a435ac5877786248f93ffffcefd24c3eab9 (patch)
tree647234d8a99ffa603208698f905bbb2ba966f896 /app-cdr
parentAdd dep on pkgconfig for prune_libtool_files (bug #432800). (diff)
downloadgentoo-2-94463a435ac5877786248f93ffffcefd24c3eab9.tar.gz
gentoo-2-94463a435ac5877786248f93ffffcefd24c3eab9.tar.bz2
gentoo-2-94463a435ac5877786248f93ffffcefd24c3eab9.zip
fix underlinking wrt #429280
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/brasero/ChangeLog6
-rw-r--r--app-cdr/brasero/brasero-2.32.1-r1.ebuild6
-rw-r--r--app-cdr/brasero/files/brasero-2.32.1-underlinking.patch40
3 files changed, 50 insertions, 2 deletions
diff --git a/app-cdr/brasero/ChangeLog b/app-cdr/brasero/ChangeLog
index 9f1d0ab4442d..d585d73e8db7 100644
--- a/app-cdr/brasero/ChangeLog
+++ b/app-cdr/brasero/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-cdr/brasero
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/brasero/ChangeLog,v 1.143 2012/05/14 00:48:15 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/brasero/ChangeLog,v 1.144 2012/08/26 08:41:38 hasufell Exp $
+
+ 26 Aug 2012; Julian Ospald <hasufell@gentoo.org> brasero-2.32.1-r1.ebuild,
+ +files/brasero-2.32.1-underlinking.patch:
+ fix underlinking wrt #429280
*brasero-3.4.1 (14 May 2012)
diff --git a/app-cdr/brasero/brasero-2.32.1-r1.ebuild b/app-cdr/brasero/brasero-2.32.1-r1.ebuild
index c086ba11d95c..d13eb260403a 100644
--- a/app-cdr/brasero/brasero-2.32.1-r1.ebuild
+++ b/app-cdr/brasero/brasero-2.32.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/brasero/brasero-2.32.1-r1.ebuild,v 1.9 2012/05/03 07:51:48 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/brasero/brasero-2.32.1-r1.ebuild,v 1.10 2012/08/26 08:41:38 hasufell Exp $
EAPI="4"
GNOME2_LA_PUNT="yes"
@@ -26,6 +26,7 @@ COMMON_DEPEND="
>=media-libs/gst-plugins-base-0.10:0.10
>=dev-libs/libxml2-2.6:2
>=dev-libs/libunique-1:1
+ x11-libs/libICE
x11-libs/libSM
introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
libburn? (
@@ -59,6 +60,7 @@ PDEPEND="gnome-base/gvfs"
pkg_setup() {
G2CONF="${G2CONF}
+ --disable-silent-rules
--disable-scrollkeeper
--disable-caches
--disable-dependency-tracking
@@ -79,6 +81,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlinking.patch
+
# Fix link against installed libraries, bug #340767
epatch "${FILESDIR}/${PN}-2.32.0-build-plugins-against-local-library.patch"
diff --git a/app-cdr/brasero/files/brasero-2.32.1-underlinking.patch b/app-cdr/brasero/files/brasero-2.32.1-underlinking.patch
new file mode 100644
index 000000000000..c4b20580c862
--- /dev/null
+++ b/app-cdr/brasero/files/brasero-2.32.1-underlinking.patch
@@ -0,0 +1,40 @@
+Author: hasufell <hasufell@gentoo.org>
+Date: Sat Aug 4 11:21:07 2012 +0200
+
+ fix underlinking wrt #429280
+
+--- configure.in
++++ configure.in
+@@ -269,6 +269,10 @@ esac
+ AC_SUBST(BRASERO_CANBERRA_CFLAGS)
+ AC_SUBST(BRASERO_CANBERRA_LIBS)
+
++PKG_CHECK_MODULES([BRASERO_ICE], [ice])
++AC_SUBST(BRASERO_ICE_CFLAGS)
++AC_SUBST(BRASERO_ICE_LIBS)
++
+ dnl ****************Nautilus**********************************
+ # Note: the extension is built against gtk+-2.0 so we cannot build extension with gtk+-3.0
+ NAUTILUS_REQUIRED=2.22.2
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -24,7 +24,8 @@ INCLUDES = \
+ $(BRASERO_LIBUNIQUE_CFLAGS) \
+ $(BRASERO_SEARCH_CFLAGS) \
+ $(BRASERO_PL_PARSER_CFLAGS) \
+- $(BRASERO_SM_CFLAGS)
++ $(BRASERO_SM_CFLAGS) \
++ $(BRASERO_ICE_CFLAGS)
+
+ GLIB_GENMARSHAL=`pkg-config --variable=glib_genmarshal glib-2.0`
+ RECMARSHALFILES = brasero-marshal.h brasero-marshal.c
+@@ -171,7 +172,8 @@ brasero_LDADD = \
+ $(BRASERO_LIBUNIQUE_LIBS) \
+ $(BRASERO_SEARCH_LIBS) \
+ $(BRASERO_PL_PARSER_LIBS) \
+- $(BRASERO_SM_LIBS)
++ $(BRASERO_SM_LIBS) \
++ $(BRASERO_ICE_LIBS)
+
+ EXTRA_DIST = \
+ brasero-marshal.list