summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-16 14:07:18 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-16 14:07:18 +0000
commitd2fab8996ef0b596d1690918f5e3e7a92fa43a73 (patch)
tree874788b6f896b65acb992d3763d9236255dbfe31 /app-cdr
parentFix failing tests. Remove old (bug #423309). (diff)
downloadgentoo-2-d2fab8996ef0b596d1690918f5e3e7a92fa43a73.tar.gz
gentoo-2-d2fab8996ef0b596d1690918f5e3e7a92fa43a73.tar.bz2
gentoo-2-d2fab8996ef0b596d1690918f5e3e7a92fa43a73.zip
Version bump for Gnome 3.6.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/brasero/ChangeLog5
-rw-r--r--app-cdr/brasero/brasero-3.6.1.ebuild43
2 files changed, 32 insertions, 16 deletions
diff --git a/app-cdr/brasero/ChangeLog b/app-cdr/brasero/ChangeLog
index 984b2e425efe..bc942b97474d 100644
--- a/app-cdr/brasero/ChangeLog
+++ b/app-cdr/brasero/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-cdr/brasero
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/brasero/ChangeLog,v 1.146 2012/12/16 09:10:31 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/brasero/ChangeLog,v 1.147 2012/12/16 14:07:18 eva Exp $
+
+ 16 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org> brasero-3.6.1.ebuild:
+ Version bump for Gnome 3.6.
*brasero-3.6.1 (16 Dec 2012)
diff --git a/app-cdr/brasero/brasero-3.6.1.ebuild b/app-cdr/brasero/brasero-3.6.1.ebuild
index 64c2a09ae4a9..55b4bd7c2999 100644
--- a/app-cdr/brasero/brasero-3.6.1.ebuild
+++ b/app-cdr/brasero/brasero-3.6.1.ebuild
@@ -1,28 +1,36 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/brasero/brasero-3.6.1.ebuild,v 1.1 2012/12/16 09:10:31 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/brasero/brasero-3.6.1.ebuild,v 1.2 2012/12/16 14:07:18 eva Exp $
-EAPI="5"
+EAPI="4"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
DESCRIPTION="CD/DVD burning application for the GNOME desktop"
HOMEPAGE="http://projects.gnome.org/brasero/"
-LICENSE="GPL-2+ CCPL-Attribution-ShareAlike-3.0"
-SLOT="0/3.1" # subslot is 3.suffix of libbrasero-burn3
+LICENSE="GPL-2+"
+SLOT="0"
IUSE="+css +introspection +libburn mp3 nautilus packagekit playlist test tracker"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+if [[ ${PV} = 9999 ]]; then
+ IUSE="${IUSE} doc"
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
COMMON_DEPEND="
>=dev-libs/glib-2.29.14:2
- >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=x11-libs/gtk+-3:3[introspection?]
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
>=dev-libs/libxml2-2.6:2
- >=x11-libs/libnotify-0.6.1:=
+ >=x11-libs/libnotify-0.6.1
media-libs/libcanberra[gtk3]
x11-libs/libICE
@@ -30,11 +38,11 @@ COMMON_DEPEND="
introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
libburn? (
- >=dev-libs/libburn-0.4:=
- >=dev-libs/libisofs-0.6.4:= )
+ >=dev-libs/libburn-0.4
+ >=dev-libs/libisofs-0.6.4 )
nautilus? ( >=gnome-base/nautilus-2.91.90 )
- playlist? ( >=dev-libs/totem-pl-parser-2.29.1:= )
- tracker? ( >=app-misc/tracker-0.12:= )"
+ playlist? ( >=dev-libs/totem-pl-parser-2.29.1 )
+ tracker? ( >=app-misc/tracker-0.12 )"
RDEPEND="${COMMON_DEPEND}
media-libs/gst-plugins-good:1.0
x11-themes/hicolor-icon-theme
@@ -55,10 +63,15 @@ DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
test? ( app-text/docbook-xml-dtd:4.3 )"
# eautoreconf deps
-# app-text/yelp-tools
# gnome-base/gnome-common
PDEPEND="gnome-base/gvfs"
+if [[ ${PV} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ app-text/yelp-tools
+ doc? ( >=dev-util/gtk-doc-1.12 )"
+fi
+
src_configure() {
DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
G2CONF="${G2CONF}
@@ -71,8 +84,8 @@ src_configure() {
$(use_enable libburn libburnia)
$(use_enable nautilus)
$(use_enable playlist)
- $(use_enable tracker search)
- ITSTOOL=$(type -P true)"
+ $(use_enable tracker search)"
+ [[ ${PV} != 9999 ]] && G2CONF="${G2CONF} ITSTOOL=$(type -P true)"
gnome2_src_configure
}
@@ -82,5 +95,5 @@ pkg_postinst() {
echo
elog "If ${PN} doesn't handle some music or video format, please check"
- elog "your USE flags on media-plugins/gst-plugins-meta:1.0"
+ elog "your USE flags on media-plugins/gst-plugins-meta"
}