summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 17:50:04 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 17:50:04 +0000
commit44e4b99eaeb332f8a9845ec1423b79fe62bb3d30 (patch)
treec05efca777275037b10766e657f2ef62e64b79fd /app-crypt/bsign/bsign-0.4.5.ebuild
parentRemove old. Version bump. Per bug #233689. (diff)
downloadgentoo-2-44e4b99eaeb332f8a9845ec1423b79fe62bb3d30.tar.gz
gentoo-2-44e4b99eaeb332f8a9845ec1423b79fe62bb3d30.tar.bz2
gentoo-2-44e4b99eaeb332f8a9845ec1423b79fe62bb3d30.zip
QA: Respect CC/CXX (bug 243536), respect CFLAGS and install the unstripped bsign
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-crypt/bsign/bsign-0.4.5.ebuild')
-rw-r--r--app-crypt/bsign/bsign-0.4.5.ebuild28
1 files changed, 22 insertions, 6 deletions
diff --git a/app-crypt/bsign/bsign-0.4.5.ebuild b/app-crypt/bsign/bsign-0.4.5.ebuild
index ca2441254105..d8974ff0a95d 100644
--- a/app-crypt/bsign/bsign-0.4.5.ebuild
+++ b/app-crypt/bsign/bsign-0.4.5.ebuild
@@ -1,20 +1,36 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bsign/bsign-0.4.5.ebuild,v 1.8 2007/10/13 17:51:36 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bsign/bsign-0.4.5.ebuild,v 1.9 2008/12/30 17:50:04 angelos Exp $
+
+inherit autotools toolchain-funcs
DESCRIPTION="embed secure hashes (SHA1) and digital signatures (GNU Privacy Guard) into files"
HOMEPAGE="http://packages.debian.org/sid/bsign"
-SRC_URI="mirror://debian/pool/main/b/bsign/${PN}_${PV}.tar.gz"
+SRC_URI="mirror://debian/pool/main/b/${PN}/${PN}_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
-DEPEND=""
-RDEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "/^CFLAGS/d" \
+ -e "/^CXXFLAGS/d" configure.in
+ eautoreconf
+}
+
+src_compile() {
+ tc-export CC CXX
+ econf
+ emake || die "emake failed"
+}
src_install() {
- dobin bsign bsign_sign bsign_verify bsign_hash bsign_check || die
+ dobin bsign_sign bsign_verify bsign_hash bsign_check || die
+ newbin o/bsign-unstripped bsign || die
doman bsign.1
+ dodoc README
}