summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-06-13 17:48:20 +0000
committerEray Aslan <eras@gentoo.org>2012-06-13 17:48:20 +0000
commit5af85a2f513d7a78836be53030f8222626db3d43 (patch)
treee9fea332b8a1dc6bf4e5476ad91a131c1ef3272c /app-crypt/heimdal
parentRemove old versions. (diff)
downloadgentoo-2-5af85a2f513d7a78836be53030f8222626db3d43.tar.gz
gentoo-2-5af85a2f513d7a78836be53030f8222626db3d43.tar.bz2
gentoo-2-5af85a2f513d7a78836be53030f8222626db3d43.zip
Add missing symbols - bug #420821
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/heimdal')
-rw-r--r--app-crypt/heimdal/ChangeLog8
-rw-r--r--app-crypt/heimdal/files/heimdal_missing_symbols.patch28
-rw-r--r--app-crypt/heimdal/heimdal-1.5.2-r1.ebuild148
3 files changed, 183 insertions, 1 deletions
diff --git a/app-crypt/heimdal/ChangeLog b/app-crypt/heimdal/ChangeLog
index 07d5c08470de..bd6fa3ecc353 100644
--- a/app-crypt/heimdal/ChangeLog
+++ b/app-crypt/heimdal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/heimdal
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.194 2012/05/31 03:25:16 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.195 2012/06/13 17:48:19 eras Exp $
+
+*heimdal-1.5.2-r1 (13 Jun 2012)
+
+ 13 Jun 2012; Eray Aslan <eras@gentoo.org> +heimdal-1.5.2-r1.ebuild,
+ +files/heimdal_missing_symbols.patch:
+ Add missing symbols - bug #420821
31 May 2012; Zac Medico <zmedico@gentoo.org> heimdal-1.5.1-r1.ebuild,
heimdal-1.5.2.ebuild:
diff --git a/app-crypt/heimdal/files/heimdal_missing_symbols.patch b/app-crypt/heimdal/files/heimdal_missing_symbols.patch
new file mode 100644
index 000000000000..aa915fb130dd
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal_missing_symbols.patch
@@ -0,0 +1,28 @@
+Add missing symbols. Cherry picked from upstream master.
+Bug #420821.
+
+--- a/lib/krb5/version-script.map 2012-01-10 21:53:51.000000000 +0000
++++ b/lib/krb5/version-script.map 2012-06-13 16:23:26.000000000 +0000
+@@ -42,6 +42,7 @@
+ krb5_auth_con_getrcache;
+ krb5_auth_con_getremoteseqnumber;
+ krb5_auth_con_getremotesubkey;
++ krb5_auth_con_getsendsubkey;
+ krb5_auth_con_init;
+ krb5_auth_con_removeflags;
+ krb5_auth_con_setaddrs;
+@@ -383,6 +384,14 @@
+ krb5_h_errno_to_heim_errno;
+ krb5_have_error_string;
+ krb5_hmac;
++ krb5_init_creds_init;
++ krb5_init_creds_set_service;
++ krb5_init_creds_set_keytab;
++ krb5_init_creds_get;
++ krb5_init_creds_set_password;
++ krb5_init_creds_free;
++ krb5_init_creds_get_creds;
++ krb5_init_creds_get_error;
+ krb5_init_context;
+ krb5_init_ets;
+ krb5_initlog;
diff --git a/app-crypt/heimdal/heimdal-1.5.2-r1.ebuild b/app-crypt/heimdal/heimdal-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..7b566688e1ea
--- /dev/null
+++ b/app-crypt/heimdal/heimdal-1.5.2-r1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-1.5.2-r1.ebuild,v 1.1 2012/06/13 17:48:19 eras Exp $
+
+EAPI=4
+# PYTHON_BDEPEND="2"
+VIRTUALX_REQUIRED="manual"
+
+inherit autotools db-use eutils multilib python toolchain-funcs virtualx flag-o-matic
+
+MY_P="${P}"
+DESCRIPTION="Kerberos 5 implementation from KTH"
+HOMEPAGE="http://www.h5l.org/"
+SRC_URI="http://www.h5l.org/dist/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="afs +berkdb caps hdb-ldap ipv6 otp +pkinit ssl static-libs threads test X"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ berkdb? ( sys-libs/db )
+ !berkdb? ( sys-libs/gdbm )
+ caps? ( sys-libs/libcap-ng )
+ >=dev-db/sqlite-3.5.7
+ >=sys-libs/e2fsprogs-libs-1.41.11
+ sys-libs/ncurses
+ sys-libs/readline
+ afs? ( net-fs/openafs )
+ hdb-ldap? ( >=net-nds/openldap-2.3.0 )
+ X? ( x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXt )
+ !!app-crypt/mit-krb5
+ !!app-crypt/mit-krb5-appl"
+
+DEPEND="${RDEPEND}
+ =dev-lang/python-2*
+ virtual/pkgconfig
+ >=sys-devel/autoconf-2.62
+ test? ( X? ( ${VIRTUALX_DEPEND} ) )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/heimdal_missing-include.patch"
+ epatch "${FILESDIR}/heimdal_db5.patch"
+ epatch "${FILESDIR}/heimdal_disable-check-iprop.patch"
+ epatch "${FILESDIR}/heimdal_link_order.patch"
+ epatch "${FILESDIR}/heimdal_missing_symbols.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # QA
+ append-flags -fno-strict-aliasing
+
+ local myconf=""
+ if use berkdb; then
+ myconf="--with-berkeley-db --with-berkeley-db-include=$(db_includedir)"
+ else
+ myconf="--without-berkeley-db"
+ fi
+ econf \
+ --enable-kcm \
+ --disable-osfc2 \
+ --enable-shared \
+ --with-libintl=/usr \
+ --with-readline=/usr \
+ --with-sqlite3=/usr \
+ --libexecdir=/usr/sbin \
+ $(use_enable afs afs-support) \
+ $(use_enable otp) \
+ $(use_enable pkinit kx509) \
+ $(use_enable pkinit pk-init) \
+ $(use_enable static-libs static) \
+ $(use_enable threads pthread-support) \
+ $(use_with caps capng) \
+ $(use_with hdb-ldap openldap /usr) \
+ $(use_with ipv6) \
+ $(use_with ssl openssl /usr) \
+ $(use_with X x) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ INSTALL_CATPAGES="no" emake DESTDIR="${D}" install
+
+ dodoc ChangeLog README NEWS TODO
+
+ # Begin client rename and install
+ for i in {telnetd,ftpd,rshd,popper}
+ do
+ mv "${D}"/usr/share/man/man8/{,k}${i}.8
+ mv "${D}"/usr/sbin/{,k}${i}
+ done
+
+ for i in {rcp,rsh,telnet,ftp,su,login,pagsh,kf}
+ do
+ mv "${D}"/usr/share/man/man1/{,k}${i}.1
+ mv "${D}"/usr/bin/{,k}${i}
+ done
+
+ mv "${D}"/usr/share/man/man5/{,k}ftpusers.5
+ mv "${D}"/usr/share/man/man5/{,k}login.access.5
+
+ newinitd "${FILESDIR}"/heimdal-kdc.initd-r1 heimdal-kdc
+ newinitd "${FILESDIR}"/heimdal-kadmind.initd-r1 heimdal-kadmind
+ newinitd "${FILESDIR}"/heimdal-kpasswdd.initd-r1 heimdal-kpasswdd
+ newinitd "${FILESDIR}"/heimdal-kcm.initd-r1 heimdal-kcm
+
+ newconfd "${FILESDIR}"/heimdal-kdc.confd heimdal-kdc
+ newconfd "${FILESDIR}"/heimdal-kadmind.confd heimdal-kadmind
+ newconfd "${FILESDIR}"/heimdal-kpasswdd.confd heimdal-kpasswdd
+ newconfd "${FILESDIR}"/heimdal-kcm.confd heimdal-kcm
+
+ insinto /etc
+ newins "${FILESDIR}"/krb5.conf krb5.conf.example
+
+ if use hdb-ldap; then
+ insinto /etc/openldap/schema
+ doins "${S}/lib/hdb/hdb.schema"
+ fi
+
+ use static-libs || prune_libtool_files
+
+ # default database dir
+ keepdir /var/heimdal
+
+ # Ugly hack for broken symlink - bug #417081
+ rm "${D}"/usr/share/man/man5/qop.5 || die
+ dosym mech.5 /usr/share/man/man5/qop.5
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libgssapi.so.2
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libgssapi.so.2
+}