summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-04 18:35:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-04 18:35:12 +0000
commitd969b942b26b65f4c2bb3ad9c4f9a3eb45ed2b21 (patch)
tree8bdc592e277da580d2f585d8d7cc0d30c41891e2 /app-crypt/pinentry
parentMarking iso-codes-3.8 ppc64 for bug 272502 (diff)
downloadgentoo-2-d969b942b26b65f4c2bb3ad9c4f9a3eb45ed2b21.tar.gz
gentoo-2-d969b942b26b65f4c2bb3ad9c4f9a3eb45ed2b21.tar.bz2
gentoo-2-d969b942b26b65f4c2bb3ad9c4f9a3eb45ed2b21.zip
Properly regenerate .moc files.
(Portage version: 13775-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/ChangeLog6
-rw-r--r--app-crypt/pinentry/files/pinentry-0.7.6-qt4-moc-fix.diff22
-rw-r--r--app-crypt/pinentry/pinentry-0.7.6.ebuild10
3 files changed, 13 insertions, 25 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index 0cc1d7ac4ee7..f8edece29ca2 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/pinentry
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.94 2009/07/04 17:42:15 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.95 2009/07/04 18:35:11 arfrever Exp $
+
+ 04 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pinentry-0.7.6.ebuild, -files/pinentry-0.7.6-qt4-moc-fix.diff:
+ Properly regenerate .moc files.
*pinentry-0.7.6 (04 Jul 2009)
diff --git a/app-crypt/pinentry/files/pinentry-0.7.6-qt4-moc-fix.diff b/app-crypt/pinentry/files/pinentry-0.7.6-qt4-moc-fix.diff
deleted file mode 100644
index d930ee6c2631..000000000000
--- a/app-crypt/pinentry/files/pinentry-0.7.6-qt4-moc-fix.diff
+++ /dev/null
@@ -1,22 +0,0 @@
---- pinentry-0.7.6/qt4/pinentrydialog.moc
-+++ pinentry-0.7.6/qt4/pinentrydialog.moc
-@@ -10,7 +10,7 @@
- #include "pinentrydialog.h"
- #if !defined(Q_MOC_OUTPUT_REVISION)
- #error "The header file 'pinentrydialog.h' doesn't include <QObject>."
--#elif Q_MOC_OUTPUT_REVISION != 59
-+#elif Q_MOC_OUTPUT_REVISION < 59
- #error "This file was generated using the moc from 4.4.1. It"
- #error "cannot be used with the include files from this version of Qt."
- #error "(The moc has changed too much.)"
---- pinentry-0.7.6/qt4/qsecurelineedit.moc
-+++ pinentry-0.7.6/qt4/qsecurelineedit.moc
-@@ -10,7 +10,7 @@
- #include "qsecurelineedit.h"
- #if !defined(Q_MOC_OUTPUT_REVISION)
- #error "The header file 'qsecurelineedit.h' doesn't include <QObject>."
--#elif Q_MOC_OUTPUT_REVISION != 59
-+#elif Q_MOC_OUTPUT_REVISION < 59
- #error "This file was generated using the moc from 4.4.1. It"
- #error "cannot be used with the include files from this version of Qt."
- #error "(The moc has changed too much.)"
diff --git a/app-crypt/pinentry/pinentry-0.7.6.ebuild b/app-crypt/pinentry/pinentry-0.7.6.ebuild
index 53da825388d8..f3d2af3ef413 100644
--- a/app-crypt/pinentry/pinentry-0.7.6.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.6.ebuild,v 1.1 2009/07/04 17:42:15 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.6.ebuild,v 1.2 2009/07/04 18:35:11 arfrever Exp $
EAPI="1"
@@ -42,7 +42,13 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${PN}-0.7.5-grab.patch"
- epatch "${FILESDIR}/${PN}-0.7.6-qt4-moc-fix.diff"
+
+ if use qt4; then
+ local file
+ for file in qt4/*.moc; do
+ /usr/bin/moc ${file/.moc/.h} > ${file} || die "moc ${file} failed"
+ done
+ fi
}
src_compile() {