summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-27 22:38:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-27 22:38:43 +0000
commit6786dcd59833bbdbc0f3b4027efe4a28f35dc291 (patch)
tree6667d322ad008576c4f53c598644920873d791ef /app-crypt
parentDelete older ebuilds. (diff)
downloadgentoo-2-6786dcd59833bbdbc0f3b4027efe4a28f35dc291.tar.gz
gentoo-2-6786dcd59833bbdbc0f3b4027efe4a28f35dc291.tar.bz2
gentoo-2-6786dcd59833bbdbc0f3b4027efe4a28f35dc291.zip
Version bump (bug #325533). Fix building with >=sys-devel/autoconf-2.64 (bug #282345).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/trousers/ChangeLog14
-rw-r--r--app-crypt/trousers/files/trousers-0.3.5-nouseradd.patch11
-rw-r--r--app-crypt/trousers/trousers-0.3.5.ebuild88
3 files changed, 111 insertions, 2 deletions
diff --git a/app-crypt/trousers/ChangeLog b/app-crypt/trousers/ChangeLog
index 7b687e8ff6bc..12a7b2f0edad 100644
--- a/app-crypt/trousers/ChangeLog
+++ b/app-crypt/trousers/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-crypt/trousers
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/ChangeLog,v 1.24 2009/09/06 22:50:29 ikelos Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/ChangeLog,v 1.25 2010/06/27 22:38:43 arfrever Exp $
+
+*trousers-0.3.5 (27 Jun 2010)
+
+ 27 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -trousers-0.3.1.ebuild, -files/trousers-0.3.1-gcc43.patch,
+ -files/trousers-0.3.1-qa.patch, -trousers-0.3.2.ebuild,
+ -trousers-0.3.2.1.ebuild, +trousers-0.3.5.ebuild,
+ +files/trousers-0.3.5-nouseradd.patch:
+ Version bump (bug #325533). Fix building with >=sys-devel/autoconf-2.64
+ (bug #282345).
*trousers-0.3.2.1-r1 (06 Sep 2009)
diff --git a/app-crypt/trousers/files/trousers-0.3.5-nouseradd.patch b/app-crypt/trousers/files/trousers-0.3.5-nouseradd.patch
new file mode 100644
index 000000000000..32114134daff
--- /dev/null
+++ b/app-crypt/trousers/files/trousers-0.3.5-nouseradd.patch
@@ -0,0 +1,11 @@
+--- dist/Makefile.am
++++ dist/Makefile.am
+@@ -6,8 +6,6 @@
+ /bin/chmod 0600 ${DESTDIR}/@sysconfdir@/tcsd.conf
+
+ install-exec-hook:
+- /usr/sbin/groupadd tss || true
+- /usr/sbin/useradd -r tss -g tss || true
+ /bin/sh -c 'if [ ! -e ${DESTDIR}/@localstatedir@/lib/tpm ];then mkdir -p ${DESTDIR}/@localstatedir@/lib/tpm; fi'
+ /bin/chown tss:tss ${DESTDIR}/@localstatedir@/lib/tpm || true
+ /bin/chmod 0700 ${DESTDIR}/@localstatedir@/lib/tpm
diff --git a/app-crypt/trousers/trousers-0.3.5.ebuild b/app-crypt/trousers/trousers-0.3.5.ebuild
new file mode 100644
index 000000000000..67364ebd4306
--- /dev/null
+++ b/app-crypt/trousers/trousers-0.3.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/trousers-0.3.5.ebuild,v 1.1 2010/06/27 22:38:43 arfrever Exp $
+
+EAPI="3"
+
+inherit autotools eutils linux-info
+
+#MY_P="${PN}-${PV%.*}-${PV##*.}"
+
+DESCRIPTION="An open-source TCG Software Stack (TSS) v1.1 implementation"
+HOMEPAGE="http://trousers.sf.net"
+SRC_URI="mirror://sourceforge/trousers/${P}.tar.gz"
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=dev-libs/openssl-0.9.7"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${P}git"
+
+pkg_setup() {
+ # Check for driver (not sure it can be an rdep, because ot depends on the
+ # version of virtual/linux-sources... Is that supported by portage?)
+ linux-info_pkg_setup
+ local tpm_kernel_version tpm_kernel_present tpm_module
+ kernel_is ge 2 6 12 && tpm_kernel_version="yes"
+ if linux_config_exists; then
+ linux_chkconfig_present TCG_TPM && tpm_kernel_present="yes"
+ else
+ ewarn "No kernel configuration could be found."
+ fi
+ has_version app-crypt/tpm-emulator && tpm_module="yes"
+ if [[ -n "${tpm_kernel_present}" ]]; then
+ einfo "Good, you seem to have in-kernel TPM support."
+ elif [[ -n "${tpm_module}" ]]; then
+ einfo "Good, you seem to have TPM support with the external module."
+ if [[ -n "${tpm_kernel_version}" ]]; then
+ elog
+ elog "Note that since you have a >=2.6.12 kernel, you could use"
+ elog "the in-kernel driver instead of (CONFIG_TCG_TPM)."
+ fi
+ elif [[ -n "${tpm_kernel_version}" ]]; then
+ eerror
+ eerror "To use this package, you will have to activate TPM support"
+ eerror "in your kernel configuration. That's at least CONFIG_TCG_TPM,"
+ eerror "plus probably a chip specific driver (like CONFIG_TCG_ATMEL)."
+ eerror
+ else
+ eerror
+ eerror "To use this package, you should install a TPM driver."
+ eerror "You can have the following options:"
+ eerror " - install app-crypt/tpm-emulator"
+ eerror " - switch to a >=2.6.12 kernel and compile the kernel module"
+ eerror
+ fi
+
+ # New user/group for the daemon
+ enewgroup tss
+ enewuser tss -1 -1 /var/lib/tpm tss
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-nouseradd.patch"
+
+ sed -e "s/ -Werror//" -i configure.in
+ eautoreconf
+}
+
+src_install() {
+ keepdir /var/lib/tpm
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NICETOHAVES README TODO
+ use doc && dodoc doc/*
+ newinitd "${FILESDIR}/tcsd.initd" tcsd
+ newconfd "${FILESDIR}/tcsd.confd" tcsd
+}
+
+pkg_postinst() {
+ elog "If you have problems starting tcsd, please check permissions and"
+ elog "ownership on /dev/tpm* and ~tss/system.data"
+}