summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-07-04 17:41:29 +0000
committerRick Farina <zerochaos@gentoo.org>2012-07-04 17:41:29 +0000
commitaccd6d68306d51b987ec4e5400336123e14974c2 (patch)
tree8987cc67b2e2ee04469a4d3b6d62d80c695f74d1 /app-crypt
parentFix issues reported in bug #424503. (diff)
downloadgentoo-2-accd6d68306d51b987ec4e5400336123e14974c2.tar.gz
gentoo-2-accd6d68306d51b987ec4e5400336123e14974c2.tar.bz2
gentoo-2-accd6d68306d51b987ec4e5400336123e14974c2.zip
minor QA with ebuild, again
(Portage version: 2.1.11.4/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/oclhashcat-lite-bin/ChangeLog6
-rw-r--r--app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.10.ebuild24
2 files changed, 17 insertions, 13 deletions
diff --git a/app-crypt/oclhashcat-lite-bin/ChangeLog b/app-crypt/oclhashcat-lite-bin/ChangeLog
index 057e191168a2..d0a0e0a01d62 100644
--- a/app-crypt/oclhashcat-lite-bin/ChangeLog
+++ b/app-crypt/oclhashcat-lite-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/oclhashcat-lite-bin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/oclhashcat-lite-bin/ChangeLog,v 1.2 2012/07/04 02:58:19 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/oclhashcat-lite-bin/ChangeLog,v 1.3 2012/07/04 17:41:29 zerochaos Exp $
+
+ 04 Jul 2012; Rick Farina <zerochaos@gentoo.org>
+ oclhashcat-lite-bin-0.10.ebuild:
+ minor QA with ebuild, again
04 Jul 2012; Rick Farina <zerochaos@gentoo.org>
oclhashcat-lite-bin-0.10.ebuild:
diff --git a/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.10.ebuild b/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.10.ebuild
index 474e237ab340..3d4dab915cdd 100644
--- a/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.10.ebuild
+++ b/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.10.ebuild,v 1.2 2012/07/04 02:58:19 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.10.ebuild,v 1.3 2012/07/04 17:41:29 zerochaos Exp $
EAPI=4
@@ -44,12 +44,12 @@ src_install() {
rm cudaHashcat-lite32.bin || die
fi
if ! use video_cards_fglrx; then
- rm -rf kernels/4098 || die
- rm -f oclHashcat-lite*.bin || die
+ rm -r kernels/4098 || die
+ rm oclHashcat-lite*.bin || die
fi
if ! use video_cards_nvidia; then
- rm -rf kernels/4318 || die
- rm -f cudaHashcat-lite*.bin || die
+ rm -r kernels/4318 || die
+ rm cudaHashcat-lite*.bin || die
fi
#I assume this is needed but I didn't check
@@ -61,9 +61,9 @@ src_install() {
dodir /opt/bin
cat <<-EOF > "${ED}"/opt/bin/oclhashcat-lite
- #! /bin/sh
- echo "oclHashcat-lite and all related files have been installed in /opt/${PN}"
- echo "Please run one of the following binaries to use gpu accelerated hashcat:"
+ #! /bin/sh
+ echo "oclHashcat-lite and all related files have been installed in /opt/${PN}"
+ echo "Please run one of the following binaries to use gpu accelerated hashcat:"
EOF
for x in oclHashcat-lite64.bin oclHashcat-lite32.bin cudaHashcat-lite64.bin cudaHashcat-lite32.bin
@@ -88,10 +88,10 @@ src_install() {
fperms +x /opt/${PN}/${x}
cat <<-EOF > "${ED}"/opt/bin/${x}
- #! /bin/sh
- cd /opt/${PN}
- echo "Warning: ${x} is running from /opt/${PN} so be careful of relative paths."
- ./${x} "\$@"
+ #! /bin/sh
+ cd /opt/${PN}
+ echo "Warning: ${x} is running from /opt/${PN} so be careful of relative paths."
+ exec ./${x} "\$@"
EOF
fperms +x /opt/bin/${x}