summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 03:12:22 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 03:12:22 +0000
commitb99efe9c1dd3b04e09d5bb010709be3e1eaa48a6 (patch)
tree1bce9d6336d24663b26277ddf8767eda55517977 /app-crypt
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadgentoo-2-b99efe9c1dd3b04e09d5bb010709be3e1eaa48a6.tar.gz
gentoo-2-b99efe9c1dd3b04e09d5bb010709be3e1eaa48a6.tar.bz2
gentoo-2-b99efe9c1dd3b04e09d5bb010709be3e1eaa48a6.zip
Changed src_install () to src_install()
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/gnupg-1.0.7.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/app-crypt/gnupg/gnupg-1.0.7.ebuild b/app-crypt/gnupg/gnupg-1.0.7.ebuild
index 7de0102d4668..d4fe0b577098 100644
--- a/app-crypt/gnupg/gnupg-1.0.7.ebuild
+++ b/app-crypt/gnupg/gnupg-1.0.7.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.0.7.ebuild,v 1.13 2002/10/17 12:57:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.0.7.ebuild,v 1.14 2002/11/30 03:12:22 vapier Exp $
-IUSE="nls"
-
-S="${WORKDIR}/${P}"
DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
HOMEPAGE="http://www.gnupg.org/"
SRC_URI="ftp://ftp.gnupg.org/pub/gcrypt/gnupg/${P}.tar.gz"
@@ -12,10 +9,10 @@ SRC_URI="ftp://ftp.gnupg.org/pub/gcrypt/gnupg/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
+IUSE="nls"
DEPEND=">=sys-libs/zlib-1.1.3"
RDEPEND="nls? ( sys-devel/gettext )"
-
src_unpack() {
unpack "${A}"
@@ -25,22 +22,19 @@ src_unpack() {
}
src_compile() {
- local myconf
+ local myconf="--enable-static-rnd=linux"
use nls || myconf="--disable-nls"
# Bug #6387, --enable-m-guard causes bus error on sparcs
if [ "${ARCH}" != "sparc" -a "${ARCH}" != "sparc64" ]; then
myconf="${myconf} --enable-m-guard"
fi
- econf \
- --enable-static-rnd=linux \
- --host="${CHOST}" \
- ${myconf} || die
+ econf ${myconf}
- emake || make || die
+ make || die
}
-src_install () {
+src_install() {
make DESTDIR="${D}" install || die
dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
dodoc README TODO VERSION