summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-23 23:43:57 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-23 23:43:57 +0000
commitdecac372aa74b108afaccd0d51a75c68f1985948 (patch)
tree53d4455662b387c14996a65d54a03aac395c51a7 /app-crypt
parentfixed issue #109 with info dir-stuff, also updated to current ebuild standard (diff)
downloadgentoo-2-decac372aa74b108afaccd0d51a75c68f1985948.tar.gz
gentoo-2-decac372aa74b108afaccd0d51a75c68f1985948.tar.bz2
gentoo-2-decac372aa74b108afaccd0d51a75c68f1985948.zip
added ebuild from Christian Rubbert, issue #174
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/mhash/files/digest-mhash-0.8.91
-rw-r--r--app-crypt/mhash/mhash-0.8.9.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/mhash/files/digest-mhash-0.8.9 b/app-crypt/mhash/files/digest-mhash-0.8.9
new file mode 100644
index 000000000000..99b963a34c98
--- /dev/null
+++ b/app-crypt/mhash/files/digest-mhash-0.8.9
@@ -0,0 +1 @@
+MD5 9e1f965298fb769f11f3507b3676edc1 mhash-0.8.9.tar.gz 229376
diff --git a/app-crypt/mhash/mhash-0.8.9.ebuild b/app-crypt/mhash/mhash-0.8.9.ebuild
new file mode 100644
index 000000000000..eb71f15ce65a
--- /dev/null
+++ b/app-crypt/mhash/mhash-0.8.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Christian Rubbert <crubb@xrc.de>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="mhash is a library providing a uniform interface to a large number of hash algorithms."
+SRC_URI="http://mhash.sourceforge.net/dl/${P}.tar.gz"
+HOMEPAGE="http://mhash.sourceforge.net/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc || die
+
+ emake || die
+}
+
+src_install () {
+
+ dodir /usr/{bin,include,lib}
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc AUTHORS COPYING INSTALL NEWS README TODO
+ docinto html
+ dodoc doc/*.html doc/*.txt doc/skid*
+}