summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-08-05 21:56:49 +0000
committerMatthias Maier <tamiko@gentoo.org>2015-08-05 21:56:49 +0000
commitd27d166ca5bf8494a18ccb1e62f79c0466761421 (patch)
tree569fa3150bf670a137f857e6c0b4d18724942c02 /app-doc
parentStable on alpha, bug 555478 (diff)
downloadgentoo-2-d27d166ca5bf8494a18ccb1e62f79c0466761421.tar.gz
gentoo-2-d27d166ca5bf8494a18ccb1e62f79c0466761421.tar.bz2
gentoo-2-d27d166ca5bf8494a18ccb1e62f79c0466761421.zip
version bump; switch to cmake - many thanks to Alex Turbov for a preliminary ebuild; drop keywords due to major build system change
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key BD3A97A3)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/ChangeLog9
-rw-r--r--app-doc/doxygen/doxygen-1.8.10.ebuild184
-rw-r--r--app-doc/doxygen/doxygen-9999.ebuild121
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.10-link_with_pthread.patch32
4 files changed, 252 insertions, 94 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index cff7db7bfc32..6fe9831e6e60 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-doc/doxygen
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.289 2015/08/02 09:40:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.290 2015/08/05 21:56:49 tamiko Exp $
+
+*doxygen-1.8.10 (05 Aug 2015)
+
+ 05 Aug 2015; Matthias Maier <tamiko@gentoo.org> +doxygen-1.8.10.ebuild,
+ +files/doxygen-1.8.10-link_with_pthread.patch, doxygen-9999.ebuild:
+ version bump; switch to cmake - many thanks to Alex Turbov for a preliminary
+ ebuild; drop keywords due to major build system change
02 Aug 2015; Pacho Ramos <pacho@gentoo.org> doxygen-1.8.9.1.ebuild:
sparc stable wrt bug #550348
diff --git a/app-doc/doxygen/doxygen-1.8.10.ebuild b/app-doc/doxygen/doxygen-1.8.10.ebuild
new file mode 100644
index 000000000000..96969352dbce
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.8.10.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.8.10.ebuild,v 1.1 2015/08/05 21:56:49 tamiko Exp $
+
+EAPI=4
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit cmake-utils eutils fdo-mime flag-o-matic python-any-r1 qt4-r2
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/doxygen/doxygen.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+ KEYWORDS="~amd64"
+ # KEYWORDS="~alpha ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+fi
+SRC_URI+=" http://dev.gentoo.org/~xarthisius/distfiles/doxywizard.png"
+
+DESCRIPTION="Documentation system for most programming languages"
+HOMEPAGE="http://www.doxygen.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="clang debug doc dot doxysearch qt4 sqlite"
+
+#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
+LANGS=(hy ar pt_BR ca zh cs de da eo es fa fi fr el hr hu id it ja ko lt mk
+nl nb pl pt ro ru sl sk sr sv tr uk vi af)
+for X in "${LANGS[@]}" ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="app-text/ghostscript-gpl
+ dev-lang/perl
+ media-libs/libpng
+ virtual/libiconv
+ clang? ( sys-devel/clang )
+ doc? ( app-text/texlive[extra] )
+ dot? (
+ media-gfx/graphviz
+ media-libs/freetype
+ )
+ doxysearch? ( =dev-libs/xapian-1.2* )
+ qt4? ( dev-qt/qtgui:4 )
+ sqlite? ( dev-db/sqlite:3 )
+ "
+
+DEPEND="sys-apps/sed
+ sys-devel/flex
+ sys-devel/bison
+ doc? ( ${PYTHON_DEPS} )
+ ${RDEPEND}"
+
+# src_test() defaults to make -C testing but there is no such directory (bug #504448)
+RESTRICT="mirror test"
+EPATCH_SUFFIX="patch"
+
+get_langs() {
+ # using only user set linguas also fixes #263641
+ my_linguas=()
+ for lingua in ${LINGUAS}; do
+ if has ${lingua} "${LANGS[@]}"; then
+ case ${lingua} in
+ hy) lingua=am ;;
+ pt_BR) lingua=br ;;
+ zh*) lingua=cn ;;
+ cs) lingua=cz ;;
+ da) lingua=dk ;;
+ el*) lingua=gr ;;
+ ja*) lingua=jp ;;
+ ko) lingua=kr ;;
+ nb) lingua=no ;;
+ sl) lingua=si ;;
+ tr*) lingua=tr ;;
+ uk) lingua=ua ;;
+ af) lingua=za ;;
+ esac
+ has ${lingua} "${my_linguas[@]}" ||
+ my_linguas+=(${lingua})
+ fi
+ done
+ f_langs="${my_linguas[@]}"
+ echo ${f_langs// /;}
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Ensure we link to -liconv
+ if use elibc_FreeBSD && has_version dev-libs/libiconv || use elibc_uclibc; then
+ for pro in */*.pro.in */*/*.pro.in; do
+ echo "unix:LIBS += -liconv" >> "${pro}"
+ done
+ fi
+
+ # Call dot with -Teps instead of -Tps for EPS generation - bug #282150
+ sed -i -e '/addJob("ps"/ s/"ps"/"eps"/g' src/dot.cpp || die
+
+ # prefix search tools patch, plus OSX fixes
+ epatch "${FILESDIR}"/${PN}-1.8.9.1-empty-line-sigsegv.patch #454348
+
+ epatch "${FILESDIR}"/${P}-link_with_pthread.patch
+
+ # fix pdf doc
+ sed -i.orig -e "s:g_kowal:g kowal:" \
+ doc/maintainers.txt || die
+
+ if is-flagq "-O3" ; then
+ echo
+ ewarn "Compiling with -O3 is known to produce incorrectly"
+ ewarn "optimized code which breaks doxygen."
+ echo
+ elog "Continuing with -O2 instead ..."
+ echo
+ replace-flags "-O3" "-O2"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=YES
+ -DDOC_INSTALL_DIR="share/doc/${P}"
+ -DLANG_CODES="$(get_langs)"
+ $(cmake-utils_use clang use_libclang)
+ $(cmake-utils_use doc build_doc)
+ $(cmake-utils_use doxysearch build_search)
+ $(cmake-utils_use qt4 build_wizard)
+ $(cmake-utils_use sqlite use_sqlite3)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ # generate html and pdf documents. errors here are not considered
+ # fatal, hence the ewarn message TeX's font caching in /var/cache/fonts
+ # causes sandbox warnings, so we allow it.
+ if use doc; then
+ if ! use dot; then
+ sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
+ {Doxyfile,doc/Doxyfile} \
+ || ewarn "disabling dot failed"
+ fi
+ cd "${BUILD_DIR}" && emake docs
+ fi
+}
+
+src_install() {
+ if use qt4; then
+ doicon "${DISTDIR}/doxywizard.png"
+ make_desktop_entry doxywizard "DoxyWizard ${PV}" \
+ "/usr/share/pixmaps/doxywizard.png" \
+ "Development"
+ fi
+
+ dodoc LANGUAGE.HOWTO README.md
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ elog
+ elog "For examples and other goodies, see the source tarball. For some"
+ elog "example output, run doxygen on the doxygen source using the"
+ elog "Doxyfile provided in the top-level source dir."
+ elog
+ elog "Disabling the dot USE flag will remove the GraphViz dependency,"
+ elog "along with Doxygen's ability to generate diagrams in the docs."
+ elog "See the Doxygen homepage for additional helper tools to parse"
+ elog "more languages."
+ elog
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-doc/doxygen/doxygen-9999.ebuild b/app-doc/doxygen/doxygen-9999.ebuild
index ae0536946acd..8fcff9f259aa 100644
--- a/app-doc/doxygen/doxygen-9999.ebuild
+++ b/app-doc/doxygen/doxygen-9999.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-9999.ebuild,v 1.1 2015/05/28 07:08:17 tamiko Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-9999.ebuild,v 1.2 2015/08/05 21:56:49 tamiko Exp $
EAPI=4
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit eutils fdo-mime flag-o-matic python-any-r1 qt4-r2 toolchain-funcs
-
+inherit cmake-utils eutils fdo-mime flag-o-matic python-any-r1 qt4-r2
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="git://github.com/doxygen/doxygen.git"
@@ -23,7 +22,7 @@ HOMEPAGE="http://www.doxygen.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="clang debug doc dot doxysearch qt4 latex sqlite"
+IUSE="clang debug doc dot doxysearch qt4 sqlite"
#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
@@ -38,12 +37,12 @@ RDEPEND="app-text/ghostscript-gpl
media-libs/libpng
virtual/libiconv
clang? ( sys-devel/clang )
+ doc? ( app-text/texlive[extra] )
dot? (
media-gfx/graphviz
media-libs/freetype
)
doxysearch? ( =dev-libs/xapian-1.2* )
- latex? ( app-text/texlive[extra] )
qt4? ( dev-qt/qtgui:4 )
sqlite? ( dev-db/sqlite:3 )
"
@@ -83,29 +82,14 @@ get_langs() {
fi
done
f_langs="${my_linguas[@]}"
- echo ${f_langs// /,}
+ echo ${f_langs// /;}
}
pkg_setup() {
- tc-export CC CXX
use doc && python-any-r1_pkg_setup
}
src_prepare() {
- # use CFLAGS, CXXFLAGS, LDFLAGS
- export ECFLAGS="${CFLAGS}" ECXXFLAGS="${CXXFLAGS}" ELDFLAGS="${LDFLAGS}"
-
- sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
- -e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
- -e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
- -e "s:^\(TMAKE_CXX\s*\)=.*$:\1= $(tc-getCXX):" \
- -e "s:^\(TMAKE_LINK\s*\)=.*$:\1= $(tc-getCXX):" \
- -e "s:^\(TMAKE_LINK_SHLIB\s*\)=.*$:\1= $(tc-getCXX):" \
- -e "s:^\(TMAKE_CC\s*\)=.*$:\1= $(tc-getCC):" \
- -e "s:^\(TMAKE_AR\s*\)=.*$:\1= $(tc-getAR) cqs:" \
- tmake/lib/{{linux,gnu,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++,linux-64}/tmake.conf \
- || die
-
# Ensure we link to -liconv
if use elibc_FreeBSD && has_version dev-libs/libiconv || use elibc_uclibc; then
for pro in */*.pro.in */*/*.pro.in; do
@@ -117,16 +101,14 @@ src_prepare() {
sed -i -e '/addJob("ps"/ s/"ps"/"eps"/g' src/dot.cpp || die
# prefix search tools patch, plus OSX fixes
- epatch "${FILESDIR}"/${PN}-1.8.1-prefix-misc-alt.patch
epatch "${FILESDIR}"/${PN}-1.8.9.1-empty-line-sigsegv.patch #454348
+ epatch "${FILESDIR}"/${P}-link_with_pthread.patch
+
# fix pdf doc
sed -i.orig -e "s:g_kowal:g kowal:" \
doc/maintainers.txt || die
- sed -e "s/\$(DATE)/$(LC_ALL="C" LANG="C" date)/g" \
- -i Makefile.in || die #428280
-
if is-flagq "-O3" ; then
echo
ewarn "Compiling with -O3 is known to produce incorrectly"
@@ -139,78 +121,37 @@ src_prepare() {
}
src_configure() {
- # set ./configure options (prefix, Qt based wizard, docdir)
-
- local my_conf="--shared --enable-langs $(get_langs)"
-
- if use debug ; then
- my_conf="${my_conf} --debug"
- else
- my_conf="${my_conf} --release "
- fi
-
- use clang && my_conf="${my_conf} --with-libclang"
-
- use doxysearch && my_conf="${my_conf} --with-doxysearch"
-
- use qt4 && my_conf="${my_conf} --with-doxywizard"
-
- use sqlite && my_conf="${my_conf} --with-sqlite3"
-
- # On non GNU userland (e.g. BSD), configure script picks up make and bails
- # out because it is not GNU make, so we force the right value.
- use userland_GNU || my_conf="${my_conf} --make ${MAKE} --install install"
-
- export LINK="${QMAKE_LINK}"
- export LINK_SHLIB="${QMAKE_CXX}"
-
- ./configure --prefix "${EPREFIX}/usr" ${my_conf} \
- || die
-
- if use qt4 ; then
- pushd addon/doxywizard &> /dev/null
- eqmake4 doxywizard.pro -o Makefile.doxywizard
- popd &> /dev/null
- fi
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=YES
+ -DDOC_INSTALL_DIR="share/doc/${P}"
+ -DLANG_CODES="$(get_langs)"
+ $(cmake-utils_use clang use_libclang)
+ $(cmake-utils_use doc build_doc)
+ $(cmake-utils_use doxysearch build_search)
+ $(cmake-utils_use qt4 build_wizard)
+ $(cmake-utils_use sqlite use_sqlite3)
+ )
+
+ cmake-utils_src_configure
}
src_compile() {
+ cmake-utils_src_compile
- emake CFLAGS+="${ECFLAGS}" CXXFLAGS+="${ECXXFLAGS}" \
- LFLAGS+="${ELDFLAGS}" all
-
- # generate html and pdf (if tetex in use) documents.
- # errors here are not considered fatal, hence the ewarn message
- # TeX's font caching in /var/cache/fonts causes sandbox warnings,
- # so we allow it.
+ # generate html and pdf documents. errors here are not considered
+ # fatal, hence the ewarn message TeX's font caching in /var/cache/fonts
+ # causes sandbox warnings, so we allow it.
if use doc; then
if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \
|| ewarn "disabling dot failed"
fi
- if use latex; then
- addwrite /var/cache/fonts
- addwrite /var/cache/fontconfig
- addwrite /usr/share/texmf/fonts/pk
- addwrite /usr/share/texmf/ls-R
- make pdf || ewarn '"make pdf docs" failed.'
- else
- cp doc/Doxyfile doc/Doxyfile.orig
- cp doc/Makefile doc/Makefile.orig
- sed -i.orig -e "s/GENERATE_LATEX = YES/GENERATE_LATEX = NO/" \
- doc/Doxyfile
- sed -i.orig -e "s/@epstopdf/# @epstopdf/" \
- -e "s/@cp Makefile.latex/# @cp Makefile.latex/" \
- -e "s/@sed/# @sed/" doc/Makefile
- make docs || ewarn '"make docs" failed.'
- fi
+ cd "${BUILD_DIR}" && emake docs
fi
}
src_install() {
- emake DESTDIR="${D}" MAN1DIR=share/man/man1 install
-
if use qt4; then
doicon "${DISTDIR}/doxywizard.png"
make_desktop_entry doxywizard "DoxyWizard ${PV}" \
@@ -220,22 +161,16 @@ src_install() {
dodoc LANGUAGE.HOWTO README.md
- # pdf and html manuals
- if use doc; then
- dohtml -r html/*
- use latex && dodoc latex/doxygen_manual.pdf
- fi
+ cmake-utils_src_install
}
pkg_postinst() {
fdo-mime_desktop_database_update
elog
- elog "The USE flags qt4, doc, and latex will enable doxywizard, or"
- elog "the html and pdf documentation, respectively. For examples"
- elog "and other goodies, see the source tarball. For some example"
- elog "output, run doxygen on the doxygen source using the Doxyfile"
- elog "provided in the top-level source dir."
+ elog "For examples and other goodies, see the source tarball. For some"
+ elog "example output, run doxygen on the doxygen source using the"
+ elog "Doxyfile provided in the top-level source dir."
elog
elog "Disabling the dot USE flag will remove the GraphViz dependency,"
elog "along with Doxygen's ability to generate diagrams in the docs."
diff --git a/app-doc/doxygen/files/doxygen-1.8.10-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.8.10-link_with_pthread.patch
new file mode 100644
index 000000000000..a2ce3453c5c8
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.10-link_with_pthread.patch
@@ -0,0 +1,32 @@
+diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
+index 055aac3..b66bde7 100644
+--- a/addon/doxywizard/CMakeLists.txt
++++ b/addon/doxywizard/CMakeLists.txt
+@@ -73,6 +73,7 @@ ${doxywizard_RESOURCES_RCC}
+ )
+ target_link_libraries(doxywizard
+ ${QT_LIBRARIES}
++pthread
+ )
+
+ install(TARGETS doxywizard DESTINATION bin)
+diff --git a/addon/doxysearch/CMakeLists.txt b/addon/doxysearch/CMakeLists.txt
+index 33e01c1..165fc3e 100644
+--- a/addon/doxysearch/CMakeLists.txt
++++ b/addon/doxysearch/CMakeLists.txt
+@@ -20,6 +20,7 @@ target_link_libraries(doxyindexer
+ ${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
+ qtools
++ pthread
+ )
+
+ add_executable(doxysearch.cgi
+@@ -29,6 +30,7 @@ target_link_libraries(doxysearch.cgi
+ ${XAPIAN_LIBRARIES}
+ ${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
++ pthread
+ )
+
+ install(TARGETS doxyindexer doxysearch.cgi DESTINATION bin)