summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-08-27 17:11:49 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-08-27 17:11:49 +0000
commit14b9e025facba38b0aa437377bcdddc5bcda0d6a (patch)
tree785e59d4ad0cd727fc6b150500a830fec4986028 /app-editors/gedit-plugins
parentStable for HPPA (bug #282063). (diff)
downloadgentoo-2-14b9e025facba38b0aa437377bcdddc5bcda0d6a.tar.gz
gentoo-2-14b9e025facba38b0aa437377bcdddc5bcda0d6a.tar.bz2
gentoo-2-14b9e025facba38b0aa437377bcdddc5bcda0d6a.zip
Version bump to 2.26.3, Misc Bugfixes, translations updated
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/ChangeLog8
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-2.26.3.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/app-editors/gedit-plugins/ChangeLog b/app-editors/gedit-plugins/ChangeLog
index 07b931264333..29472b7d33fb 100644
--- a/app-editors/gedit-plugins/ChangeLog
+++ b/app-editors/gedit-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/gedit-plugins
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.4 2009/08/17 11:15:07 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.5 2009/08/27 17:11:49 mrpouet Exp $
+
+*gedit-plugins-2.26.3 (27 Aug 2009)
+
+ 27 Aug 2009; Romain Perier <mrpouet@gentoo.org>
+ +gedit-plugins-2.26.3.ebuild:
+ Version bump to 2.26.3, Misc Bugfixes, translations updated
17 Aug 2009; Rémi Cardona <remi@gentoo.org> gedit-plugins-2.26.2.ebuild:
add ~x86 keyword, fixes bug #281750
diff --git a/app-editors/gedit-plugins/gedit-plugins-2.26.3.ebuild b/app-editors/gedit-plugins/gedit-plugins-2.26.3.ebuild
new file mode 100644
index 000000000000..4fded35cac17
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-2.26.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-2.26.3.ebuild,v 1.1 2009/08/27 17:11:49 mrpouet Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Offical plugins for gedit."
+HOMEPAGE="http://live.gnome.org/GeditPlugins"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="bookmarks +bracketcompletion charmap colorpicker +drawspaces +joinlines python +session showtabbar smartspaces terminal"
+
+RDEPEND=">=x11-libs/gtk+-2.14
+ gnome-base/gconf
+ >=x11-libs/gtksourceview-2.6
+ >=app-editors/gedit-2.26.1[python]
+ >=dev-python/pygtk-2.14
+ charmap? (
+ >=gnome-extra/gucharmap-2.24.3
+ )
+ session? (
+ dev-lang/python[xml]
+ )
+ python? (
+ >=dev-python/pygtksourceview-2.2.0
+ )
+ terminal? (
+ >=x11-libs/vte-0.19.4[python]
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+DOCS="AUTHORS NEWS"
+
+pkg_setup()
+{
+ local myplugins="codecomment"
+
+ for plugin in ${IUSE/python}; do
+ if use session && [ "${plugin/+}" = "session" ]; then
+ myplugins="${myplugins},sessionsaver"
+ elif use ${plugin/+}; then
+ myplugins="${myplugins},${plugin/+}"
+ fi
+ done
+
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --with-plugins=${myplugins}
+ $(use_enable python)"
+}
+
+src_test() {
+ emake check || die "make check failed"
+}