summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-05-21 07:20:53 +0000
committerRémi Cardona <remi@gentoo.org>2008-05-21 07:20:53 +0000
commite8b7b91f55b6cf947c3e7024f899be3179fc85ad (patch)
tree5a7618eae5b0612fd97e747f8c0ece67e27ef0de /app-editors/katoob
parentStable on ppc64; bug #222995 (diff)
downloadgentoo-2-e8b7b91f55b6cf947c3e7024f899be3179fc85ad.tar.gz
gentoo-2-e8b7b91f55b6cf947c3e7024f899be3179fc85ad.tar.bz2
gentoo-2-e8b7b91f55b6cf947c3e7024f899be3179fc85ad.zip
app-editors/katoob: bump to 0.5.9.1 (which now deps on the new gtksourceviewmm)
(Portage version: 2.1.5)
Diffstat (limited to 'app-editors/katoob')
-rw-r--r--app-editors/katoob/ChangeLog9
-rw-r--r--app-editors/katoob/katoob-0.5.9.1.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/app-editors/katoob/ChangeLog b/app-editors/katoob/ChangeLog
index 585cb3452861..bec99975fb2e 100644
--- a/app-editors/katoob/ChangeLog
+++ b/app-editors/katoob/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/katoob
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/katoob/ChangeLog,v 1.20 2007/10/11 19:44:58 remi Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/katoob/ChangeLog,v 1.21 2008/05/21 07:20:53 remi Exp $
+
+*katoob-0.5.9.1 (21 May 2008)
+
+ 21 May 2008; Rémi Cardona <remi@gentoo.org> +katoob-0.5.9.1.ebuild:
+ bump to 0.5.9.1 (which now deps on the new gtksourceviewmm)
11 Oct 2007; Rémi Cardona <remi@gentoo.org> katoob-0.3.8.ebuild:
update gtksourceview deps (see bug #195366)
diff --git a/app-editors/katoob/katoob-0.5.9.1.ebuild b/app-editors/katoob/katoob-0.5.9.1.ebuild
new file mode 100644
index 000000000000..8e7633483c2a
--- /dev/null
+++ b/app-editors/katoob/katoob-0.5.9.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/katoob/katoob-0.5.9.1.ebuild,v 1.1 2008/05/21 07:20:53 remi Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A light-weight multilingual BiDi aware text editor"
+HOMEPAGE="http://foolab.org/projects/katoob"
+SRC_URI="ftp://foolab.org/pub/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bidi bzip2 cups dbus debug highlight spell"
+
+RDEPEND=">=dev-cpp/gtkmm-2.6
+ >=dev-libs/glib-2
+ spell? ( app-text/aspell )
+ bidi? ( dev-libs/fribidi )
+ cups? (
+ >=net-print/cups-1.1.23
+ >=x11-libs/pango-1 )
+ bzip2? ( app-arch/bzip2 )
+ dbus? ( dev-libs/dbus-glib )
+ highlight? ( dev-cpp/gtksourceviewmm )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.28
+ >=dev-util/pkgconfig-0.9"
+
+pkg_setup() {
+ G2CONF="$(use_enable spell aspell) \
+ $(use_enable bidi fribidi) \
+ $(use_enable cups print) \
+ $(use_enable bzip2) \
+ $(use_enable dbus) \
+ $(use_enable highlight) \
+ $(use_enable !debug release)"
+}
+
+#src_install() {
+# make DESTDIR="${D}" install || die "Installation failed"
+#
+# dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+#}