summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-08-07 17:54:48 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-08-07 17:54:48 +0000
commit979fb9aec9c1d22b48f73bee8ff1fc5437ca8d70 (patch)
treefe9c74e7c1b7dfa6d7d87b61a77a1db85538792b /app-editors/vi
parentadded ppc to keywords and adjust nasm for x86 only (diff)
downloadgentoo-2-979fb9aec9c1d22b48f73bee8ff1fc5437ca8d70.tar.gz
gentoo-2-979fb9aec9c1d22b48f73bee8ff1fc5437ca8d70.tar.bz2
gentoo-2-979fb9aec9c1d22b48f73bee8ff1fc5437ca8d70.zip
fix segfault with TERM=linux in console
Diffstat (limited to 'app-editors/vi')
-rw-r--r--app-editors/vi/ChangeLog21
-rw-r--r--app-editors/vi/files/digest-vi-3.7-r21
-rw-r--r--app-editors/vi/vi-3.7-r2.ebuild55
3 files changed, 70 insertions, 7 deletions
diff --git a/app-editors/vi/ChangeLog b/app-editors/vi/ChangeLog
index 4775f6568ce5..f183b9765a8d 100644
--- a/app-editors/vi/ChangeLog
+++ b/app-editors/vi/ChangeLog
@@ -1,21 +1,28 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vi/ChangeLog,v 1.4 2002/07/16 02:43:19 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vi/ChangeLog,v 1.5 2002/08/07 17:54:48 azarah Exp $
-vi-3.7-r1 (12 May 2002)
+*vi-3.7-r1 (06 Aug 2002)
- 15 Jul 2002; Owen Stampflee <owen@gentoo.org> :
+ 06 Aug 2002; Martin Schlemmer <azarah@gentoo.org> :
+ Change it to use the buildin termlib instead of ncurses. This should
+ fix segfaults in console with TERM=linux. It now requires /etc/termcap,
+ but I added http://www.ibiblio.org/gentoo/distfiles/termcap.bz2, and
+ will also add it to baselayout.
+
+*vi-3.7-r1 (12 May 2002)
+ 15 Jul 2002; Owen Stampflee <owen@gentoo.org> :
Added KEYWORDS.
12 May 2002; Michael Nazaroff <naz@gentoo.org> :
- Added a addpredict line to hopefully fix 3038. Which is a sandbox violation
- that seems to occur when logged in via ssh and trying to merge vi. The
- pacakge tries to access /dev/pty/s6.
+ Added a addpredict line to hopefully fix 3038. Which is a sandbox violation
+ that seems to occur when logged in via ssh and trying to merge vi. The
+ pacakge tries to access /dev/pty/s6.
-vi-3.7 (12 May 2002)
+*vi-3.7 (12 May 2002)
12 May 2002; Spider <spider@gentoo.org> :
Now that I've added the Caldera LICENSE I'm changing this one too
diff --git a/app-editors/vi/files/digest-vi-3.7-r2 b/app-editors/vi/files/digest-vi-3.7-r2
new file mode 100644
index 000000000000..7e51cfd075bf
--- /dev/null
+++ b/app-editors/vi/files/digest-vi-3.7-r2
@@ -0,0 +1 @@
+MD5 544e5014f8fe8674ec3bcedd30815582 ex-020403.tar.gz 216587
diff --git a/app-editors/vi/vi-3.7-r2.ebuild b/app-editors/vi/vi-3.7-r2.ebuild
new file mode 100644
index 000000000000..3f3c4408bf7d
--- /dev/null
+++ b/app-editors/vi/vi-3.7-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vi/vi-3.7-r2.ebuild,v 1.1 2002/08/07 17:54:48 azarah Exp $
+
+MY_P=ex-020403
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="The original VI package"
+SRC_URI="http://download.berlios.de/ex-vi/${MY_P}.tar.gz"
+HOMEPAGE="http://ex-vi.berlios.de/"
+
+LICENSE="Caldera"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="virtual/glibc sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ addpredict /dev/ptys/*
+
+ make DESTDIR=/usr \
+ TERMLIB=termlib \
+ PRESERVEDIR=/var/preserve \
+ || die "failed compilation"
+}
+
+src_install() {
+ dodir /var/preserve /usr/share/man
+ make INSTALL=/usr/bin/install \
+ DESTDIR=${D}/usr \
+ MANDIR=/share/man \
+ PRESERVEDIR=${D}/var/preserve \
+ TERMLIB=termlib \
+ install || die
+
+ dodoc Changes LICENSE README TODO
+}
+
+pkg_postinst() {
+
+ if [ "${ROOT}" = "/" ] && [ ! -f /etc/termcap ]
+ then
+ ewarn "*********************************************************"
+ ewarn " vi needs /etc/termcap, so please install the latest *"
+ ewarn " baselaout (if 1.8.1 is released yet), or get it from: *"
+ ewarn " *"
+ ewarn " http://www.ibiblio.org/gentoo/distfiles/termcap.bz2 *"
+ ewarn " *"
+ ewarn " and install it in /etc with permissions 0644. *"
+ ewarn "*********************************************************"
+ fi
+}
+