summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-27 22:22:00 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-27 22:22:00 +0000
commit3e332a62c7e50fcf435825ddb60322be03678f28 (patch)
treef63e73226d6099d94d47fb9e542889283db2f68f /app-editors/xemacs
parenttouch the libc (Manifest recommit) (diff)
downloadgentoo-2-3e332a62c7e50fcf435825ddb60322be03678f28.tar.gz
gentoo-2-3e332a62c7e50fcf435825ddb60322be03678f28.tar.bz2
gentoo-2-3e332a62c7e50fcf435825ddb60322be03678f28.zip
touch the libc
Diffstat (limited to 'app-editors/xemacs')
-rw-r--r--app-editors/xemacs/xemacs-21.4.12.ebuild30
-rw-r--r--app-editors/xemacs/xemacs-21.4.15.ebuild28
-rw-r--r--app-editors/xemacs/xemacs-21.4.9.ebuild25
3 files changed, 29 insertions, 54 deletions
diff --git a/app-editors/xemacs/xemacs-21.4.12.ebuild b/app-editors/xemacs/xemacs-21.4.12.ebuild
index 75ebbd9e27d7..96c3154dd7cf 100644
--- a/app-editors/xemacs/xemacs-21.4.12.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.12.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.12.ebuild,v 1.17 2004/06/24 22:03:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.12.ebuild,v 1.18 2004/06/27 22:21:15 vapier Exp $
inherit eutils
-IUSE="gpm postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna athena neXt Xaw3d"
-
-LICENSE="GPL-2"
-DESCRIPTION="XEmacs is a highly customizable open source text editor and application development system."
-
+DESCRIPTION="highly customizable open source text editor and application development system"
+HOMEPAGE="http://www.xemacs.org/"
SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
- http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
+ http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
-HOMEPAGE="http://www.xemacs.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc alpha amd64"
+IUSE="gpm postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna athena neXt Xaw3d"
# esound is know to cause problems in XEmacs
#esd? ( media-sound/esound )
-
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/xemacs
>=sys-libs/gdbm-1.8.0
@@ -46,20 +45,13 @@ RDEPEND="virtual/glibc
canna? ( app-i18n/canna )
!amd64? ( freewnn? ( app-i18n/freewnn ) )"
-
DEPEND="${RDEPEND}
>=sys-libs/ncurses-5.2"
-
PDEPEND="app-xemacs/efs
- app-xemacs/xemacs-base
- mule? app-xemacs/mule-base"
-
+ app-xemacs/xemacs-base
+ mule? app-xemacs/mule-base"
PROVIDE="virtual/xemacs virtual/editor"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 x86 ~ppc alpha sparc"
-
src_unpack() {
unpack ${P}.tar.gz
unpack NeXT_XEmacs.tar.gz
diff --git a/app-editors/xemacs/xemacs-21.4.15.ebuild b/app-editors/xemacs/xemacs-21.4.15.ebuild
index 291b75ea5a47..ee67b1916661 100644
--- a/app-editors/xemacs/xemacs-21.4.15.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.15.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.15.ebuild,v 1.5 2004/06/24 22:03:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.15.ebuild,v 1.6 2004/06/27 22:21:15 vapier Exp $
inherit eutils
-IUSE="gpm postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna athena neXt Xaw3d berkdb"
-
-LICENSE="GPL-2"
-DESCRIPTION="XEmacs is a highly customizable open source text editor and application development system."
-
+DESCRIPTION="highly customizable open source text editor and application development system"
+HOMEPAGE="http://www.xemacs.org/"
SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
- http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
+ http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
-HOMEPAGE="http://www.xemacs.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="gpm postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna athena neXt Xaw3d berkdb"
# esound is know to cause problems in XEmacs
#esd? ( media-sound/esound )
-
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/xemacs
berkdb? ( =sys-libs/db-1* >=sys-libs/gdbm-1.8.0 )
@@ -46,19 +45,12 @@ RDEPEND="virtual/glibc
canna? ( app-i18n/canna )
!amd64? ( freewnn? ( app-i18n/freewnn ) )"
-
DEPEND="${RDEPEND}
>=sys-libs/ncurses-5.2"
-
PDEPEND="app-xemacs/xemacs-base
- mule? app-xemacs/mule-base"
-
+ mule? app-xemacs/mule-base"
PROVIDE="virtual/xemacs virtual/editor"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~ppc ~alpha ~sparc"
-
src_unpack() {
unpack ${P}.tar.gz
unpack NeXT_XEmacs.tar.gz
diff --git a/app-editors/xemacs/xemacs-21.4.9.ebuild b/app-editors/xemacs/xemacs-21.4.9.ebuild
index c260d3ceeb79..fcca4fda2c68 100644
--- a/app-editors/xemacs/xemacs-21.4.9.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.9.ebuild
@@ -1,30 +1,28 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.9.ebuild,v 1.16 2004/06/24 22:03:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.9.ebuild,v 1.17 2004/06/27 22:21:15 vapier Exp $
inherit eutils
-IUSE="gpm esd postgres xface nas X jpeg tiff png mule"
-
# this is just TEMPORARY until we can get to the core of the problem
SANDBOX_DISABLED="1"
-LICENSE="GPL-2"
-
-DESCRIPTION="XEmacs is a highly customizable open source text editor and application development system."
EFS=1.29
BASE=1.68
MULE=1.42
-
+DESCRIPTION="highly customizable open source text editor and application development system"
+HOMEPAGE="http://www.xemacs.org/"
SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
http://ftp.xemacs.org/packages/efs-${EFS}-pkg.tar.gz
http://ftp.xemacs.org/packages/xemacs-base-${BASE}-pkg.tar.gz
mule? ( http://ftp.xemacs.org/packages/mule-base-${MULE}-pkg.tar.gz )"
-HOMEPAGE="http://www.xemacs.org"
-
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
+IUSE="gpm esd postgres xface nas X jpeg tiff png mule"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/xemacs
>=sys-libs/gdbm-1.8.0
@@ -43,17 +41,10 @@ RDEPEND="virtual/glibc
tiff? ( media-libs/tiff )
png? ( =media-libs/libpng-1.2* )
jpeg? ( media-libs/jpeg )"
-
DEPEND="${RDEPEND}
>=sys-libs/ncurses-5.2"
-
PROVIDE="virtual/xemacs virtual/editor"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc "
-
-
src_unpack() {
unpack ${P}.tar.gz