summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-08-27 07:32:49 +0000
committerTim Harder <radhermit@gentoo.org>2013-08-27 07:32:49 +0000
commit0bbc3d5f4ee1f4b71fffe7b0bb4a5980ea3cbb3a (patch)
treebd796cbbf46e62a483669380bdad3a63d95878bc /app-editors/xvile
parentVersion bump. (diff)
downloadgentoo-2-0bbc3d5f4ee1f4b71fffe7b0bb4a5980ea3cbb3a.tar.gz
gentoo-2-0bbc3d5f4ee1f4b71fffe7b0bb4a5980ea3cbb3a.tar.bz2
gentoo-2-0bbc3d5f4ee1f4b71fffe7b0bb4a5980ea3cbb3a.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-editors/xvile')
-rw-r--r--app-editors/xvile/ChangeLog9
-rw-r--r--app-editors/xvile/xvile-9.8k.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/app-editors/xvile/ChangeLog b/app-editors/xvile/ChangeLog
index 68ed20716ca9..e9e19b8ad052 100644
--- a/app-editors/xvile/ChangeLog
+++ b/app-editors/xvile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/xvile
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.32 2012/08/28 08:35:45 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.33 2013/08/27 07:32:49 radhermit Exp $
+
+*xvile-9.8k (27 Aug 2013)
+
+ 27 Aug 2013; Tim Harder <radhermit@gentoo.org> +xvile-9.8k.ebuild:
+ Version bump.
*xvile-9.8h (28 Aug 2012)
diff --git a/app-editors/xvile/xvile-9.8k.ebuild b/app-editors/xvile/xvile-9.8k.ebuild
new file mode 100644
index 000000000000..16d2f0ddfa8d
--- /dev/null
+++ b/app-editors/xvile/xvile-9.8k.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.8k.ebuild,v 1.1 2013/08/27 07:32:49 radhermit Exp $
+
+EAPI="5"
+
+inherit eutils
+
+MY_P="${PN/x/}-${PV}"
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="perl"
+
+RDEPEND="perl? ( dev-lang/perl )
+ =app-editors/vile-${PV}
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0
+ >=x11-libs/libXaw-1.0.1
+ >=x11-libs/libXpm-3.5.4.2
+ >=x11-proto/xproto-7.0.4"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/vile-9.8h-flex.patch
+}
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-x \
+ $(use_with perl)
+}
+
+src_install() {
+ dobin xvile
+ dodoc CHANGES* README doc/*.doc
+ dohtml doc/*.html
+}