summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-11-06 11:11:58 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-11-06 11:11:58 +0000
commit04530866cae445629fecab3a6d82836ed0eef6da (patch)
treefdb997dc59d5ce994727ba0b80ebe9a45b818187 /app-editors
parentStable on alpha. (diff)
downloadgentoo-2-04530866cae445629fecab3a6d82836ed0eef6da.tar.gz
gentoo-2-04530866cae445629fecab3a6d82836ed0eef6da.tar.bz2
gentoo-2-04530866cae445629fecab3a6d82836ed0eef6da.zip
version bump
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/lfhex/ChangeLog7
-rw-r--r--app-editors/lfhex/files/digest-lfhex-0.43
-rw-r--r--app-editors/lfhex/lfhex-0.4.ebuild35
3 files changed, 44 insertions, 1 deletions
diff --git a/app-editors/lfhex/ChangeLog b/app-editors/lfhex/ChangeLog
index 9759db480104..86e8e0864865 100644
--- a/app-editors/lfhex/ChangeLog
+++ b/app-editors/lfhex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/lfhex
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/ChangeLog,v 1.17 2006/10/05 21:11:05 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/ChangeLog,v 1.18 2006/11/06 11:11:58 dragonheart Exp $
+
+*lfhex-0.4 (06 Nov 2006)
+
+ 06 Nov 2006; Daniel Black <dragonheart@gentoo.org> +lfhex-0.4.ebuild:
+ version bump
05 Oct 2006; <sjl@gentoo.org> lfhex-0.3.7.2.ebuild:
stable on ppc (Bug #146103)
diff --git a/app-editors/lfhex/files/digest-lfhex-0.4 b/app-editors/lfhex/files/digest-lfhex-0.4
new file mode 100644
index 000000000000..583698bc371c
--- /dev/null
+++ b/app-editors/lfhex/files/digest-lfhex-0.4
@@ -0,0 +1,3 @@
+MD5 7c664502819cfe8bd984f3f2a683df66 lfhex-0.4.tar.gz 39180
+RMD160 a23cbe5b7f62b0ac1234c4caa54457d41671bf5c lfhex-0.4.tar.gz 39180
+SHA256 97e3f481a275671395d2b500d904474dfaaf5055b42b0f230e3ac6a2478897b0 lfhex-0.4.tar.gz 39180
diff --git a/app-editors/lfhex/lfhex-0.4.ebuild b/app-editors/lfhex/lfhex-0.4.ebuild
new file mode 100644
index 000000000000..024830647ad6
--- /dev/null
+++ b/app-editors/lfhex/lfhex-0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.4.ebuild,v 1.1 2006/11/06 11:11:58 dragonheart Exp $
+
+inherit qt4 toolchain-funcs
+
+DESCRIPTION="A fast, efficient hex-editor with support for large files and comparing binary files"
+HOMEPAGE="http://stoopidsimple.com/lfhex"
+SRC_URI="http://stoopidsimple.com/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+RDEPEND="$(qt4_min_version 4)
+ || (
+ ( >=x11-libs/libXt-1.0.0 )
+ virtual/x11 )"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ ${RDEPEND}"
+
+
+src_compile() {
+ export QTDIR=/usr QTLIBDIR=/usr/lib/qt4 QTINCLUDEDIR=/usr/include/qt4 QTPLUGINDIR=/usr/lib/qt4/plugins
+ ${QTDIR}/bin/qmake lfhex.pro || die
+ emake CXX=$(tc-getCXX) LINK=$(tc-getCXX) LFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin lfhex
+ dodoc README
+}