summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-04 20:43:19 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-04 20:43:19 +0000
commit2d16c7d845f16a789398110b6cd2d1d2e0ab3d30 (patch)
treeb3b1ae0b8209cd1f4e932354dfbc4410fab01172 /app-editors
parentStable for ia64, wrt bug #449178 (diff)
downloadgentoo-2-2d16c7d845f16a789398110b6cd2d1d2e0ab3d30.tar.gz
gentoo-2-2d16c7d845f16a789398110b6cd2d1d2e0ab3d30.tar.bz2
gentoo-2-2d16c7d845f16a789398110b6cd2d1d2e0ab3d30.zip
various cleanups, also fixes bug 450294
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/efte/ChangeLog10
-rw-r--r--app-editors/efte/efte-1.1-r1.ebuild54
-rw-r--r--app-editors/efte/files/efte-1.1-desktopfile.patch18
-rw-r--r--app-editors/efte/files/efte-1.1-flags.patch15
4 files changed, 95 insertions, 2 deletions
diff --git a/app-editors/efte/ChangeLog b/app-editors/efte/ChangeLog
index 53e9e4795782..d985a653a4c8 100644
--- a/app-editors/efte/ChangeLog
+++ b/app-editors/efte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/efte
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/ChangeLog,v 1.11 2012/05/10 14:53:07 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/ChangeLog,v 1.12 2013/01/04 20:43:19 hasufell Exp $
+
+*efte-1.1-r1 (04 Jan 2013)
+
+ 04 Jan 2013; Julian Ospald <hasufell@gentoo.org> +efte-1.1-r1.ebuild,
+ +files/efte-1.1-desktopfile.patch, +files/efte-1.1-flags.patch:
+ various cleanups, also fixes bug 450294
10 May 2012; Agostino Sarubbo <ago@gentoo.org> -efte-1.0.ebuild:
Remove old
diff --git a/app-editors/efte/efte-1.1-r1.ebuild b/app-editors/efte/efte-1.1-r1.ebuild
new file mode 100644
index 000000000000..23fb72c579ab
--- /dev/null
+++ b/app-editors/efte/efte-1.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/efte-1.1-r1.ebuild,v 1.1 2013/01/04 20:43:19 hasufell Exp $
+
+EAPI=5
+
+inherit eutils cmake-utils fdo-mime
+
+DESCRIPTION="A fast text editor supporting folding, syntax highlighting, etc."
+HOMEPAGE="http://efte.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 Artistic )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gpm X"
+
+RDEPEND="sys-libs/ncurses
+ gpm? ( sys-libs/gpm )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXdmcp
+ x11-libs/libXau
+ media-fonts/font-misc-misc
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-desktopfile.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build gpm)
+ $(cmake-utils_use_build X)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -f "${D}"/usr/share/doc/${PN}/{COPYING,Artistic}
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-editors/efte/files/efte-1.1-desktopfile.patch b/app-editors/efte/files/efte-1.1-desktopfile.patch
new file mode 100644
index 000000000000..79cfc1c0ab34
--- /dev/null
+++ b/app-editors/efte/files/efte-1.1-desktopfile.patch
@@ -0,0 +1,18 @@
+--- efte-1.1/packaging/shared/efte.desktop
++++ efte-1.1/packaging/shared/efte.desktop
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ Name=eFTE
+-Version=1.1
+ GenericName=Text Editor
+ GenericName[cz]=Textový editor
+ GenericName[de]=Texteditor
+@@ -29,7 +28,7 @@
+ Comment[sv]=Snabb, utbyggbar textredigerare för programmerare
+ MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
+ Exec=efte %f
+-Icon=efte
++Icon=efte48x48
+ Type=Application
+ Terminal=false
+ Categories=Development;TextEditor;
diff --git a/app-editors/efte/files/efte-1.1-flags.patch b/app-editors/efte/files/efte-1.1-flags.patch
new file mode 100644
index 000000000000..10c17cff322c
--- /dev/null
+++ b/app-editors/efte/files/efte-1.1-flags.patch
@@ -0,0 +1,15 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jan 4 20:17:34 UTC 2013
+Subject: respect system CXXFLAGS
+
+--- efte-1.1/src/CMakeLists.txt
++++ efte-1.1/src/CMakeLists.txt
+@@ -86,7 +86,7 @@
+ ENDIF( UNIX AND ${CMAKE_SYSTEM_NAME} MATCHES "Darwin" )
+
+ IF( CMAKE_COMPILER_IS_GNUCC )
+- SET( CMAKE_CXX_FLAGS "-pedantic -Wall -Wno-long-long -Wpointer-arith -Wconversion -Wwrite-strings -Winline -fno-rtti -fno-exceptions" )
++ SET( CMAKE_CXX_FLAGS "-pedantic -Wall -Wno-long-long -Wpointer-arith -Wconversion -Wwrite-strings -Winline -fno-rtti -fno-exceptions ${CMAKE_CXX_FLAGS}" )
+ ENDIF( CMAKE_COMPILER_IS_GNUCC )
+
+ IF( CMAKE_SYSTEM_NAME MATCHES "HP/UX" )