summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-07 14:50:30 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-07 14:50:30 +0000
commit62f93e8530d6a91e59a24425174eba7ccfe80f88 (patch)
tree9f1ae66b594c80f5d82f1cfe511bd5929e8ffeec /app-editors
parentsg3_utils already provides this (diff)
downloadgentoo-2-62f93e8530d6a91e59a24425174eba7ccfe80f88.tar.gz
gentoo-2-62f93e8530d6a91e59a24425174eba7ccfe80f88.tar.bz2
gentoo-2-62f93e8530d6a91e59a24425174eba7ccfe80f88.zip
Added utf8 patch. Closing bug #62829.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/qemacs/ChangeLog6
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.1-tty_utf8.patch37
-rw-r--r--app-editors/qemacs/qemacs-0.3.1.ebuild7
3 files changed, 46 insertions, 4 deletions
diff --git a/app-editors/qemacs/ChangeLog b/app-editors/qemacs/ChangeLog
index 9c2c6e887cf2..088d9a7d6f03 100644
--- a/app-editors/qemacs/ChangeLog
+++ b/app-editors/qemacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/qemacs
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.8 2004/09/04 16:38:14 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.9 2004/09/07 14:50:30 usata Exp $
+
+ 07 Sep 2004; Mamoru KOMACHI <usata@gentoo.org> qemacs-0.3.1.ebuild,
+ +files/qemacs-0.3.1-tty_utf8.patch:
+ Added utf8 patch. Closing bug #62829.
04 Sep 2004; David Holm <dholm@gentoo.org> qemacs-0.3.1.ebuild:
Added to ~ppc.
diff --git a/app-editors/qemacs/files/qemacs-0.3.1-tty_utf8.patch b/app-editors/qemacs/files/qemacs-0.3.1-tty_utf8.patch
new file mode 100644
index 000000000000..6ca528074975
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.3.1-tty_utf8.patch
@@ -0,0 +1,37 @@
+--- qemacs-0.3.1/tty.c 2003-04-22 00:01:42.000000000 +0200
++++ qemacs-0.3.1-tty_utf8/tty.c 2004-03-14 17:38:58.000000000 +0100
+@@ -53,7 +53,6 @@
+ /* input handling */
+ enum InputState input_state;
+ int input_param;
+- int utf8_state;
+ int utf8_index;
+ unsigned char buf[10];
+ } TTYState;
+@@ -211,15 +210,20 @@
+
+ /* charset handling */
+ if (s->charset == &charset_utf8) {
+- if (ts->utf8_state == 0) {
++
++ /* Make sure utf8 input works correctly 20040314 <damm@opensource.se> */
++
++ ts->utf8_index++;
++
++ if (utf8_length[ts->buf[0]] == ts->utf8_index) {;
+ const char *p;
+ p = ts->buf;
+ ch = utf8_decode(&p);
+- } else {
+- ts->utf8_state = utf8_length[ts->buf[0]] - 1;
+- ts->utf8_index = 0;
+- return;
+- }
++ ts->utf8_index = 0;
++ }
++ else {
++ return;
++ }
+ } else {
+ ch = ts->buf[0];
+ }
diff --git a/app-editors/qemacs/qemacs-0.3.1.ebuild b/app-editors/qemacs/qemacs-0.3.1.ebuild
index 23a5170c9b19..b016f521fc07 100644
--- a/app-editors/qemacs/qemacs-0.3.1.ebuild
+++ b/app-editors/qemacs/qemacs-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1.ebuild,v 1.11 2004/09/04 16:38:14 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1.ebuild,v 1.12 2004/09/07 14:50:30 usata Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="http://fabrice.bellard.free.fr/qemacs/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86 ~amd64 ~ppc"
-IUSE="X png"
+IUSE="X png unicode"
DEPEND="X? ( virtual/x11 )
png? ( =media-libs/libpng-1.2* )"
@@ -21,6 +21,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/qemacs-Makefile-gentoo.patch
epatch ${FILESDIR}/qemacs-${PV}-configure-gentoo.patch
+ use unicode && epatch ${FILESDIR}/${P}-tty_utf8.patch
}
src_compile() {
@@ -28,7 +29,7 @@ src_compile() {
use X && myconf="--enable-x11" || myconf="--disable-x11"
use png && myconf="${myconf} --enable-png" || myconf="${myconf} --disable-png"
econf ${myconf} || die "econf failed"
- emake || die
+ emake -j1 || die
}
src_install() {