summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Knight <tomk@gentoo.org>2013-04-06 14:40:39 +0000
committerTom Knight <tomk@gentoo.org>2013-04-06 14:40:39 +0000
commit9bb3e1246ca9fca596214b4cbe239243138ef17a (patch)
treeae8a13cec0e2ffa6bcbd6aa80784b18738243ed6 /app-editors
parentadd die to calls to python (diff)
downloadgentoo-2-9bb3e1246ca9fca596214b4cbe239243138ef17a.tar.gz
gentoo-2-9bb3e1246ca9fca596214b4cbe239243138ef17a.tar.bz2
gentoo-2-9bb3e1246ca9fca596214b4cbe239243138ef17a.zip
Added Gentoo-specific file types to ftyperc
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 5395BF49)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/joe/ChangeLog11
-rw-r--r--app-editors/joe/files/joe-3.5-ftyperc.patch43
-rw-r--r--app-editors/joe/files/joe-3.7-ftyperc.patch43
-rw-r--r--app-editors/joe/joe-3.5-r1.ebuild57
-rw-r--r--app-editors/joe/joe-3.7-r2.ebuild56
5 files changed, 208 insertions, 2 deletions
diff --git a/app-editors/joe/ChangeLog b/app-editors/joe/ChangeLog
index ac05f6bdb6a4..25fc510d98b3 100644
--- a/app-editors/joe/ChangeLog
+++ b/app-editors/joe/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/joe
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.77 2012/08/21 14:21:30 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.78 2013/04/06 14:40:39 tomk Exp $
+
+*joe-3.7-r2 (06 Apr 2013)
+*joe-3.5-r1 (06 Apr 2013)
+
+ 06 Apr 2013; Tom Knight <tomk@gentoo.org> +files/joe-3.5-ftyperc.patch,
+ +files/joe-3.7-ftyperc.patch, +joe-3.5-r1.ebuild, +joe-3.7-r2.ebuild:
+ Added Gentoo-specific file types to ftyperc
21 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> joe-3.7-r1.ebuild:
QA: restore src_compile after prefix screwup.
diff --git a/app-editors/joe/files/joe-3.5-ftyperc.patch b/app-editors/joe/files/joe-3.5-ftyperc.patch
new file mode 100644
index 000000000000..834b57690440
--- /dev/null
+++ b/app-editors/joe/files/joe-3.5-ftyperc.patch
@@ -0,0 +1,43 @@
+--- rc/ftyperc 2006-07-20 16:35:56.000000000 +0100
++++ rc/ftyperc.gentoo 2013-04-05 15:05:11.000000000 +0100
+@@ -709,3 +709,40 @@
+ *jpicorc.in
+ -syntax joerc
+
++ Gentoo files
++*.ebuild
++-autoindent
++-syntax sh
++-pound_comment
++-text_delimiters do=done:if=elif=else=fi:case=esac
++-smarthome
++-smartbacks
++-indentc 9
++-istep 1
++-tab 4
++
++*.eclass
++-autoindent
++-syntax sh
++-pound_comment
++-text_delimiters do=done:if=elif=else=fi:case=esac
++-smarthome
++-smartbacks
++-indentc 9
++-istep 1
++-tab 4
++
++*/etc/portage/*
++-syntax conf
++
++*/make.conf
++-syntax sh
++
++*/etc/conf.d/*
++-syntax conf
++
++*/etc/env.d/*
++-syntax conf
++
++*/usr/portage/profiles/*
++-syntax conf
diff --git a/app-editors/joe/files/joe-3.7-ftyperc.patch b/app-editors/joe/files/joe-3.7-ftyperc.patch
new file mode 100644
index 000000000000..e570d6b1864f
--- /dev/null
+++ b/app-editors/joe/files/joe-3.7-ftyperc.patch
@@ -0,0 +1,43 @@
+--- rc/ftyperc 2008-10-31 01:42:29.000000000 +0000
++++ rc/ftyperc.gentoo 2013-04-05 15:04:49.000000000 +0100
+@@ -753,3 +753,40 @@
+ *jpicorc.in
+ -syntax joerc
+
++ Gentoo files
++*.ebuild
++-autoindent
++-syntax sh
++-pound_comment
++-text_delimiters do=done:if=elif=else=fi:case=esac
++-smarthome
++-smartbacks
++-indentc 9
++-istep 1
++-tab 4
++
++*.eclass
++-autoindent
++-syntax sh
++-pound_comment
++-text_delimiters do=done:if=elif=else=fi:case=esac
++-smarthome
++-smartbacks
++-indentc 9
++-istep 1
++-tab 4
++
++*/etc/portage/*
++-syntax conf
++
++*/make.conf
++-syntax sh
++
++*/etc/conf.d/*
++-syntax conf
++
++*/etc/env.d/*
++-syntax conf
++
++*/usr/portage/profiles/*
++-syntax conf
diff --git a/app-editors/joe/joe-3.5-r1.ebuild b/app-editors/joe/joe-3.5-r1.ebuild
new file mode 100644
index 000000000000..c81bacabcb77
--- /dev/null
+++ b/app-editors/joe/joe-3.5-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.5-r1.ebuild,v 1.1 2013/04/06 14:40:39 tomk Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xterm"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND="xterm? ( >=x11-terms/xterm-239 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-ftyperc.patch"
+
+ cd "${S}"/rc
+
+ # Enable xterm mouse support in the rc files
+ if use xterm; then
+ for i in *rc*.in; do
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die "sed failed"
+ done
+ fi
+}
+
+src_compile() {
+ # Bug 34609 (joe 2.9.8 editor seg-faults on 'find and replace' when compiled with -Os)
+ replace-flags "-Os" "-O2"
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog HACKING HINTS LIST NEWS README TODO
+ # remove superfluous documentation, fixes bug #116861
+ rm -rf "${D}"/etc/joe/doc
+}
+
+pkg_postinst() {
+ if use xterm; then
+ elog "To enable full xterm clipboard you need to set the allowWindowOps"
+ elog "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
+ elog "This is false by default due to potential security problems on some"
+ elog "architectures (see bug #91453)."
+ fi
+}
diff --git a/app-editors/joe/joe-3.7-r2.ebuild b/app-editors/joe/joe-3.7-r2.ebuild
new file mode 100644
index 000000000000..5c060a7a585e
--- /dev/null
+++ b/app-editors/joe/joe-3.7-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.7-r2.ebuild,v 1.1 2013/04/06 14:40:39 tomk Exp $
+
+EAPI="3"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="xterm"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND="xterm? ( >=x11-terms/xterm-239 )"
+
+src_prepare() {
+ # Fix segfault, bug 283508
+ epatch "${FILESDIR}/${P}-segfault-fix.patch"
+ epatch "${FILESDIR}/${P}-sanitise-includes.patch"
+ epatch "${FILESDIR}/${P}-ftyperc.patch"
+
+ cd "${S}"/rc
+
+ # Enable xterm mouse support in the rc files
+ if use xterm; then
+ for i in *rc*.in; do
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die "sed failed"
+ done
+ fi
+}
+
+src_configure() {
+ # Bug 34609 (joe 2.9.8 editor seg-faults on 'find and replace' when compiled with -Os)
+ replace-flags "-Os" "-O2"
+
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF} || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog HACKING HINTS LIST NEWS README TODO
+}
+
+pkg_postinst() {
+ if use xterm; then
+ elog "To enable full xterm clipboard you need to set the allowWindowOps"
+ elog "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
+ elog "This is false by default due to potential security problems on some"
+ elog "architectures (see bug #91453)."
+ fi
+}