summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-03-16 20:36:53 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-03-16 20:36:53 +0000
commitb56030e4882169e629bcdc0b86eb88f199c6490c (patch)
tree479c644ab862b293e6befb3cca1387697f68dfb8 /app-editors
parentDrop old versions, permissions granted by maintainer (diff)
downloadgentoo-2-b56030e4882169e629bcdc0b86eb88f199c6490c.tar.gz
gentoo-2-b56030e4882169e629bcdc0b86eb88f199c6490c.tar.bz2
gentoo-2-b56030e4882169e629bcdc0b86eb88f199c6490c.zip
Version bump (Bug #455956 by Dave Armstrong). Fix .desktop file validation
warnings. Remove old. (Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/wxhexeditor/ChangeLog11
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.11-makefile.patch96
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.21-desktop-validation.patch17
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.21-makefile.patch107
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.21.ebuild (renamed from app-editors/wxhexeditor/wxhexeditor-0.11.ebuild)18
5 files changed, 147 insertions, 102 deletions
diff --git a/app-editors/wxhexeditor/ChangeLog b/app-editors/wxhexeditor/ChangeLog
index e4096ded8111..d44c56e80832 100644
--- a/app-editors/wxhexeditor/ChangeLog
+++ b/app-editors/wxhexeditor/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-editors/wxhexeditor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/ChangeLog,v 1.4 2013/02/05 18:38:02 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/ChangeLog,v 1.5 2013/03/16 20:36:53 dirtyepic Exp $
+
+*wxhexeditor-0.21 (16 Mar 2013)
+
+ 16 Mar 2013; Ryan Hill <dirtyepic@gentoo.org> -wxhexeditor-0.11.ebuild,
+ -files/wxhexeditor-0.11-makefile.patch, +wxhexeditor-0.21.ebuild,
+ +files/wxhexeditor-0.21-desktop-validation.patch,
+ +files/wxhexeditor-0.21-makefile.patch:
+ Version bump (Bug #455956 by Dave Armstrong). Fix .desktop file validation
+ warnings. Remove old.
05 Feb 2013; Tim Harder <radhermit@gentoo.org> metadata.xml:
Remove redundant maintainer from metadata.
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.11-makefile.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.11-makefile.patch
deleted file mode 100644
index 10180c9b2877..000000000000
--- a/app-editors/wxhexeditor/files/wxhexeditor-0.11-makefile.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-https://bugs.gentoo.org/373665
-
- use system udis86
- respect flags
- fix parallel build
-
---- a/hashlibpp/src/Makefile
-+++ b/hashlibpp/src/Makefile
-@@ -50,7 +50,7 @@ INCLUDE_PATH = /usr/include/hashlib++
- LIB_PATH = /usr/local/lib/
-
- # Compiler to use
--COMPILER = g++
-+COMPILER = ${CXX}
-
- # Global options for the compiler
- COPTIONS = -ansi -Wall -Wextra
-@@ -62,7 +62,7 @@ COPTIONS = -ansi -Wall -Wextra
- ifdef DEBUG
- COPTIONS += -g
- else
-- COPTIONS += -O3 -fomit-frame-pointer
-+ COPTIONS += ${CXXFLAGS}
- endif
-
- GCC = $(COMPILER) $(COPTIONS)
-@@ -149,7 +149,7 @@ hl_sha512wrapper.o: hl_sha512wrapper.cpp hl_sha512wrapper.h
- #-----------------------------------------------------------------------
- # Creating a static lib using ar
-
--LIB: MD5 SHA1 SHA256
-+LIB: MD5 SHA1 SHA256 SHA2EXT
- ar rs libhl++.a $(MD5) $(SHA1) $(SHA256) $(SHA2EXT)
-
- #-----------------------------------------------------------------------
---- a/makefile
-+++ b/makefile
-@@ -1,7 +1,7 @@
- WXCONFIG = wx-config
- CPP = `$(WXCONFIG) --cxx`
--CXXFLAGS= `$(WXCONFIG) --cxxflags` -Iudis86 -MMD -c ${OPTFLAGS}
--LDFLAGS = `$(WXCONFIG) --libs`
-+WXCXXFLAGS= `$(WXCONFIG) --cxxflags` -MMD -c ${OPTFLAGS}
-+WXLDFLAGS = `$(WXCONFIG) --libs` ${LDFLAGS}
- RC = `$(WXCONFIG) --rescomp`
- #RC = x86_64-w64-mingw32-windres --define WX_CPU_AMD64
- RCFLAGS = `$(WXCONFIG) --cxxflags | sed s/' '-m.*//g;`
-@@ -17,7 +17,7 @@ SOURCES= src/HexEditorGui.cpp \
- src/HexEditorCtrl/wxHexCtrl/Tag.cpp\
- src/HexEditorCtrl/HexEditorCtrlGui.cpp\
- src/HexEditorFrame.cpp
--LIBS = udis86/libudis86/.libs/libudis86.a hashlibpp/src/libhl++.a
-+LIBS = hashlibpp/src/libhl++.a
- OBJECTS=$(SOURCES:.cpp=.o)
- DEPENDS=$(OBJECTS:.o=.d)
- RESOURCES= resources/resource.rc
-@@ -39,19 +39,19 @@ all: prepare $(EXECUTABLE)
- prepare: $(LIBS) $(SOURCES)
-
- $(EXECUTABLE): $(OBJECTS) $(LIBS)
-- $(CPP) $(OBJECTS) $(LIBS) $(LDFLAGS) -o $@
-+ $(CPP) $(OBJECTS) $(LIBS) -ludis86 $(WXLDFLAGS) ${LDFLAGS} -o $@
-
- .cpp.o:
-- $(CPP) $(CXXFLAGS) $< -o $@
-+ $(CPP) $(WXCXXFLAGS) ${CXXFLAGS} $< -o $@
-
- %.o : %.rc
- $(RC) $(RCFLAGS) $< -o $@
-
--udis86/libudis86/.libs/libudis86.a:
-- echo Please make sure if libudis86 build for your host to avoid link time errors!
-- cd udis86;./autogen.sh
-- cd udis86;./configure
-- cd udis86/libudis86; $(MAKE) $(MFLAGS)
-+#udis86/libudis86/.libs/libudis86.a:
-+# echo Please make sure if libudis86 build for your host to avoid link time errors!
-+# cd udis86;./autogen.sh
-+# cd udis86;./configure
-+# cd udis86/libudis86; $(MAKE) $(MFLAGS)
-
- hashlibpp/src/libhl++.a:
- echo "Please make sure if libudis86 build for your host to avoid link time errors!"
-@@ -61,10 +61,10 @@ win: prepare $(RESOURCES) $(EXECUTABLE_WIN)
-
- #Stack override required for file comparison function...
- $(EXECUTABLE_WIN): $(OBJECTS) $(RESOURCE_OBJ)
-- $(CPP) $(OBJECTS) $(RESOURCE_OBJ) $(LIBS) $(LDFLAGS) -static-libgcc -static-libstdc++ -Wl,--stack,5242880 -o $@
-+ $(CPP) $(OBJECTS) $(RESOURCE_OBJ) $(LIBS) $(WXLDFLAGS) -static-libgcc -static-libstdc++ -Wl,--stack,5242880 ${LDFLAGS} -o $@
-
- maclink: $(OBJECTS)
-- $(CPP) $(OBJECTS) $(LIBS) $(LDFLAGS) -lexpat -o $(EXECUTABLE)
-+ $(CPP) $(OBJECTS) $(LIBS) $(WXLDFLAGS) -lexpat ${LDFLAGS} -o $(EXECUTABLE)
-
- mac: prepare maclink
- mkdir -p $(EXECUTABLE_DIR_MAC)/Contents
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.21-desktop-validation.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.21-desktop-validation.patch
new file mode 100644
index 000000000000..aa2bb39bf85a
--- /dev/null
+++ b/app-editors/wxhexeditor/files/wxhexeditor-0.21-desktop-validation.patch
@@ -0,0 +1,17 @@
+--- a/resources/wxHexEditor.desktop
++++ b/resources/wxHexEditor.desktop
+@@ -1,12 +1,11 @@
+ [Desktop Entry]
+-Version=v1.0
++Version=1.0
+ Encoding=UTF-8
+ Name=wxHexEditor
+ GenericName=wxHexEditor
+ Comment=A hex editor for huge files and devices
+ Exec=wxHexEditor
+-Icon=wxHexEditor.png
++Icon=wxHexEditor
+ Terminal=false
+ Type=Application
+-MimeType=*
+ Categories=Utility;TextEditor;
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.21-makefile.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.21-makefile.patch
new file mode 100644
index 000000000000..34efd652abbe
--- /dev/null
+++ b/app-editors/wxhexeditor/files/wxhexeditor-0.21-makefile.patch
@@ -0,0 +1,107 @@
+- respect CXXFLAGS/LDFLAGS
+- install into /usr
+- use system mhash and udis86
+
+--- a/makefile
++++ b/makefile
+@@ -1,8 +1,8 @@
+ WXCONFIG = wx-config
+ CC = `$(WXCONFIG) --cc`
+ CXX = `$(WXCONFIG) --cxx`
+-CXXFLAGS= `$(WXCONFIG) --cxxflags` -Iudis86 -Imhash/include -MMD -O2 -c ${OPTFLAGS}
+-LDFLAGS = `$(WXCONFIG) --libs`
++WXCXXFLAGS= `$(WXCONFIG) --cxxflags` -MMD -O2 -c ${OPTFLAGS}
++WXLDFLAGS = `$(WXCONFIG) --libs`
+ RC = `$(WXCONFIG) --rescomp`
+ #RC = x86_64-w64-mingw32-windres --define WX_CPU_AMD64
+ RCFLAGS = `$(WXCONFIG) --cxxflags | sed s/' '-m.*//g;`
+@@ -21,7 +21,7 @@ SOURCES= src/HexEditorGui.cpp \
+ src/HexEditorCtrl/wxHexCtrl/Tag.cpp\
+ src/HexEditorCtrl/HexEditorCtrlGui.cpp\
+ src/HexEditorFrame.cpp
+-LIBS = udis86/libudis86/.libs/libudis86.a mhash/lib/.libs/libmhash.a
++LIBS = -ludis86 -lmhash
+ OBJECTS=$(SOURCES:.cpp=.o)
+ DEPENDS=$(OBJECTS:.o=.d)
+ LANGUAGEDIRS=tr
+@@ -32,7 +32,7 @@ EXECUTABLE=wxHexEditor
+ EXECUTABLE_WIN=$(EXECUTABLE).exe
+ EXECUTABLE_DIR_MAC=$(EXECUTABLE).app
+
+-PREFIX = /usr/local
++PREFIX = /usr
+ BINDIR = $(PREFIX)/bin
+ DATADIR = $(PREFIX)/share
+ LOCALEDIR = $(DATADIR)/locale
+@@ -46,10 +46,10 @@ $(OBJECTS): $(LIBS) $(SOURCES)
+ MOBJECTS=$(LANGUAGES:.po=.mo)
+
+ $(EXECUTABLE): $(OBJECTS)
+- $(CXX) $(OBJECTS) $(LIBS) $(LDFLAGS) -lgomp -o $@
++ $(CXX) $(OBJECTS) $(LIBS) ${CXXFLAGS} $(WXLDFLAGS) ${LDFLAGS} -lgomp -o $@
+
+ .cpp.o: $(LIBS)
+- $(CXX) $(CXXFLAGS) $< -o $@
++ $(CXX) $(WXCXXFLAGS) ${CXXFLAGS} $< -o $@
+
+ %.o : %.rc
+ $(RC) $(RCFLAGS) $< -o $@
+@@ -59,23 +59,14 @@ langs: $(MOBJECTS)
+ %.mo : %.po
+ $(MSGFMT) $< -o $@
+
+-udis86/libudis86/.libs/libudis86.a:
+- cd udis86;./autogen.sh
+- cd udis86;./configure --host=$(HOST)
+- cd udis86/libudis86; $(MAKE) $(MFLAGS)
+-
+-mhash/lib/.libs/libmhash.a:
+- cd mhash; ./configure --host=$(HOST)
+- cd mhash; $(MAKE) $(MFLAGS)
+-
+ win: $(RESOURCES) $(EXECUTABLE_WIN)
+
+ #Stack override required for file comparison function...
+ $(EXECUTABLE_WIN): $(OBJECTS) $(RESOURCE_OBJ)
+- $(CXX) $(OBJECTS) $(RESOURCE_OBJ) $(LIBS) $(LDFLAGS) -static-libgcc -static-libstdc++ -Wl,--stack,32000000 -o $@
++ $(CXX) $(OBJECTS) $(RESOURCE_OBJ) $(LIBS) ${CXXFLAGS} $(WXLDFLAGS) ${LDFLAGS} -static-libgcc -static-libstdc++ -Wl,--stack,32000000 -o $@
+
+ maclink: $(OBJECTS)
+- $(CXX) $(OBJECTS) $(LIBS) $(LDFLAGS) -lexpat -lgomp -Wl,-stack_size,0x2000000 -o $(EXECUTABLE)
++ $(CXX) $(OBJECTS) $(LIBS) ${CXXFLAGS} $(WXLDFLAGS) ${LDFLAGS} -lexpat -lgomp -Wl,-stack_size,0x2000000 -o $(EXECUTABLE)
+
+ mac: maclink langs
+ mkdir -p $(EXECUTABLE_DIR_MAC)/Contents
+--- a/src/HexDialogs.cpp
++++ b/src/HexDialogs.cpp
+@@ -24,7 +24,7 @@
+ #define NANINT 0xFFFFFFFFFFFFFFFFLL
+ #include "HexDialogs.h"
+ #include <wx/progdlg.h>
+-#include "../mhash/include/mhash.h"
++#include <mhash.h>
+
+ #ifdef _OPENMP
+ #include <omp.h>
+--- a/src/HexEditor.h
++++ b/src/HexEditor.h
+@@ -25,7 +25,7 @@
+ #ifndef _wxHexEditor_h_
+ #define _wxHexEditor_h_
+
+-#include "../mhash/include/mhash.h"
++#include <mhash.h>
+
+ #include <wx/ffile.h>
+ #include <wx/clipbrd.h>
+--- a/src/HexPanels.h
++++ b/src/HexPanels.h
+@@ -27,7 +27,7 @@
+ #include "HexEditorFrame.h"
+ #include "HexEditorCtrl/HexEditorCtrl.h"
+ #include "HexEditorCtrl/wxHexCtrl/wxHexCtrl.h"
+-#include "../udis86/udis86.h"
++#include <udis86.h>
+
+ #ifdef WX_GCH
+ #include <wx_pch.h>
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.11.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.21.ebuild
index 4a966d4aef3d..80bccd2624a6 100644
--- a/app-editors/wxhexeditor/wxhexeditor-0.11.ebuild
+++ b/app-editors/wxhexeditor/wxhexeditor-0.21.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/wxhexeditor-0.11.ebuild,v 1.1 2011/08/19 04:44:27 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/wxhexeditor-0.21.ebuild,v 1.1 2013/03/16 20:36:53 dirtyepic Exp $
-EAPI="4"
+EAPI="5"
WX_GTK_VER="2.8"
inherit eutils toolchain-funcs wxwidgets
@@ -18,13 +18,21 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-libs/udis86
+DEPEND="app-crypt/mhash
+ dev-libs/udis86
x11-libs/wxGTK:2.8[X]"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_PN}"
+pkg_pretend() {
+ tc-has-openmp \
+ || die "${PN} uses OpenMP libraries. Please use an OpenMP-capable compiler."
+}
+
src_prepare() {
+ # parts sent upstream : https://sourceforge.net/p/wxhexeditor/patches/8/
epatch "${FILESDIR}"/${P}-makefile.patch
- tc-export CXX
+ # sent upstream : https://sourceforge.net/p/wxhexeditor/patches/9/
+ epatch "${FILESDIR}"/${P}-desktop-validation.patch
}