summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-04-06 22:05:15 +0000
committerUlrich Müller <ulm@gentoo.org>2008-04-06 22:05:15 +0000
commitbcb7b27ae7a70cecc9c4199df3c3ac23ae1a2473 (patch)
tree144701be48c9fd33da7f94decda7e2c8eae87052 /app-editors
parentAdd support to kde.eclass too for making PATCHES an array for proper quoting. (diff)
downloadgentoo-2-bcb7b27ae7a70cecc9c4199df3c3ac23ae1a2473.tar.gz
gentoo-2-bcb7b27ae7a70cecc9c4199df3c3ac23ae1a2473.tar.bz2
gentoo-2-bcb7b27ae7a70cecc9c4199df3c3ac23ae1a2473.zip
Add patch to support compilation with Heimdal, and change dependency back
to virtual/krb5; fixes bug 215558. (Portage version: 2.1.5_rc2)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/ChangeLog9
-rw-r--r--app-editors/emacs/emacs-22.2.ebuild5
-rw-r--r--app-editors/emacs/files/emacs-22.2-heimdal-gentoo.patch53
3 files changed, 64 insertions, 3 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 72d791bed307..b0e4b86834cf 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.235 2008/04/01 11:43:24 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.236 2008/04/06 22:05:14 ulm Exp $
+
+ 06 Apr 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/emacs-22.2-heimdal-gentoo.patch, emacs-22.2.ebuild:
+ Add patch to support compilation with Heimdal, and change dependency back
+ to virtual/krb5; fixes bug 215558. Thanks to Michael Hammer (mueli)
+ <michael@derhammer.net>, Honza Macháček <Hloupy.Honza@centrum.cz> and
+ Martin Mokrejš <mmokrejs@ribosome.natur.cuni.cz> for their help.
01 Apr 2008; Ulrich Mueller <ulm@gentoo.org> emacs-22.2.ebuild:
Explicitely depend on mit-krb5 instead of virtual/kerberos, bug 215558.
diff --git a/app-editors/emacs/emacs-22.2.ebuild b/app-editors/emacs/emacs-22.2.ebuild
index 071eeba0d648..becd979d775e 100644
--- a/app-editors/emacs/emacs-22.2.ebuild
+++ b/app-editors/emacs/emacs-22.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.2.ebuild,v 1.3 2008/04/01 11:43:24 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.2.ebuild,v 1.4 2008/04/06 22:05:14 ulm Exp $
inherit autotools elisp-common eutils flag-o-matic
@@ -19,7 +19,7 @@ RDEPEND="!<app-editors/emacs-cvs-22.1
>=app-admin/eselect-emacs-1.2
net-libs/liblockfile
hesiod? ( net-dns/hesiod )
- kerberos? ( app-crypt/mit-krb5 )
+ kerberos? ( virtual/krb5 )
spell? ( || ( app-text/ispell app-text/aspell ) )
alsa? ( media-libs/alsa-lib )
X? (
@@ -56,6 +56,7 @@ src_unpack() {
epatch "${FILESDIR}/emacs-22.1-Xaw3d-headers.patch"
epatch "${FILESDIR}/emacs-22.1-freebsd-sparc.patch"
+ epatch "${FILESDIR}/${P}-heimdal-gentoo.patch"
sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
-e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
diff --git a/app-editors/emacs/files/emacs-22.2-heimdal-gentoo.patch b/app-editors/emacs/files/emacs-22.2-heimdal-gentoo.patch
new file mode 100644
index 000000000000..349a9e2a60b9
--- /dev/null
+++ b/app-editors/emacs/files/emacs-22.2-heimdal-gentoo.patch
@@ -0,0 +1,53 @@
+--- emacs-22.2-orig/configure.in 2008-04-02 18:28:37.000000000 +0200
++++ emacs-22.2/configure.in 2008-04-02 22:18:38.000000000 +0200
+@@ -2700,7 +2700,9 @@
+ fi
+
+ if test "${with_kerberos5+set}" = set; then
+- AC_CHECK_HEADERS(krb5.h)
++ AC_CHECK_HEADERS(krb5.h,
++ AC_CHECK_MEMBERS([krb5_error.text, krb5_error.e_text],,,
++ [#include <krb5.h>]))
+ else
+ AC_CHECK_HEADERS(des.h,,
+ [AC_CHECK_HEADERS(kerberosIV/des.h,,
+--- emacs-22.2-orig/lib-src/pop.c 2008-02-23 14:49:00.000000000 +0100
++++ emacs-22.2/lib-src/pop.c 2008-04-02 22:35:55.000000000 +0200
+@@ -1200,11 +1200,12 @@
+ krb5_free_principal (kcontext, server);
+ if (rem)
+ {
++ strcpy (pop_error, KRB_ERROR);
++ strncat (pop_error, error_message (rem),
++ ERROR_MAX - sizeof (KRB_ERROR));
++#if defined HAVE_KRB5_ERROR_TEXT
+ if (err_ret && err_ret->text.length)
+ {
+- strcpy (pop_error, KRB_ERROR);
+- strncat (pop_error, error_message (rem),
+- ERROR_MAX - sizeof (KRB_ERROR));
+ strncat (pop_error, " [server says '",
+ ERROR_MAX - strlen (pop_error) - 1);
+ strncat (pop_error, err_ret->text.data,
+@@ -1213,12 +1214,17 @@
+ strncat (pop_error, "']",
+ ERROR_MAX - strlen (pop_error) - 1);
+ }
+- else
++#elif defined HAVE_KRB5_ERROR_E_TEXT
++ if (err_ret && err_ret->e_text && strlen(*err_ret->e_text))
+ {
+- strcpy (pop_error, KRB_ERROR);
+- strncat (pop_error, error_message (rem),
+- ERROR_MAX - sizeof (KRB_ERROR));
++ strncat (pop_error, " [server says '",
++ ERROR_MAX - strlen (pop_error) - 1);
++ strncat (pop_error, *err_ret->e_text,
++ ERROR_MAX - strlen (pop_error) - 1);
++ strncat (pop_error, "']",
++ ERROR_MAX - strlen (pop_error) - 1);
+ }
++#endif
+ if (err_ret)
+ krb5_free_error (kcontext, err_ret);
+ krb5_auth_con_free (kcontext, auth_context);