summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-05-22 20:34:47 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-05-22 20:34:47 +0000
commitc4b833816e5c1041fee51cb3eaf523bd7b1be356 (patch)
treeeb565ebfd7fc46883686bc37adb5ed59ff345ab3 /app-editors
parentDon't install .a and .la files in site-packages directories. (diff)
downloadgentoo-2-c4b833816e5c1041fee51cb3eaf523bd7b1be356.tar.gz
gentoo-2-c4b833816e5c1041fee51cb3eaf523bd7b1be356.tar.bz2
gentoo-2-c4b833816e5c1041fee51cb3eaf523bd7b1be356.zip
Version bump. Fixes a number of problems with tab control and other
outstanding issues. Update minimum python version to 2.5. (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/editra/ChangeLog9
-rw-r--r--app-editors/editra/editra-0.5.60.ebuild (renamed from app-editors/editra/editra-0.5.32.ebuild)13
2 files changed, 13 insertions, 9 deletions
diff --git a/app-editors/editra/ChangeLog b/app-editors/editra/ChangeLog
index c6e88a4d43d3..c2effb358338 100644
--- a/app-editors/editra/ChangeLog
+++ b/app-editors/editra/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/editra
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/editra/ChangeLog,v 1.13 2010/03/17 23:09:57 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/editra/ChangeLog,v 1.14 2010/05/22 20:34:46 dirtyepic Exp $
+
+*editra-0.5.60 (22 May 2010)
+
+ 22 May 2010; Ryan Hill <dirtyepic@gentoo.org> -editra-0.5.32.ebuild,
+ +editra-0.5.60.ebuild:
+ Version bump. Fixes a number of problems with tab control and other
+ outstanding issues. Update minimum python version to 2.5.
*editra-0.5.51 (17 Mar 2010)
diff --git a/app-editors/editra/editra-0.5.32.ebuild b/app-editors/editra/editra-0.5.60.ebuild
index 03aae94c23dc..5178712f19b2 100644
--- a/app-editors/editra/editra-0.5.32.ebuild
+++ b/app-editors/editra/editra-0.5.60.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/editra/editra-0.5.32.ebuild,v 1.4 2010/03/07 21:29:36 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/editra/editra-0.5.60.ebuild,v 1.1 2010/05/22 20:34:47 dirtyepic Exp $
EAPI=2
SUPPORT_PYTHON_ABIS=1
-PYTHON_DEPEND="2:2.4"
+PYTHON_DEPEND="2:2.5"
inherit distutils eutils fdo-mime python
@@ -29,15 +29,12 @@ RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}"/${MY_PN}-${PV}
-src_prepare() {
- #http://code.google.com/p/editra/issues/detail?id=481
- epatch "${FILESDIR}"/${P}-sandbox.patch
- # next version, use setup.py install --no-clean
- distutils_src_prepare
+src_compile() {
+ distutils_src_compile --no-clean # http://code.google.com/p/editra/issues/detail?id=481
}
src_install() {
- distutils_src_install
+ distutils_src_install --no-clean
insinto /usr/share/pixmaps
doins "${S}"/pixmaps/editra.png
make_desktop_entry Editra Editra editra "Development;TextEditor"