summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-10-28 13:03:48 +0000
committerUlrich Müller <ulm@gentoo.org>2014-10-28 13:03:48 +0000
commitf0322ce8aab5133290fb316db1c10c2909018d1a (patch)
treeee4fd3940b624698fdd27038902e49ffe343ab17 /app-editors
parentVersion bump (diff)
downloadgentoo-2-f0322ce8aab5133290fb316db1c10c2909018d1a.tar.gz
gentoo-2-f0322ce8aab5133290fb316db1c10c2909018d1a.tar.bz2
gentoo-2-f0322ce8aab5133290fb316db1c10c2909018d1a.zip
Filter -pie from CFLAGS. Make sure that PT_PAX and XATTR_PAX flags for temacs are identical. Fixes build failure on hardened Linux, bug 526948.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/ChangeLog7
-rw-r--r--app-editors/emacs/emacs-23.4-r11.ebuild4
-rw-r--r--app-editors/emacs/emacs-24.4.ebuild8
3 files changed, 13 insertions, 6 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 4e56dc862afe..efe3eb5f5048 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/emacs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.642 2014/10/20 22:13:02 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.643 2014/10/28 13:03:48 ulm Exp $
+
+ 28 Oct 2014; Ulrich Müller <ulm@gentoo.org> emacs-23.4-r11.ebuild,
+ emacs-24.4.ebuild:
+ Filter -pie from CFLAGS. Make sure that PT_PAX and XATTR_PAX flags for
+ temacs are identical. Fixes build failure on hardened Linux, bug 526948.
*emacs-24.4 (20 Oct 2014)
diff --git a/app-editors/emacs/emacs-23.4-r11.ebuild b/app-editors/emacs/emacs-23.4-r11.ebuild
index bd48997f7c9a..b4a79eaee3a3 100644
--- a/app-editors/emacs/emacs-23.4-r11.ebuild
+++ b/app-editors/emacs/emacs-23.4-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.4-r11.ebuild,v 1.11 2014/06/19 18:14:23 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.4-r11.ebuild,v 1.12 2014/10/28 13:03:48 ulm Exp $
EAPI=5
WANT_AUTOMAKE="none"
@@ -104,7 +104,7 @@ src_prepare() {
src_configure() {
strip-flags
- filter-flags -fstrict-aliasing
+ filter-flags -fstrict-aliasing -pie
append-flags $(test-flags -fno-strict-aliasing)
if use sh; then
diff --git a/app-editors/emacs/emacs-24.4.ebuild b/app-editors/emacs/emacs-24.4.ebuild
index b04248a04ad6..84d3df96d4f4 100644
--- a/app-editors/emacs/emacs-24.4.ebuild
+++ b/app-editors/emacs/emacs-24.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-24.4.ebuild,v 1.1 2014/10/20 22:13:02 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-24.4.ebuild,v 1.2 2014/10/28 13:03:48 ulm Exp $
EAPI=5
@@ -8,7 +8,8 @@ inherit elisp-common eutils flag-o-matic multilib readme.gentoo
DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
HOMEPAGE="http://www.gnu.org/software/emacs/"
-SRC_URI="mirror://gnu/emacs/${P}.tar.xz"
+SRC_URI="mirror://gnu/emacs/${P}.tar.xz
+ http://dev.gentoo.org/~ulm/emacs/${P}-patches-1.tar.xz"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="24"
@@ -86,7 +87,7 @@ FULL_VERSION="${PV%%_*}"
S="${WORKDIR}/emacs-${FULL_VERSION}"
src_prepare() {
- #EPATCH_SUFFIX=patch epatch
+ EPATCH_SUFFIX=patch epatch
epatch_user
# Fix filename reference in redirected man page
@@ -98,6 +99,7 @@ src_prepare() {
src_configure() {
strip-flags
+ filter-flags -pie #526948
if use sh; then
replace-flags "-O[1-9]" -O0 #262359