summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-07-12 15:12:21 +0000
committerMamoru Komachi <usata@gentoo.org>2003-07-12 15:12:21 +0000
commit85abac6fd64da692725b28c3ab459960e8ae8a6e (patch)
tree11e5c67b7a8d1140f2148eb987b01316831584c4 /app-emacs/apel/apel-10.6.ebuild
parentVersion bump (diff)
downloadgentoo-2-85abac6fd64da692725b28c3ab459960e8ae8a6e.tar.gz
gentoo-2-85abac6fd64da692725b28c3ab459960e8ae8a6e.tar.bz2
gentoo-2-85abac6fd64da692725b28c3ab459960e8ae8a6e.zip
Version bump
Diffstat (limited to 'app-emacs/apel/apel-10.6.ebuild')
-rw-r--r--app-emacs/apel/apel-10.6.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/apel/apel-10.6.ebuild b/app-emacs/apel/apel-10.6.ebuild
new file mode 100644
index 000000000000..90e38ce9b2d8
--- /dev/null
+++ b/app-emacs/apel/apel-10.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/apel/apel-10.6.ebuild,v 1.1 2003/07/12 15:11:56 usata Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="A Portable Emacs Library is a library for making portable Emacs Lisp programs."
+HOMEPAGE="http://cvs.m17n.org/elisp/APEL/"
+SRC_URI="ftp://ftp.jpl.org/pub/elisp/apel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~sparc ~ppc"
+
+DEPEND="virtual/emacs"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat <<-EOF >> APEL-CFG
+ (setq APEL_PREFIX "apel")
+ (setq EMU_PREFIX "apel")
+ EOF
+}
+
+src_compile() {
+ make PREFIX=${D}/usr \
+ LISPDIR=${D}/${SITELISP} \
+ VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} || die
+}
+
+src_install() {
+ make PREFIX=${D}/usr \
+ LISPDIR=${D}/${SITELISP} \
+ VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} install || die
+
+ elisp-site-file-install ${FILESDIR}/50apel-gentoo.el
+
+ dodoc ChangeLog README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ einfo "See the /usr/share/doc/${P}/README.en.gz for tips on how to customize this package"
+ einfo "And you need to rebuild packages depending on ${PN}."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}