summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-09-23 13:52:57 +0000
committerUlrich Müller <ulm@gentoo.org>2008-09-23 13:52:57 +0000
commitea115393214be21e42df809e37a338a4916f7d03 (patch)
tree0d2785b6d01f42d0edcf7f7f06fc3e6e04d1dbd6 /app-emacs/bbdb
parentRemoved older versions (diff)
downloadgentoo-2-ea115393214be21e42df809e37a338a4916f7d03.tar.gz
gentoo-2-ea115393214be21e42df809e37a338a4916f7d03.tar.bz2
gentoo-2-ea115393214be21e42df809e37a338a4916f7d03.zip
Install TeX support files under texmf-site/tex/plain.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'app-emacs/bbdb')
-rw-r--r--app-emacs/bbdb/ChangeLog8
-rw-r--r--app-emacs/bbdb/bbdb-2.35-r1.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/app-emacs/bbdb/ChangeLog b/app-emacs/bbdb/ChangeLog
index 02673cd236f7..6d6799c9daad 100644
--- a/app-emacs/bbdb/ChangeLog
+++ b/app-emacs/bbdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/bbdb
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/ChangeLog,v 1.34 2008/07/28 18:54:03 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/ChangeLog,v 1.35 2008/09/23 13:52:57 ulm Exp $
+
+*bbdb-2.35-r1 (23 Sep 2008)
+
+ 23 Sep 2008; Ulrich Mueller <ulm@gentoo.org> +bbdb-2.35-r1.ebuild:
+ Install TeX support files under texmf-site/tex/plain. Simplify code for
+ byte-compilation of contributed files.
28 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-emacs/bbdb/bbdb-2.35-r1.ebuild b/app-emacs/bbdb/bbdb-2.35-r1.ebuild
new file mode 100644
index 000000000000..fe251c51a649
--- /dev/null
+++ b/app-emacs/bbdb/bbdb-2.35-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/bbdb-2.35-r1.ebuild,v 1.1 2008/09/23 13:52:57 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="The Insidious Big Brother Database"
+HOMEPAGE="http://bbdb.sourceforge.net/"
+SRC_URI="http://bbdb.sourceforge.net/${P}.tar.gz
+ http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/point-at.el
+ http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/dates.el"
+
+LICENSE="GPL-2 as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="tex"
+
+DEPEND=""
+RDEPEND="tex? ( virtual/tex-base )"
+
+SITEFILE=50${PN}-gentoo.el
+TEXMF="/usr/share/texmf-site"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ sed -i -e '0,/^--- bbdb-mail-folders.el ---$/d;/^--- end ---$/,$d' \
+ bits/bbdb-mail-folders.el || die "sed failed"
+ sed -i -e '/^;/,$!d' bits/bbdb-sort-mailrc.el || die "sed failed"
+ cp "${DISTDIR}"/{dates,point-at}.el bits || die "cp failed"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake -j1 || die "emake failed"
+ BYTECOMPFLAGS="-L bits -L lisp" elisp-compile bits/*.el || die
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el{,c} || die
+ elisp-install ${PN}/bits bits/*.el{,c} || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ doinfo texinfo/*.info*
+ dodoc ChangeLog INSTALL README bits/*.txt
+ newdoc bits/README README.bits
+ if use tex; then
+ insinto "${TEXMF}"/tex/plain/bbdb
+ doins tex/*.tex
+ fi
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ use tex && texconfig rehash
+
+ elog "If you use encryption or signing, you may specify the encryption"
+ elog "method by customising variable \"bbdb/pgp-method\". For details,"
+ elog "see the documentation of this variable. Depending on the Emacs"
+ elog "version, installation of additional packages like app-emacs/gnus"
+ elog "or app-emacs/mailcrypt may be required."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+ use tex && texconfig rehash
+}