summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-05-17 08:21:57 +0000
committerUlrich Müller <ulm@gentoo.org>2009-05-17 08:21:57 +0000
commit55da2a969ca54cd25edaa2c81273d2eddbd8ff26 (patch)
treefcedd56e83245a4a85c876a45a85d0a1cc42ccb7 /app-emacs/ecb
parentnon maintainer revbump, incorporate patch from debian to build w/ clamav-0.95... (diff)
downloadgentoo-2-55da2a969ca54cd25edaa2c81273d2eddbd8ff26.tar.gz
gentoo-2-55da2a969ca54cd25edaa2c81273d2eddbd8ff26.tar.bz2
gentoo-2-55da2a969ca54cd25edaa2c81273d2eddbd8ff26.zip
Version bump, bug 270121.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-emacs/ecb')
-rw-r--r--app-emacs/ecb/ChangeLog9
-rw-r--r--app-emacs/ecb/ecb-2.40.ebuild55
-rw-r--r--app-emacs/ecb/metadata.xml44
3 files changed, 83 insertions, 25 deletions
diff --git a/app-emacs/ecb/ChangeLog b/app-emacs/ecb/ChangeLog
index f281566200ae..aa8866f2310c 100644
--- a/app-emacs/ecb/ChangeLog
+++ b/app-emacs/ecb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/ecb
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ChangeLog,v 1.38 2009/04/06 21:04:45 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ChangeLog,v 1.39 2009/05/17 08:21:57 ulm Exp $
+
+*ecb-2.40 (17 May 2009)
+
+ 17 May 2009; Ulrich Mueller <ulm@gentoo.org> +ecb-2.40.ebuild:
+ Version bump, bug 270121.
06 Apr 2009; Ulrich Mueller <ulm@gentoo.org> -ecb-2.32-r2.ebuild:
Remove old.
@@ -149,7 +154,7 @@
1 Jan 2003; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
ecb-1.90.ebuild, files/50ecb-gentoo.el, files/ecb-1.9-gentoo.patch,
- files/digest-ecb-1.80 :
+ files/digest-ecb-1.80 :
Minor version bump.
diff --git a/app-emacs/ecb/ecb-2.40.ebuild b/app-emacs/ecb/ecb-2.40.ebuild
new file mode 100644
index 000000000000..5ab67ab87d9d
--- /dev/null
+++ b/app-emacs/ecb/ecb-2.40.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ecb-2.40.ebuild,v 1.1 2009/05/17 08:21:57 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="Source code browser for Emacs"
+HOMEPAGE="http://ecb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ecb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="java"
+
+DEPEND=">=app-emacs/cedet-1.0_pre6
+ java? ( app-emacs/jde )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="71${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-2.32-gentoo.patch"
+ sed -i -e "s:@PF@:${PF}:" ecb-help.el || die "sed failed"
+}
+
+src_compile() {
+ local loadpath=""
+ if use java; then
+ loadpath="${SITELISP}/elib ${SITELISP}/jde ${SITELISP}/jde/lisp"
+ fi
+
+ emake CEDET="${SITELISP}/cedet" LOADPATH="${loadpath}" \
+ || die "emake failed"
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r ecb-images || die
+
+ doinfo info-help/ecb.info* || die
+ dohtml html-help/*.html || die
+ dodoc NEWS README RELEASE_NOTES || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "ECB is now autoloaded in site-gentoo.el. Add the line"
+ elog " (require 'ecb)"
+ elog "to your ~/.emacs file to enable all features on Emacs startup."
+}
diff --git a/app-emacs/ecb/metadata.xml b/app-emacs/ecb/metadata.xml
index 17468753f05f..4858374f9d5b 100644
--- a/app-emacs/ecb/metadata.xml
+++ b/app-emacs/ecb/metadata.xml
@@ -3,32 +3,30 @@
<pkgmetadata>
<herd>emacs</herd>
<longdescription>
-ECB stands for "Emacs Code Browser". While Emacs already has good editing
-support for many modes, its browsing support is somewhat lacking. That's where
-ECB comes in: it displays a number of informational windows that allow for easy
-source code navigation and overview.
+ ECB stands for "Emacs Code Browser". While Emacs already has good editing
+ support for many modes, its browsing support is somewhat lacking. That's
+ where ECB comes in: it displays a number of informational windows that allow
+ for easy source code navigation and overview.
-The informational windows can contain:
+ The informational windows can contain:
- * A directory tree,
- * a list of source files in the current directory,
+ * A directory tree,
+ * a list of source files in the current directory,
+ * a list of functions/classes/methods/... in the current file, (ECB uses
+ the Semantic Bovinator, or Imenu, or etags, for getting this list so all
+ languages supported by any of these tools are automatically supported by
+ ECB too),
+ * a history of recently visited files,
+ * the Speedbar and
+ * output from compilation (the compilation window) and other modes like
+ help, grep etc. or whatever a user defines to be displayed in this
+ window.
- * a list of functions/classes/methods/... in the current file, (ECB uses the
- Semantic Bovinator, or Imenu, or etags, for getting this list so all
- languages supported by any of these tools are automatically supported by ECB
- too)
+ As an added bonus, ECB makes sure to keep these informational windows
+ visible, even when you use C-x 1 and similar commands.
- * a history of recently visited files,
- * the Speedbar and
-
- * output from compilation (the compilation window) and other modes like help,
- grep etc. or whatever a user defines to be displayed in this window.
-
-As an added bonus, ECB makes sure to keep these informational windows visible,
-even when you use C-x 1 and similar commands.
-
-It goes without saying that you can configure the layout, ie. which
-informational windows should be displayed where. ECB comes with a number of
-ready-made window layouts to choose from.
+ It goes without saying that you can configure the layout, ie. which
+ informational windows should be displayed where. ECB comes with a number of
+ ready-made window layouts to choose from.
</longdescription>
</pkgmetadata>