summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-16 13:24:42 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-16 13:24:42 +0000
commitd88435e5ecb588d27ff9a539dbb1ef4aefe62b5c (patch)
tree25d77e91ca7fefb181c1d09a3cddc75f92da12f9 /app-emacs/haskell-mode
parentVersion bump (diff)
downloadgentoo-2-d88435e5ecb588d27ff9a539dbb1ef4aefe62b5c.tar.gz
gentoo-2-d88435e5ecb588d27ff9a539dbb1ef4aefe62b5c.tar.bz2
gentoo-2-d88435e5ecb588d27ff9a539dbb1ef4aefe62b5c.zip
Version bump. Remove old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/haskell-mode')
-rw-r--r--app-emacs/haskell-mode/ChangeLog10
-rw-r--r--app-emacs/haskell-mode/haskell-mode-13.07.ebuild39
-rw-r--r--app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild31
3 files changed, 47 insertions, 33 deletions
diff --git a/app-emacs/haskell-mode/ChangeLog b/app-emacs/haskell-mode/ChangeLog
index 808e7de5487c..8cfa6cb101d4 100644
--- a/app-emacs/haskell-mode/ChangeLog
+++ b/app-emacs/haskell-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/haskell-mode
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/ChangeLog,v 1.48 2013/05/16 14:12:30 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/ChangeLog,v 1.49 2014/02/16 13:24:41 ulm Exp $
+
+*haskell-mode-13.07 (16 Feb 2014)
+
+ 16 Feb 2014; Ulrich Müller <ulm@gentoo.org> -haskell-mode-2.8.0.ebuild,
+ +haskell-mode-13.07.ebuild:
+ Version bump. Remove old.
16 May 2013; Ulrich Müller <ulm@gentoo.org> -haskell-mode-2.6.4.ebuild,
-haskell-mode-2.7.0.ebuild:
diff --git a/app-emacs/haskell-mode/haskell-mode-13.07.ebuild b/app-emacs/haskell-mode/haskell-mode-13.07.ebuild
new file mode 100644
index 000000000000..61a872c421e3
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-13.07.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-13.07.ebuild,v 1.1 2014/02/16 13:24:42 ulm Exp $
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://projects.haskell.org/haskellmode-emacs/
+ http://www.haskell.org/haskellwiki/Emacs#Haskell-mode"
+SRC_URI="https://github.com/haskell/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="haskell-mode.texi"
+DOCS="NEWS README.md examples/*.hs examples/init.el"
+
+src_prepare() {
+ # We install the logo in SITEETC, not in SITELISP
+ # https://github.com/haskell/haskell-mode/issues/102
+ sed -i -e "/defconst haskell-process-logo/{n;" \
+ -e "s:(.*\"\\(.*\\)\".*):\"${SITEETC}/${PN}/\\1\":}" \
+ haskell-process.el || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file haskell-site-file.el
+}
+
+src_install() {
+ elisp_src_install
+ insinto "${SITEETC}/${PN}"
+ doins logo.svg
+}
diff --git a/app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild b/app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild
deleted file mode 100644
index 80890e03ada1..000000000000
--- a/app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild,v 1.4 2010/08/13 12:57:43 josejx Exp $
-
-inherit elisp
-
-DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
-HOMEPAGE="http://projects.haskell.org/haskellmode-emacs/
- http://www.haskell.org/haskellwiki/Haskell_mode_for_Emacs"
-SRC_URI="http://projects.haskell.org/haskellmode-emacs/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ppc ~sparc x86"
-IUSE=""
-
-DOCS="ChangeLog NEWS README *.hs"
-SITEFILE="50${PN}-gentoo.el"
-
-src_compile() {
- elisp-make-autoload-file haskell-site-file.el || die
- elisp-compile *.el || die
-}
-
-pkg_postinst() {
- elisp-site-regen
-
- elog "If you update from before version 2.5 you must reconfigure,"
- elog "or indentation will not work."
- elog "Read the README file in /usr/share/doc/${PF}."
-}