summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-11-03 10:04:07 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-11-03 10:04:07 +0000
commite0fb0eea2093dc872e5c2d80f8665a49ae8c1d0f (patch)
tree0fb5dd1cc6d4028e3ea44473e7715ad7cc60d737 /app-emacs/http-emacs
parent*** empty log message *** (diff)
downloadgentoo-2-e0fb0eea2093dc872e5c2d80f8665a49ae8c1d0f.tar.gz
gentoo-2-e0fb0eea2093dc872e5c2d80f8665a49ae8c1d0f.tar.bz2
gentoo-2-e0fb0eea2093dc872e5c2d80f8665a49ae8c1d0f.zip
*** empty log message ***
Diffstat (limited to 'app-emacs/http-emacs')
-rw-r--r--app-emacs/http-emacs/ChangeLog10
-rw-r--r--app-emacs/http-emacs/Manifest4
-rw-r--r--app-emacs/http-emacs/files/50http-emacs-gentoo.el4
-rw-r--r--app-emacs/http-emacs/files/digest-http-emacs-1.11
-rw-r--r--app-emacs/http-emacs/http-emacs-1.1.ebuild27
-rw-r--r--app-emacs/http-emacs/metadata.xml5
6 files changed, 49 insertions, 2 deletions
diff --git a/app-emacs/http-emacs/ChangeLog b/app-emacs/http-emacs/ChangeLog
new file mode 100644
index 000000000000..5f63a9788f73
--- /dev/null
+++ b/app-emacs/http-emacs/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emacs/http-emacs
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/http-emacs/ChangeLog,v 1.1 2003/11/03 10:04:01 mkennedy Exp $
+
+*http-emacs-1.1 (03 Nov 2003)
+
+ 03 Nov 2003; <mkennedy@gentoo.org> http-emacs-1.1.ebuild, metadata.xml,
+ files/50http-emacs-gentoo.el:
+ initial import. ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/app-emacs/http-emacs/Manifest b/app-emacs/http-emacs/Manifest
index 00e20bb73cad..a5ff948d42bb 100644
--- a/app-emacs/http-emacs/Manifest
+++ b/app-emacs/http-emacs/Manifest
@@ -1,5 +1,5 @@
MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
-MD5 e89b279caea0edee039adacb93f2bd4c http-emacs-1.1.ebuild 962
+MD5 0f954fb4884622ec921aeadd24be9bc4 http-emacs-1.1.ebuild 967
+MD5 4c48eaf905405028f8df28a71173f4b6 ChangeLog 440
MD5 7e25cea82fdb64654f673b2dc24a02f1 files/50http-emacs-gentoo.el 83
MD5 3c3f1ae83ee53786e797df5b16a72633 files/digest-http-emacs-1.1 65
-MD5 406af9c58396f3ec546fbbb63f5a5ab7 files/50http-emacs-gentoo.el~ 45
diff --git a/app-emacs/http-emacs/files/50http-emacs-gentoo.el b/app-emacs/http-emacs/files/50http-emacs-gentoo.el
new file mode 100644
index 000000000000..ff389bb7766b
--- /dev/null
+++ b/app-emacs/http-emacs/files/50http-emacs-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; site-lisp configuration for http-emacs
+
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/http-emacs/files/digest-http-emacs-1.1 b/app-emacs/http-emacs/files/digest-http-emacs-1.1
new file mode 100644
index 000000000000..99970a02887b
--- /dev/null
+++ b/app-emacs/http-emacs/files/digest-http-emacs-1.1
@@ -0,0 +1 @@
+MD5 1c4195457ba5becd2e8e1d5ee45c5003 http-emacs-1.1.tar.gz 11030
diff --git a/app-emacs/http-emacs/http-emacs-1.1.ebuild b/app-emacs/http-emacs/http-emacs-1.1.ebuild
new file mode 100644
index 000000000000..e12d8240ad02
--- /dev/null
+++ b/app-emacs/http-emacs/http-emacs-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/http-emacs/http-emacs-1.1.ebuild,v 1.1 2003/11/03 10:04:01 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="http-emacs includes http-post and http-get which allows you to fetch, render and post html pages via emacs. It also includes simple-wiki-* modules, which allow you to edit remote (and local) wikis via emacs, and also includes a major-mode for the same."
+HOMEPAGE="http://emacswiki.org/cgi-bin/wiki.pl?SimpleWikiEditMode"
+SRC_URI="http://savannah.nongnu.org/download/http-emacs/http-emacs.pkg/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/emacs"
+S=${WORKDIR}/${PN}
+
+SITEFILE=50http-emacs-gentoo.el
+
+src_compile() {
+ elisp-comp http-*.el || die
+}
+
+src_install() {
+ elisp-install ${PN} http-*.el*
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ dodoc CONTRIBUTORS
+}
diff --git a/app-emacs/http-emacs/metadata.xml b/app-emacs/http-emacs/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/http-emacs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>