summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-20 18:25:35 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-20 18:25:35 +0000
commit1c42550abc7c0c144ca6522ed3a96d69f3b90d84 (patch)
tree2ad04dbbb34bc6454e90cd3496cc871f6383cd7b /app-emacs/mpg123-el/mpg123-el-1.59.ebuild
parentarm stable, bug #495448 (diff)
downloadgentoo-2-1c42550abc7c0c144ca6522ed3a96d69f3b90d84.tar.gz
gentoo-2-1c42550abc7c0c144ca6522ed3a96d69f3b90d84.tar.bz2
gentoo-2-1c42550abc7c0c144ca6522ed3a96d69f3b90d84.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/mpg123-el/mpg123-el-1.59.ebuild')
-rw-r--r--app-emacs/mpg123-el/mpg123-el-1.59.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/mpg123-el/mpg123-el-1.59.ebuild b/app-emacs/mpg123-el/mpg123-el-1.59.ebuild
new file mode 100644
index 000000000000..1ba0a7284c95
--- /dev/null
+++ b/app-emacs/mpg123-el/mpg123-el-1.59.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/mpg123-el-1.59.ebuild,v 1.1 2014/02/20 18:25:35 ulm Exp $
+
+EAPI=5
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
+HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="mpg123-el"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="vorbis"
+
+RDEPEND="media-sound/mpg123
+ media-sound/alsa-utils
+ vorbis? ( media-sound/vorbis-tools )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i -e "s/\(mainloop:\)/\1 ;/" tagput.c || die
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tagput tagput.c || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o id3put id3put.c || die
+ elisp-compile *.el
+}
+
+src_install() {
+ dobin tagput id3put
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}