summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-09-10 19:19:40 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-09-10 19:19:40 +0000
commit148fd188e889da419b107c489ba922a2b5224ba3 (patch)
tree30fb3842c1b92f9c64a2f9ece9a567233dfba4a4 /app-emacs/ocaml-mode
parentMarked ~amd64. (Manifest recommit) (diff)
downloadgentoo-2-148fd188e889da419b107c489ba922a2b5224ba3.tar.gz
gentoo-2-148fd188e889da419b107c489ba922a2b5224ba3.tar.bz2
gentoo-2-148fd188e889da419b107c489ba922a2b5224ba3.zip
Add latest version, move former one to stable.
Diffstat (limited to 'app-emacs/ocaml-mode')
-rw-r--r--app-emacs/ocaml-mode/ChangeLog9
-rw-r--r--app-emacs/ocaml-mode/files/digest-ocaml-mode-3.08.11
-rw-r--r--app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild4
-rw-r--r--app-emacs/ocaml-mode/ocaml-mode-3.08.1.ebuild49
4 files changed, 60 insertions, 3 deletions
diff --git a/app-emacs/ocaml-mode/ChangeLog b/app-emacs/ocaml-mode/ChangeLog
index 5342c62068f7..130082b83110 100644
--- a/app-emacs/ocaml-mode/ChangeLog
+++ b/app-emacs/ocaml-mode/ChangeLog
@@ -1,11 +1,18 @@
# ChangeLog for app-emacs/ocaml-mode
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ChangeLog,v 1.3 2004/09/03 22:03:02 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ChangeLog,v 1.4 2004/09/10 19:19:40 mattam Exp $
+
+*ocaml-mode-3.08.1 (10 Sep 2004)
+
+ 10 Sep 2004; Matthieu Sozeau <mattam@gentoo.org> ocaml-mode-3.07.ebuild,
+ +ocaml-mode-3.08.1.ebuild:
+ Add latest version, move former one to stable.
03 Sep 2004; Tom Martin <slarti@gentoo.org> ocaml-mode-3.07.ebuild:
Marked ~amd64, resolves #58421. Thanks to Gabriel Ebner <ge@gabrielebner.at>
for reporting.
+
*ocaml-mode-3.07 (11 Apr 2004)
11 Apr 2004; Matthieu Sozeau <mattam@gentoo.org> ocaml-mode-3.07.ebuild,
diff --git a/app-emacs/ocaml-mode/files/digest-ocaml-mode-3.08.1 b/app-emacs/ocaml-mode/files/digest-ocaml-mode-3.08.1
new file mode 100644
index 000000000000..a1b51298cc9d
--- /dev/null
+++ b/app-emacs/ocaml-mode/files/digest-ocaml-mode-3.08.1
@@ -0,0 +1 @@
+MD5 dbe9defdf7491854e8ec852bee367307 ocaml-3.08.1.tar.bz2 2050084
diff --git a/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild b/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild
index 2d057b9034a6..09556ce39aa2 100644
--- a/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild
+++ b/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild,v 1.4 2004/09/03 22:03:02 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild,v 1.5 2004/09/10 19:19:40 mattam Exp $
inherit elisp
@@ -13,7 +13,7 @@ SRC_URI="http://caml.inria.fr/distrib/${MY_P}/${MY_P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="x86 ppc ~amd64"
IUSE=""
DEPEND="virtual/emacs"
diff --git a/app-emacs/ocaml-mode/ocaml-mode-3.08.1.ebuild b/app-emacs/ocaml-mode/ocaml-mode-3.08.1.ebuild
new file mode 100644
index 000000000000..c6d2fc095fb6
--- /dev/null
+++ b/app-emacs/ocaml-mode/ocaml-mode-3.08.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ocaml-mode-3.08.1.ebuild,v 1.1 2004/09/10 19:19:40 mattam Exp $
+
+inherit elisp
+
+IUSE=""
+MY_P=${P/-mode/}
+
+DESCRIPTION="Emacs mode for OCaml"
+HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/${MY_P}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${MY_P}/emacs"
+
+src_compile() {
+ COMPILECMD='(progn
+ (setq load-path (cons "." load-path))
+ (byte-compile-file "caml-xemacs.el")
+ (byte-compile-file "caml-emacs.el")
+ (byte-compile-file "caml-types.el")
+ (byte-compile-file "caml-hilit.el")
+ (byte-compile-file "caml-font.el")
+ (byte-compile-file "caml.el")
+ (byte-compile-file "inf-caml.el")
+ (byte-compile-file "caml-help.el")
+ (byte-compile-file "camldebug.el"))'
+ emacs -batch -eval "${COMPILECMD}"
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/50ocaml-mode-gentoo.el
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}