summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-27 18:00:00 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-27 18:00:00 +0000
commitec23505596a0d9e61fc83f8dfdc2ef13238c7e35 (patch)
tree815f958bfdee008aa342ae2bdabb10a993731832 /app-emacs/popwin
parentPass --disable-shave to make the build verbose (almost same as --disable-sile... (diff)
downloadgentoo-2-ec23505596a0d9e61fc83f8dfdc2ef13238c7e35.tar.gz
gentoo-2-ec23505596a0d9e61fc83f8dfdc2ef13238c7e35.tar.bz2
gentoo-2-ec23505596a0d9e61fc83f8dfdc2ef13238c7e35.zip
Version bump. Remove old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/popwin')
-rw-r--r--app-emacs/popwin/ChangeLog10
-rw-r--r--app-emacs/popwin/files/popwin-0.3-emacs24.patch135
-rw-r--r--app-emacs/popwin/popwin-0.5.1.ebuild5
-rw-r--r--app-emacs/popwin/popwin-0.6.2.ebuild (renamed from app-emacs/popwin/popwin-0.3-r1.ebuild)14
4 files changed, 16 insertions, 148 deletions
diff --git a/app-emacs/popwin/ChangeLog b/app-emacs/popwin/ChangeLog
index 2173d179b392..046051866462 100644
--- a/app-emacs/popwin/ChangeLog
+++ b/app-emacs/popwin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/popwin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/popwin/ChangeLog,v 1.5 2012/09/08 08:59:28 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/popwin/ChangeLog,v 1.6 2014/02/27 18:00:00 ulm Exp $
+
+*popwin-0.6.2 (27 Feb 2014)
+
+ 27 Feb 2014; Ulrich Müller <ulm@gentoo.org> -popwin-0.3-r1.ebuild,
+ +popwin-0.6.2.ebuild, -files/popwin-0.3-emacs24.patch:
+ Version bump. Remove old.
*popwin-0.5.1 (08 Sep 2012)
diff --git a/app-emacs/popwin/files/popwin-0.3-emacs24.patch b/app-emacs/popwin/files/popwin-0.3-emacs24.patch
deleted file mode 100644
index 0aa7cb2d8ca6..000000000000
--- a/app-emacs/popwin/files/popwin-0.3-emacs24.patch
+++ /dev/null
@@ -1,135 +0,0 @@
-diff --git a/popwin.el b/popwin.el
-index 22f64f0..a5bafeb 100644
---- a/popwin.el
-+++ b/popwin.el
-@@ -4,7 +4,7 @@
-
- ;; Author: Tomohiro Matsuyama <tomo@cx4a.org>
- ;; Keywords: convenience
--;; Version: 0.3
-+;; Version: 0.4
-
- ;; This program is free software; you can redistribute it and/or modify
- ;; it under the terms of the GNU General Public License as published by
-@@ -69,7 +69,19 @@
-
-
-
--;;; Common API
-+;;; Common
-+
-+(defmacro popwin:save-selected-window (&rest body)
-+ "Evaluate BODY saving the selected window."
-+ `(with-selected-window (selected-window) ,@body))
-+
-+(defun popwin:switch-to-buffer (buffer-or-name &optional norecord)
-+ "Call `switch-to-buffer' forcing BUFFER-OF-NAME be displayed in
-+the selected window."
-+ (with-no-warnings
-+ (if (>= emacs-major-version 24)
-+ (switch-to-buffer buffer-or-name norecord t)
-+ (switch-to-buffer buffer-or-name norecord))))
-
- (defun popwin:last-selected-window ()
- "Return currently selected window or lastly selected window if
-@@ -82,6 +94,12 @@ minibuffer window is selected."
- "Return t if BUFFER might be thought of as a buried buffer."
- (eq (car (last (buffer-list))) buffer))
-
-+(defun popwin:called-interactively-p ()
-+ (with-no-warnings
-+ (if (>= emacs-major-version 23)
-+ (called-interactively-p 'any)
-+ (called-interactively-p))))
-+
- (defvar popwin:empty-buffer nil
- "Marker buffer of indicating a window of the buffer is being a
- popup window.")
-@@ -142,7 +160,7 @@ horizontal factor HFACTOR, and vertical factor VFACTOR."
- (cdr node)
- (popwin:adjust-window-edges window edges hfactor vfactor)
- (with-selected-window window
-- (switch-to-buffer buffer t))
-+ (popwin:switch-to-buffer buffer t))
- (when selected
- (select-window window)))
- (destructuring-bind (dir edges . windows) node
-@@ -221,7 +239,8 @@ window-configuration."
- (root-win (popwin:last-selected-window))
- (hfactor 1)
- (vfactor 1))
-- (delete-other-windows root-win)
-+ (popwin:save-selected-window
-+ (delete-other-windows root-win))
- (let ((root-width (window-width root-win))
- (root-height (window-height root-win)))
- (when adjust
-@@ -238,7 +257,7 @@ window-configuration."
- (popwin:create-popup-window-1 root-win size position)
- ;; Mark popup-win being a popup window.
- (with-selected-window popup-win
-- (switch-to-buffer (popwin:empty-buffer) t))
-+ (popwin:switch-to-buffer (popwin:empty-buffer) t))
- (popwin:replicate-window-config master-win root hfactor vfactor)
- (list master-win popup-win)))))
-
-@@ -410,7 +429,7 @@ BUFFER."
- popwin:selected-window (selected-window))
- (popwin:start-close-popup-window-timer))))
- (with-selected-window popwin:popup-window
-- (switch-to-buffer buffer))
-+ (popwin:switch-to-buffer buffer))
- (setq popwin:popup-buffer buffer
- popwin:popup-window-stuck-p stick)
- (if noselect
-@@ -438,6 +457,10 @@ be closed by `popwin:close-popup-window'."
-
- ;;; Special Display
-
-+(defmacro popwin:without-special-display (&rest body)
-+ "Evaluate BODY without special displaying."
-+ `(let (display-buffer-function special-display-function) ,@body))
-+
- (defcustom popwin:special-display-config
- '(("*Help*")
- ("*Completions*" :noselect t)
-@@ -481,13 +504,19 @@ buffers will be shown at the left of the frame with width 80."
-
- (defun popwin:original-display-buffer (buffer &optional not-this-window)
- "Call `display-buffer' for BUFFER without special displaying."
-- (let (display-buffer-function special-display-function)
-- ;; Close the popup window here so that the popup window won't to
-- ;; be splitted.
-- (when (and (eq (selected-window) popwin:popup-window)
-- (not (same-window-p (buffer-name buffer))))
-- (popwin:close-popup-window))
-- (display-buffer buffer not-this-window)))
-+ (popwin:without-special-display
-+ ;; Close the popup window here so that the popup window won't to
-+ ;; be splitted.
-+ (when (and (eq (selected-window) popwin:popup-window)
-+ (not (same-window-p (buffer-name buffer))))
-+ (popwin:close-popup-window))
-+ (if (and (>= emacs-major-version 24)
-+ (boundp 'action)
-+ (boundp 'frame))
-+ ;; Use variables ACTION and FRAME which are formal parameters
-+ ;; of DISPLAY-BUFFER.
-+ (display-buffer buffer action frame)
-+ (display-buffer buffer not-this-window))))
-
- (defun* popwin:display-buffer-1 (buffer-or-name &key default-config-keywords if-buffer-not-found if-config-not-found)
- "Display BUFFER-OR-NAME, if possible, in a popup
-@@ -548,9 +577,9 @@ usual. This function can be used as a value of
- (popwin:display-buffer-1
- buffer-or-name
- :if-config-not-found
-- (unless (interactive-p)
-- (lambda (buffer-or-name)
-- (popwin:original-display-buffer buffer-or-name not-this-window)))))
-+ (unless (popwin:called-interactively-p)
-+ (lambda (buffer)
-+ (popwin:original-display-buffer buffer not-this-window)))))
-
- (defun popwin:special-display-popup-window (buffer &rest ignore)
- "The `special-display-function' with a popup window."
diff --git a/app-emacs/popwin/popwin-0.5.1.ebuild b/app-emacs/popwin/popwin-0.5.1.ebuild
index 81aa94f588eb..1c316095990c 100644
--- a/app-emacs/popwin/popwin-0.5.1.ebuild
+++ b/app-emacs/popwin/popwin-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/popwin/popwin-0.5.1.ebuild,v 1.1 2012/09/08 08:59:28 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/popwin/popwin-0.5.1.ebuild,v 1.2 2014/02/27 18:00:00 ulm Exp $
EAPI=4
NEED_EMACS=22
@@ -11,10 +11,9 @@ DESCRIPTION="Popup window manager for Emacs"
HOMEPAGE="https://github.com/m2ym/popwin-el/"
SRC_URI="https://github.com/m2ym/popwin-el/tarball/v${PV} -> ${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
SITEFILE="50${PN}-gentoo.el"
DOCS="README.md NEWS.md"
diff --git a/app-emacs/popwin/popwin-0.3-r1.ebuild b/app-emacs/popwin/popwin-0.6.2.ebuild
index 3df9bbd83744..640459c635df 100644
--- a/app-emacs/popwin/popwin-0.3-r1.ebuild
+++ b/app-emacs/popwin/popwin-0.6.2.ebuild
@@ -1,24 +1,22 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/popwin/popwin-0.3-r1.ebuild,v 1.2 2011/10/21 19:19:58 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/popwin/popwin-0.6.2.ebuild,v 1.1 2014/02/27 18:00:00 ulm Exp $
-EAPI=3
+EAPI=5
NEED_EMACS=22
inherit elisp eutils
DESCRIPTION="Popup window manager for Emacs"
HOMEPAGE="https://github.com/m2ym/popwin-el/"
-SRC_URI="https://github.com/m2ym/popwin-el/tarball/v${PV} -> ${P}.tar.gz"
+SRC_URI="https://github.com/m2ym/${PN}-el/tarball/v${PV} -> ${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
SITEFILE="50${PN}-gentoo.el"
-DOCS="README.markdown"
-ELISP_PATCHES="${P}-emacs24.patch"
+DOCS="README.md NEWS.md"
src_unpack() {
unpack ${A}