summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-02-11 11:53:45 +0000
committerUlrich Müller <ulm@gentoo.org>2008-02-11 11:53:45 +0000
commit71e113f85f9eb8820a8c2f186c2d5e007b0d6ab8 (patch)
tree42f0c94c34dff464bb1ad07203694c917016f3ac /app-emacs/pymacs
parentabout all the Makefiles are broken wrt parallel make (diff)
downloadgentoo-2-71e113f85f9eb8820a8c2f186c2d5e007b0d6ab8.tar.gz
gentoo-2-71e113f85f9eb8820a8c2f186c2d5e007b0d6ab8.tar.bz2
gentoo-2-71e113f85f9eb8820a8c2f186c2d5e007b0d6ab8.zip
New beta version.
(Portage version: 2.1.4.3)
Diffstat (limited to 'app-emacs/pymacs')
-rw-r--r--app-emacs/pymacs/ChangeLog7
-rw-r--r--app-emacs/pymacs/pymacs-0.23_beta7.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/app-emacs/pymacs/ChangeLog b/app-emacs/pymacs/ChangeLog
index 6afc911c8d82..a35a8a511606 100644
--- a/app-emacs/pymacs/ChangeLog
+++ b/app-emacs/pymacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/pymacs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/ChangeLog,v 1.24 2008/02/09 10:08:11 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/ChangeLog,v 1.25 2008/02/11 11:53:45 ulm Exp $
+
+*pymacs-0.23_beta7 (11 Feb 2008)
+
+ 11 Feb 2008; Ulrich Mueller <ulm@gentoo.org> +pymacs-0.23_beta7.ebuild:
+ New beta version.
*pymacs-0.23_beta6 (09 Feb 2008)
diff --git a/app-emacs/pymacs/pymacs-0.23_beta7.ebuild b/app-emacs/pymacs/pymacs-0.23_beta7.ebuild
new file mode 100644
index 000000000000..e81c429a17a0
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.23_beta7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/pymacs-0.23_beta7.ebuild,v 1.1 2008/02/11 11:53:45 ulm Exp $
+
+inherit distutils elisp versionator
+
+MY_P=Pymacs-$(replace_version_separator 2 -)
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
+HOMEPAGE="http://pymacs.progiciels-bpi.ca/"
+SRC_URI="http://pymacs.progiciels-bpi.ca/archives/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/docutils virtual/latex-base )"
+RDEPEND=""
+
+SITEFILE=50${PN}-gentoo.el
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake || die "emake failed"
+ elisp-compile pymacs.el || die "elisp-compile failed"
+ if use doc; then
+ emake pymacs.pdf || die "emake pymacs.pdf failed"
+ fi
+}
+
+src_install() {
+ elisp_src_install
+ distutils_src_install
+ dodoc THANKS pymacs.rst
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins pymacs.pdf
+ fi
+}