summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-04-08 10:09:05 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-04-08 10:09:05 +0000
commit93d65885b3e449e2c4ecbf8b0108a07c2cd09cf1 (patch)
tree1e79e1babd5c7e9b37745e453148f1fe31e1605e /app-emacs/pymacs
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-93d65885b3e449e2c4ecbf8b0108a07c2cd09cf1.tar.gz
gentoo-2-93d65885b3e449e2c4ecbf8b0108a07c2cd09cf1.tar.bz2
gentoo-2-93d65885b3e449e2c4ecbf8b0108a07c2cd09cf1.zip
Fix PYTHON_DEPEND usage and only use Python 2.x, fixes bug 311181
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'app-emacs/pymacs')
-rw-r--r--app-emacs/pymacs/ChangeLog10
-rw-r--r--app-emacs/pymacs/pymacs-0.23-r1.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/app-emacs/pymacs/ChangeLog b/app-emacs/pymacs/ChangeLog
index 316bcdc08cbc..27b155d3bdd2 100644
--- a/app-emacs/pymacs/ChangeLog
+++ b/app-emacs/pymacs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/pymacs
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/ChangeLog,v 1.43 2009/11/24 21:14:16 fauli Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/ChangeLog,v 1.44 2010/04/08 10:09:05 fauli Exp $
+
+*pymacs-0.23-r1 (08 Apr 2010)
+
+ 08 Apr 2010; Christian Faulhammer <fauli@gentoo.org>
+ +pymacs-0.23-r1.ebuild:
+ Fix PYTHON_DEPEND usage and only use Python 2.x, fixes bug 311181
24 Nov 2009; Christian Faulhammer <fauli@gentoo.org> pymacs-0.23.ebuild:
import changes from Prefix overlay
diff --git a/app-emacs/pymacs/pymacs-0.23-r1.ebuild b/app-emacs/pymacs/pymacs-0.23-r1.ebuild
new file mode 100644
index 000000000000..d7f5105be8f0
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.23-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/pymacs-0.23-r1.ebuild,v 1.1 2010/04/08 10:09:05 fauli Exp $
+
+PYTHON_DEPEND="2"
+
+inherit distutils elisp
+
+MY_P=Pymacs-${PV}
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
+HOMEPAGE="http://pymacs.progiciels-bpi.ca/"
+SRC_URI="http://pymacs.progiciels-bpi.ca/archives/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+# additional doc? dependencies for multirow.sty and aeguill.sty (bug 247703)
+DEPEND="
+ doc? ( dev-python/docutils
+ virtual/latex-base
+ || ( ( dev-texlive/texlive-latexextra
+ dev-texlive/texlive-langfrench )
+ app-text/ptex ) )"
+RDEPEND=""
+
+SITEFILE=50${PN}-gentoo.el
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_compile() {
+ emake || die "emake failed"
+ elisp-compile pymacs.el || die "elisp-compile failed"
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts \
+ emake pymacs.pdf || die "emake pymacs.pdf failed"
+ fi
+}
+
+src_install() {
+ elisp_src_install
+ distutils_src_install
+ dodoc THANKS pymacs.rst
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins pymacs.pdf
+ fi
+}