summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-04-17 21:37:14 +0000
committerUlrich Müller <ulm@gentoo.org>2007-04-17 21:37:14 +0000
commitb2d0b5ae17c5c8e949cbae008437242fd5f83681 (patch)
treefda9d085bb34968a8392dffaf291869cad452668 /app-emacs/semantic
parentFix 2007.0/packages to require a slightly older minimum gcc. Fixes virtual/li... (diff)
downloadgentoo-2-b2d0b5ae17c5c8e949cbae008437242fd5f83681.tar.gz
gentoo-2-b2d0b5ae17c5c8e949cbae008437242fd5f83681.tar.bz2
gentoo-2-b2d0b5ae17c5c8e949cbae008437242fd5f83681.zip
Autoload semantic-map-buffers.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-emacs/semantic')
-rw-r--r--app-emacs/semantic/ChangeLog9
-rw-r--r--app-emacs/semantic/files/61semantic-gentoo.el31
-rw-r--r--app-emacs/semantic/files/digest-semantic-1.4.4-r23
-rw-r--r--app-emacs/semantic/semantic-1.4.4-r2.ebuild32
4 files changed, 74 insertions, 1 deletions
diff --git a/app-emacs/semantic/ChangeLog b/app-emacs/semantic/ChangeLog
index 5051d8ec00a0..94e80d1510fe 100644
--- a/app-emacs/semantic/ChangeLog
+++ b/app-emacs/semantic/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/semantic
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/semantic/ChangeLog,v 1.14 2007/03/08 09:29:20 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/semantic/ChangeLog,v 1.15 2007/04/17 21:37:14 ulm Exp $
+
+*semantic-1.4.4-r2 (17 Apr 2007)
+
+ 17 Apr 2007; Ulrich Mueller <ulm@gentoo.org> +files/61semantic-gentoo.el,
+ +semantic-1.4.4-r2.ebuild:
+ Autoload semantic-map-buffers, as suggested by Martin Buerger
+ <buerger_martin@web.de> in bug #30589.
08 Mar 2007; Christian Faulhammer <opfer@gentoo.org>
files/60semantic-gentoo.el:
diff --git a/app-emacs/semantic/files/61semantic-gentoo.el b/app-emacs/semantic/files/61semantic-gentoo.el
new file mode 100644
index 000000000000..81531928ee67
--- /dev/null
+++ b/app-emacs/semantic/files/61semantic-gentoo.el
@@ -0,0 +1,31 @@
+
+;;; semantic site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'semantic-map-buffers "semantic-util")
+
+;; To determine what should be done here every semantic release, check
+;; semantic-load.el. Here we replicate the (when ... sexp twoards the
+;; end of the source.
+
+;; We turn on everything except foor `global-semantic-stickyfunc-mode'
+;; as it seems to be a source of consternation for new and experienced
+;; users alike.
+
+(setq semantic-load-turn-everything-on nil
+ semantic-load-turn-useful-things-on nil)
+(require 'semantic-load)
+
+(global-semantic-show-dirty-mode 1)
+(global-senator-minor-mode 1)
+(global-semantic-show-unmatched-syntax-mode 1)
+(global-semantic-auto-parse-mode 1)
+(global-semanticdb-minor-mode 1)
+(global-semantic-summary-mode 1)
+;; (global-semantic-stickyfunc-mode 1)
+
+(when (and (eq window-system 'x)
+ (locate-library "imenu"))
+ (add-hook 'semantic-init-hooks (lambda ()
+ (imenu-add-to-menubar "TOKENS"))))
diff --git a/app-emacs/semantic/files/digest-semantic-1.4.4-r2 b/app-emacs/semantic/files/digest-semantic-1.4.4-r2
new file mode 100644
index 000000000000..3923e363b95b
--- /dev/null
+++ b/app-emacs/semantic/files/digest-semantic-1.4.4-r2
@@ -0,0 +1,3 @@
+MD5 9b3780695154dc66e1ecbdc40c0541a0 semantic-1.4.4.tar.gz 322819
+RMD160 e67bed991b9c1d0ade548304a47fad7019d2f912 semantic-1.4.4.tar.gz 322819
+SHA256 aed8e4e2de749cbc0801280d12d3a334049ddf48b7bfe5f02e83aee21b6ea048 semantic-1.4.4.tar.gz 322819
diff --git a/app-emacs/semantic/semantic-1.4.4-r2.ebuild b/app-emacs/semantic/semantic-1.4.4-r2.ebuild
new file mode 100644
index 000000000000..6fcacdd835cb
--- /dev/null
+++ b/app-emacs/semantic/semantic-1.4.4-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/semantic/semantic-1.4.4-r2.ebuild,v 1.1 2007/04/17 21:37:14 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="The Semantic Bovinator is a lexer, parser-generator, and parser written in Emacs Lisp"
+HOMEPAGE="http://cedet.sourceforge.net/semantic.shtml"
+SRC_URI="mirror://sourceforge/cedet/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/emacs
+ >=app-emacs/speedbar-0.14_beta4
+ >=app-emacs/eieio-0.17
+ !app-emacs/cedet"
+
+SITEFILE=61${PN}-gentoo.el
+
+src_compile() {
+ make LOADPATH="${SITELISP}/speedbar ${SITELISP}/eieio" || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc *.bnf
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ChangeLog NEWS INSTALL
+ doinfo semantic.info*
+}