summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-14 15:50:36 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-14 15:50:36 +0000
commit6642be4c4b3314de5e2e356ebe641c7583574e20 (patch)
tree88035c86cce57e63fd0bc5dea880057a3528c440 /app-emacs/volume
parentia64 stable wrt bug #477894 (diff)
downloadgentoo-2-6642be4c4b3314de5e2e356ebe641c7583574e20.tar.gz
gentoo-2-6642be4c4b3314de5e2e356ebe641c7583574e20.tar.bz2
gentoo-2-6642be4c4b3314de5e2e356ebe641c7583574e20.zip
Patch for better Emacs 24 compatibility.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/volume')
-rw-r--r--app-emacs/volume/ChangeLog8
-rw-r--r--app-emacs/volume/files/volume-1.0-mode-line.patch14
-rw-r--r--app-emacs/volume/volume-1.0-r1.ebuild23
3 files changed, 44 insertions, 1 deletions
diff --git a/app-emacs/volume/ChangeLog b/app-emacs/volume/ChangeLog
index 713f79fa1971..b6b4d7971464 100644
--- a/app-emacs/volume/ChangeLog
+++ b/app-emacs/volume/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/volume
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/volume/ChangeLog,v 1.11 2014/01/01 16:03:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/volume/ChangeLog,v 1.12 2014/02/14 15:50:36 ulm Exp $
+
+*volume-1.0-r1 (14 Feb 2014)
+
+ 14 Feb 2014; Ulrich Müller <ulm@gentoo.org> +volume-1.0-r1.ebuild,
+ +files/volume-1.0-mode-line.patch:
+ Patch for better Emacs 24 compatibility.
01 Jan 2014; Ulrich Müller <ulm@gentoo.org> volume-1.0.ebuild:
Update HOMEPAGE and SRC_URI. Specify LICENSE more precisely. Bump EAPI to 5.
diff --git a/app-emacs/volume/files/volume-1.0-mode-line.patch b/app-emacs/volume/files/volume-1.0-mode-line.patch
new file mode 100644
index 000000000000..2b3e4ccd33ef
--- /dev/null
+++ b/app-emacs/volume/files/volume-1.0-mode-line.patch
@@ -0,0 +1,14 @@
+Use `mode-line' instead of `modeline' for Emacs 24 compat.
+Patch taken from upstream repo.
+
+--- a/volume.el
++++ b/volume.el
+@@ -973,7 +973,7 @@
+ (select-window
+ (split-window-vertically
+ (if (and (fboundp 'face-attr-construct)
+- (plist-get (face-attr-construct 'modeline) :box))
++ (plist-get (face-attr-construct 'mode-line) :box))
+ -3 -2)))
+ (switch-to-buffer volume-buffer)))
+ ((not (eq (current-buffer) volume-buffer))
diff --git a/app-emacs/volume/volume-1.0-r1.ebuild b/app-emacs/volume/volume-1.0-r1.ebuild
new file mode 100644
index 000000000000..3a605e978d5a
--- /dev/null
+++ b/app-emacs/volume/volume-1.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/volume/volume-1.0-r1.ebuild,v 1.1 2014/02/14 15:50:36 ulm Exp $
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Tweak your sound card volume from Emacs"
+HOMEPAGE="https://github.com/dbrock/volume-el"
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+# NOTE we might define the following which volume.el can work with by
+# default, but volume.el can really work with anything.
+
+# RDEPEND="|| ( media-sound/aumixer media-sound/alsa-utils )"
+
+ELISP_PATCHES="${P}-mode-line.patch"
+SITEFILE="50${PN}-gentoo.el"