summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2002-12-20 11:55:26 +0000
committerMasatomo Nakano <nakano@gentoo.org>2002-12-20 11:55:26 +0000
commit59678fb67f949d642b1326b70df0618f22a33ad6 (patch)
tree741ae52ac5308a264019b8971a6a64508a2127ed /app-emacs/yc
parentVersion bumped (diff)
downloadgentoo-2-59678fb67f949d642b1326b70df0618f22a33ad6.tar.gz
gentoo-2-59678fb67f949d642b1326b70df0618f22a33ad6.tar.bz2
gentoo-2-59678fb67f949d642b1326b70df0618f22a33ad6.zip
initial import
Diffstat (limited to 'app-emacs/yc')
-rw-r--r--app-emacs/yc/ChangeLog12
-rw-r--r--app-emacs/yc/files/50yc-gentoo.el4
-rw-r--r--app-emacs/yc/files/digest-yc-3.5.01
-rw-r--r--app-emacs/yc/files/sample.dot.emacs10
-rw-r--r--app-emacs/yc/files/sample.hosts.canna2
-rw-r--r--app-emacs/yc/yc-3.5.0.ebuild50
6 files changed, 79 insertions, 0 deletions
diff --git a/app-emacs/yc/ChangeLog b/app-emacs/yc/ChangeLog
new file mode 100644
index 000000000000..9af6f5ee5ad2
--- /dev/null
+++ b/app-emacs/yc/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-emacs/yc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yc/ChangeLog,v 1.1 2002/12/20 11:55:26 nakano Exp $
+
+*yc-3.5.0 (20 Dec 2002)
+
+ 20 Dec 2002; Masatomo Nakano <nakano@gentoo.org> ChangeLog,
+ yc-3.5.0.ebuild, files/30yc-gentoo.el, files/sample.dot.emacs,
+ files/sample.hosts.canna, files/digest-yc-3.5.0 :
+
+ Initial import. Ebuild submitted by ni_naoto@ybb.ne.jp (Nishimura Naoto).
+
diff --git a/app-emacs/yc/files/50yc-gentoo.el b/app-emacs/yc/files/50yc-gentoo.el
new file mode 100644
index 000000000000..3914d6a58b3a
--- /dev/null
+++ b/app-emacs/yc/files/50yc-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; YC site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
diff --git a/app-emacs/yc/files/digest-yc-3.5.0 b/app-emacs/yc/files/digest-yc-3.5.0
new file mode 100644
index 000000000000..00f78d4a5404
--- /dev/null
+++ b/app-emacs/yc/files/digest-yc-3.5.0
@@ -0,0 +1 @@
+MD5 005349434105cc06dc6cb930bb7fa9c3 yc.el-3.5.0.gz 32218
diff --git a/app-emacs/yc/files/sample.dot.emacs b/app-emacs/yc/files/sample.dot.emacs
new file mode 100644
index 000000000000..8432c2ab3dd0
--- /dev/null
+++ b/app-emacs/yc/files/sample.dot.emacs
@@ -0,0 +1,10 @@
+;;;; -*- mode: lisp-interaction; syntax: elisp; coding: iso-2022-7bit -*-
+
+;;;; Configuration for yc
+(setq yc-server-host "localhost")
+(setq yc-use-color t)
+(if (eq window-system 'x)
+ (setq yc-use-fence nil)
+ (setq yc-use-fence t))
+(load "yc")
+(global-yc-mode 1)
diff --git a/app-emacs/yc/files/sample.hosts.canna b/app-emacs/yc/files/sample.hosts.canna
new file mode 100644
index 000000000000..70523ea54f9a
--- /dev/null
+++ b/app-emacs/yc/files/sample.hosts.canna
@@ -0,0 +1,2 @@
+localhost
+unix \ No newline at end of file
diff --git a/app-emacs/yc/yc-3.5.0.ebuild b/app-emacs/yc/yc-3.5.0.ebuild
new file mode 100644
index 000000000000..3ddd57ea71c1
--- /dev/null
+++ b/app-emacs/yc/yc-3.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yc/yc-3.5.0.ebuild,v 1.1 2002/12/20 11:55:26 nakano Exp $
+
+inherit elisp
+
+IUSE=""
+
+MY_P=yc.el-${PV}
+DESCRIPTION="YC - Yet another Canna client on Emacsen."
+HOMEPAGE="http://www.ceres.dti.ne.jp/~knak/yc.html"
+SRC_URI="http://www.ceres.dti.ne.jp/~knak/${MY_P}.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs
+ >=app-i18n/canna-3.5_beta2"
+
+S="${WORKDIR}/${P}"
+SITEFILE="50yc-gentoo.el"
+
+src_unpack() {
+ mkdir -p ${S}
+ gzip -dc ${DISTDIR}/${MY_P}.gz > ${S}/yc.el
+}
+
+src_compile() {
+ emacs -batch -eval '(byte-compile-file "yc.el")'
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc ${FILESDIR}/sample*
+}
+
+pkg_postinst() {
+ einfo "Please modify as following in /etc/conf.d/canna."
+ einfo "\n\t CANNASERVER_OPTS=\"-inet\"\n"
+ einfo "And create /etc/hosts.canna."
+ einfo "(sample is /usr/share/doc/${P}/sample.hosts.canna.gz)"
+ einfo "And see /usr/share/doc/${P}/sample.dot.emacs.gz."
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}