summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-01-30 21:58:51 +0000
committerUlrich Müller <ulm@gentoo.org>2010-01-30 21:58:51 +0000
commit1530c4060e5cced21c3d7bb8f208fc8a2a480553 (patch)
treeef917b6ada40a028029e4330f882e77c708ec6a7 /app-emacs
parentRestore fortune-mod-dune. (diff)
downloadgentoo-2-1530c4060e5cced21c3d7bb8f208fc8a2a480553.tar.gz
gentoo-2-1530c4060e5cced21c3d7bb8f208fc8a2a480553.tar.bz2
gentoo-2-1530c4060e5cced21c3d7bb8f208fc8a2a480553.zip
Properly split off src_configure for EAPI 3.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/auctex/auctex-11.85-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-emacs/auctex/auctex-11.85-r1.ebuild b/app-emacs/auctex/auctex-11.85-r1.ebuild
index e8e559a65656..f17534796f3a 100644
--- a/app-emacs/auctex/auctex-11.85-r1.ebuild
+++ b/app-emacs/auctex/auctex-11.85-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.85-r1.ebuild,v 1.1 2010/01/30 18:03:35 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.85-r1.ebuild,v 1.2 2010/01/30 21:58:51 ulm Exp $
EAPI=3
@@ -23,7 +23,7 @@ RDEPEND="${DEPEND}"
TEXMF="/usr/share/texmf-site"
-src_compile() {
+src_configure() {
# Remove broken Info file (will be recreated by the build system)
rm doc/auctex.info
@@ -35,6 +35,9 @@ src_compile() {
--with-texmf-dir="${EPREFIX}${TEXMF}" \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_enable preview-latex preview) || die "econf failed"
+}
+
+src_compile() {
emake || die "emake failed"
cd doc; emake tex-ref.pdf || die "creation of tex-ref.pdf failed"
}