summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-02-26 08:20:30 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-02-26 08:20:30 +0000
commit2e58572b0524cc6b5eebf6e47840b45c3159902a (patch)
treef26cebad65d8e861bdb4ffd1f8b571bbc1808e2c /app-emacs
parentrevision bump: fixes some warnings with GCC 4, also change installation direc... (diff)
downloadgentoo-2-2e58572b0524cc6b5eebf6e47840b45c3159902a.tar.gz
gentoo-2-2e58572b0524cc6b5eebf6e47840b45c3159902a.tar.bz2
gentoo-2-2e58572b0524cc6b5eebf6e47840b45c3159902a.zip
added some quotes and braces for better readability and possible breakages
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/cedet/ChangeLog6
-rw-r--r--app-emacs/cedet/cedet-1.0_pre3-r2.ebuild38
2 files changed, 25 insertions, 19 deletions
diff --git a/app-emacs/cedet/ChangeLog b/app-emacs/cedet/ChangeLog
index 1e9d7f4788e3..3ffd7201a512 100644
--- a/app-emacs/cedet/ChangeLog
+++ b/app-emacs/cedet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/cedet
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.14 2007/02/21 21:27:00 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.15 2007/02/26 08:20:30 opfer Exp $
+
+ 26 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
+ cedet-1.0_pre3-r2.ebuild:
+ added some quotes and braces for better readability and possible breakages
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-emacs/cedet/cedet-1.0_pre3-r2.ebuild b/app-emacs/cedet/cedet-1.0_pre3-r2.ebuild
index 984b95fdfce7..3ed9af791b69 100644
--- a/app-emacs/cedet/cedet-1.0_pre3-r2.ebuild
+++ b/app-emacs/cedet/cedet-1.0_pre3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.0_pre3-r2.ebuild,v 1.1 2006/11/19 17:13:20 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.0_pre3-r2.ebuild,v 1.2 2007/02/26 08:20:30 opfer Exp $
inherit elisp eutils
@@ -24,9 +24,11 @@ SITEFILE="60cedet-gentoo.el"
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/1.0_pre3-eieio-tests-gentoo.patch # Bug #124598
- epatch ${FILESDIR}/1.0_pre3-sb-info-circular-dep-gentoo.patch # Bug #138190
- epatch ${FILESDIR}/1.0_pre3-idle-gentoo.patch # Bug #149842
+
+ cd "${S}"
+ epatch "${FILESDIR}/1.0_pre3-eieio-tests-gentoo.patch" # Bug #124598
+ epatch "${FILESDIR}/1.0_pre3-sb-info-circular-dep-gentoo.patch" # Bug #138190
+ epatch "${FILESDIR}/1.0_pre3-idle-gentoo.patch" # Bug #149842
}
src_compile() {
@@ -34,37 +36,37 @@ src_compile() {
}
src_install() {
- find ${S} -type f -print \
+ find "${S}" -type f -print \
| while read target; do
local directory=`dirname $target` file=`basename $target`
local sub_directory=`basename $directory`
case $file in
*~ | Makefile | *.texi | *-script | PRERELEASE_CHECKLIST | Project.ede)
- rm -f $file
+ rm -f ${file}
;;
ChangeLog | README | AUTHORS | *NEWS | INSTALL)
- docinto $sub_directory
- dodoc $target
+ docinto ${sub_directory}
+ dodoc ${target}
;;
*.png)
- insinto /usr/share/doc/${PF}/$sub_directory
- doins $target
+ insinto /usr/share/doc/${PF}/${sub_directory}
+ doins ${target}
;;
IMPLICIT_TARGETS)
;;
*.el | *.elc)
- insinto /usr/share/emacs/site-lisp/cedet/$sub_directory
- doins $target
+ insinto /usr/share/emacs/site-lisp/cedet/${sub_directory}
+ doins ${target}
;;
*.info*)
- doinfo $target
+ doinfo ${target}
;;
*)
- insinto /usr/share/emacs/site-lisp/cedet/$sub_directory
- doins $target
- echo $target >>${S}/IMPLICIT_TARGETS
+ insinto /usr/share/emacs/site-lisp/cedet/${sub_directory}
+ doins ${target}
+ echo ${target} >>"${S}/IMPLICIT_TARGETS"
;;
esac
done
- elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
}