summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-07-21 09:40:10 +0000
committerUlrich Müller <ulm@gentoo.org>2012-07-21 09:40:10 +0000
commitb48986afcd7b66108bc3ca3d616d395e57c4281d (patch)
tree30447f4138a12d2f3723ef6cff6cc819327b5810 /app-emacs
parentmarked x86 per bug 426500 (diff)
downloadgentoo-2-b48986afcd7b66108bc3ca3d616d395e57c4281d.tar.gz
gentoo-2-b48986afcd7b66108bc3ca3d616d395e57c4281d.tar.bz2
gentoo-2-b48986afcd7b66108bc3ca3d616d395e57c4281d.zip
Version bump, dropping compatibility with baselayout-1.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/emacs-daemon/ChangeLog9
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.19.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/app-emacs/emacs-daemon/ChangeLog b/app-emacs/emacs-daemon/ChangeLog
index 532bdda227ac..a556dfe0b0a8 100644
--- a/app-emacs/emacs-daemon/ChangeLog
+++ b/app-emacs/emacs-daemon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/emacs-daemon
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/ChangeLog,v 1.48 2011/08/24 20:39:51 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/ChangeLog,v 1.49 2012/07/21 09:40:10 ulm Exp $
+
+*emacs-daemon-0.19 (21 Jul 2012)
+
+ 21 Jul 2012; Ulrich Müller <ulm@gentoo.org> +emacs-daemon-0.19.ebuild:
+ Version bump, dropping compatibility with baselayout-1.
24 Aug 2011; Ulrich Mueller <ulm@gentoo.org> emacs-daemon-0.18.ebuild:
Warn about problems in GTK+, bug 292471.
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.19.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.19.ebuild
new file mode 100644
index 000000000000..0a33beb74145
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.19.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/emacs-daemon-0.19.ebuild,v 1.1 2012/07/21 09:40:10 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/emacs-23"
+RDEPEND="${DEPEND}"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon has_gtk line
+ has_daemon=$(${EMACS} ${EMACSFLAGS} --eval "(princ (fboundp 'daemonp))")
+ has_gtk=$(${EMACS} ${EMACSFLAGS} --eval "(princ (featurep 'gtk))")
+
+ if [[ ${has_daemon} != t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs version does not support running as a daemon
+ which is required for ${CATEGORY}/${PN}.
+ Use "eselect emacs" to select an Emacs version >= 23.
+ EOF
+ elif [[ ${has_gtk} == t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs is compiled with GTK+. There is a long-standing
+ bug in GTK+ that prevents Emacs from recovering from X disconnects:
+ <http://bugzilla.gnome.org/show_bug.cgi?id=85715>
+ If you run Emacs as a daemon, then it is strongly recommended that
+ you compile it with the Lucid toolkit, i.e. with USE="Xaw3d -gtk".
+ EOF
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs || die
+ newconfd emacs.conf emacs || die
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh emacs-stop.sh || die
+ elisp-site-file-install "${SITEFILE}" || die
+ dodoc README ChangeLog || die
+}