summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-19 07:00:53 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-19 07:00:53 +0000
commitbc654dd2e4e238ec0e4c5b292c1abf66fec9885e (patch)
tree5856565f979f346995ab8bd5a6b9e9062d78692b /app-emacs
parentrevision bump 4.2.4, 4.3.2 (diff)
downloadgentoo-2-bc654dd2e4e238ec0e4c5b292c1abf66fec9885e.tar.gz
gentoo-2-bc654dd2e4e238ec0e4c5b292c1abf66fec9885e.tar.bz2
gentoo-2-bc654dd2e4e238ec0e4c5b292c1abf66fec9885e.zip
Update ebuild to EAPI 5. Update HOMEPAGE. Specify LICENSE more precisely. Install Japanese documentation only with LINGUAS=ja. Don't load w3m-wget in site-init file.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/emacs-wget/ChangeLog12
-rw-r--r--app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild27
-rw-r--r--app-emacs/emacs-wget/files/50emacs-wget-gentoo.el4
3 files changed, 41 insertions, 2 deletions
diff --git a/app-emacs/emacs-wget/ChangeLog b/app-emacs/emacs-wget/ChangeLog
index e0c53284baac..aa0aeee4f5e4 100644
--- a/app-emacs/emacs-wget/ChangeLog
+++ b/app-emacs/emacs-wget/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/emacs-wget
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-wget/ChangeLog,v 1.20 2008/08/27 13:22:34 ulm Exp $
+# Copyright 2000-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-wget/ChangeLog,v 1.21 2014/02/19 07:00:53 ulm Exp $
+
+*emacs-wget-0.5.0-r1 (19 Feb 2014)
+
+ 19 Feb 2014; Ulrich Müller <ulm@gentoo.org> +emacs-wget-0.5.0-r1.ebuild,
+ +files/50emacs-wget-gentoo.el:
+ Update ebuild to EAPI 5. Update HOMEPAGE. Specify LICENSE more precisely.
+ Install Japanese documentation only with LINGUAS=ja. Don't load w3m-wget in
+ site-init file.
27 Aug 2008; Ulrich Mueller <ulm@gentoo.org> emacs-wget-0.5.0.ebuild:
Use eclass default instead of elisp-comp, bug 235442.
diff --git a/app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild b/app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..5c0d464d6a1a
--- /dev/null
+++ b/app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild,v 1.1 2014/02/19 07:00:53 ulm Exp $
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Wget interface for Emacs"
+HOMEPAGE="http://www.emacswiki.org/emacs/EmacsWget"
+SRC_URI="http://pop-club.hp.infoseek.co.jp/emacs/emacs-wget/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="linguas_ja"
+
+RDEPEND=">=net-misc/wget-1.8.2"
+
+ELISP_REMOVE="lpath.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ dodoc ChangeLog README USAGE
+ use linguas_ja && dodoc README.ja USAGE.ja
+}
diff --git a/app-emacs/emacs-wget/files/50emacs-wget-gentoo.el b/app-emacs/emacs-wget/files/50emacs-wget-gentoo.el
new file mode 100644
index 000000000000..51afcaf6d4c1
--- /dev/null
+++ b/app-emacs/emacs-wget/files/50emacs-wget-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'wget "wget" "wget interface for Emacs." t)
+(autoload 'wget-web-page "wget" "wget interface to download whole web page." t)
+(add-hook 'w3m-mode-hook (lambda () (require 'w3m-wget)))