summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-10-29 04:42:05 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-10-29 04:42:05 +0000
commit51f66b4197813daf17cb11a2a80f06a77409cca8 (patch)
treeecd781d251adbb97ed6d9754c1f98a3a2a917c66 /app-emulation/cloud-init
parentRemove ruby18-only versions, acked by aballier. See bug #483100 (diff)
downloadgentoo-2-51f66b4197813daf17cb11a2a80f06a77409cca8.tar.gz
gentoo-2-51f66b4197813daf17cb11a2a80f06a77409cca8.tar.bz2
gentoo-2-51f66b4197813daf17cb11a2a80f06a77409cca8.zip
now installs the python module
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-emulation/cloud-init')
-rw-r--r--app-emulation/cloud-init/ChangeLog6
-rw-r--r--app-emulation/cloud-init/cloud-init-0.7.2.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/app-emulation/cloud-init/ChangeLog b/app-emulation/cloud-init/ChangeLog
index 8fb9d7b25f30..8aaa6eef1011 100644
--- a/app-emulation/cloud-init/ChangeLog
+++ b/app-emulation/cloud-init/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/cloud-init
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cloud-init/ChangeLog,v 1.1 2013/09/22 19:11:45 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cloud-init/ChangeLog,v 1.2 2013/10/29 04:42:05 prometheanfire Exp $
+
+ 29 Oct 2013; Matthew Thode <prometheanfire@gentoo.org>
+ cloud-init-0.7.2.ebuild:
+ now installs the python module
*cloud-init-0.7.2 (22 Sep 2013)
diff --git a/app-emulation/cloud-init/cloud-init-0.7.2.ebuild b/app-emulation/cloud-init/cloud-init-0.7.2.ebuild
index 5deca81d7d18..18babdf5f4c1 100644
--- a/app-emulation/cloud-init/cloud-init-0.7.2.ebuild
+++ b/app-emulation/cloud-init/cloud-init-0.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cloud-init/cloud-init-0.7.2.ebuild,v 1.1 2013/09/22 19:11:45 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cloud-init/cloud-init-0.7.2.ebuild,v 1.2 2013/10/29 04:42:05 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -11,7 +11,7 @@ DESCRIPTION="Package provides configuration and customization of cloud instance.
HOMEPAGE="https://launchpad.net/cloud-init"
SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
-LICENSE="Apache-2.0"
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
@@ -30,5 +30,6 @@ RDEPEND="dev-python/cheetah[${PYTHON_USEDEP}]
dev-python/jsonpatch[${PYTHON_USEDEP}]"
src_prepare() {
- sed -i '/exclude/d' "${S}/setup.py"
+ sed -i "s/'tests'//g" "${S}/setup.py"
+ rm -R "${S}/tests"
}