summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-21 04:04:45 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-21 04:04:45 +0000
commit1d246bcf09b9b734fd6b663c376fbfa662961a47 (patch)
tree8d516c27d74d3fdb47a9f0a5fd8ce0bc066b34d4 /app-emulation/fuse
parentinitial import (diff)
downloadgentoo-2-1d246bcf09b9b734fd6b663c376fbfa662961a47.tar.gz
gentoo-2-1d246bcf09b9b734fd6b663c376fbfa662961a47.tar.bz2
gentoo-2-1d246bcf09b9b734fd6b663c376fbfa662961a47.zip
ver bump #31215 #27711
Diffstat (limited to 'app-emulation/fuse')
-rw-r--r--app-emulation/fuse/ChangeLog7
-rw-r--r--app-emulation/fuse/files/digest-fuse-0.6.1.11
-rw-r--r--app-emulation/fuse/fuse-0.6.1.1.ebuild64
3 files changed, 71 insertions, 1 deletions
diff --git a/app-emulation/fuse/ChangeLog b/app-emulation/fuse/ChangeLog
index 35f9abd0f061..ad8fd1ab8425 100644
--- a/app-emulation/fuse/ChangeLog
+++ b/app-emulation/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/fuse
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/ChangeLog,v 1.1 2003/07/16 00:54:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/ChangeLog,v 1.2 2003/11/21 04:04:11 vapier Exp $
+
+*fuse-0.6.1.1 (20 Nov 2003)
+
+ 20 Nov 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + DEPEND fixups #31215 #27711.
*fuse-0.6.0.1 (15 Jul 2003)
diff --git a/app-emulation/fuse/files/digest-fuse-0.6.1.1 b/app-emulation/fuse/files/digest-fuse-0.6.1.1
new file mode 100644
index 000000000000..e0318a684ae7
--- /dev/null
+++ b/app-emulation/fuse/files/digest-fuse-0.6.1.1
@@ -0,0 +1 @@
+MD5 6738574d0f01f758ed352a6d3cb5f4b1 fuse-0.6.1.1.tar.gz 509597
diff --git a/app-emulation/fuse/fuse-0.6.1.1.ebuild b/app-emulation/fuse/fuse-0.6.1.1.ebuild
new file mode 100644
index 000000000000..c00cb702b4d2
--- /dev/null
+++ b/app-emulation/fuse/fuse-0.6.1.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/fuse-0.6.1.1.ebuild,v 1.1 2003/11/21 04:04:11 vapier Exp $
+
+DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
+HOMEPAGE="http://www.srcf.ucam.org/~pak21/spectrum/fuse.html"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="X svga libdsk"
+
+# This build is heavily use dependent. USE="svga" will build the svga
+# version of fuse, otherwise X will be used. Libdsk must be specified
+# in order to take advantage of +3 emulation.
+DEPEND="dev-lang/perl
+ xml2? ( dev-libs/libxml2 )
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )
+ >=app-emulation/libspectrum-0.1.0
+ || (
+ X? (
+ virtual/x11
+ || (
+ gtk2? ( =x11-libs/gtk+-2* )
+ gtk? ( =x11-libs/gtk+-1* )
+ )
+ )
+ sdl? ( media-libs/libsdl )
+ svga? ( media-libs/svgalib )
+ fbcon? ( )
+ virtual/x11
+ )
+ gnome? ( =dev-libs/glib-1* )
+ libdsk? ( app-emulation/libdsk
+ app-emulation/lib765 )"
+
+src_compile() {
+ local guiflag
+ if [ `use X` ] ; then
+ guiflag="--with-x"
+ elif [ `use sdl` ] ; then
+ guiflag="--without-x --with-sdl"
+ elif [ `use svga` ] ; then
+ guiflag="--without-x --with-svgalib"
+ elif [ `use fbcon` ] ; then
+ guiflag="--without-x --with-fb"
+ else
+ guiflag="--with-x"
+ fi
+ econf \
+ `use_with gnome glib` \
+ `use_with gtk` \
+ `use_with gtk2` \
+ `use_with libdsk plus3-disk` \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ dodoc AUTHORS README THANKS hacking/*.txt
+}